aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-native_2.6.4.bb
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2010-01-28 12:51:22 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2010-02-01 18:44:27 +0100
commit4d0023adf6b1f76028b40d9edf313f94c831cc90 (patch)
tree9b44090ee68f6a88a8c8e3b1e84c09a44a74287e /recipes/python/python-native_2.6.4.bb
parent506f7841f89c8cd735fdc864c3da8d9601f9ca08 (diff)
downloadopenembedded-4d0023adf6b1f76028b40d9edf313f94c831cc90.tar.gz
python: add version 2.6.4
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Michael 'Mickey' Lauer <mickey@vanille-media.de>
Diffstat (limited to 'recipes/python/python-native_2.6.4.bb')
-rw-r--r--recipes/python/python-native_2.6.4.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/python/python-native_2.6.4.bb b/recipes/python/python-native_2.6.4.bb
new file mode 100644
index 0000000000..ca65057395
--- /dev/null
+++ b/recipes/python/python-native_2.6.4.bb
@@ -0,0 +1,33 @@
+require python.inc
+DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native"
+PR = "${INC_PR}.2"
+
+SRC_URI = "\
+ http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2;name=archive \
+ file://00-fix-bindir-libdir-for-cross.patch;patch=1 \
+ file://04-default-is-optimized.patch;patch=1 \
+ file://05-enable-ctypes-cross-build.patch;patch=1 \
+ file://10-distutils-fix-swig-parameter.patch;patch=1 \
+ file://11-distutils-never-modify-shebang-line.patch;patch=1 \
+ file://12-distutils-prefix-is-inside-staging-area.patch;patch=1 \
+ file://debug.patch;patch=1 \
+ file://nohostlibs.patch;patch=1 \
+"
+S = "${WORKDIR}/Python-${PV}"
+
+SRC_URI[archive.md5sum] = "fee5408634a54e721a93531aba37f8c1"
+SRC_URI[archive.sha256sum] = "dad8d5575144a210d5cc4fdbc40b8a26386e9cdb1ef58941bec0be02c7cb9d89"
+
+inherit native
+
+EXTRA_OEMAKE = '\
+ BUILD_SYS="" \
+ HOST_SYS="" \
+ LIBC="" \
+ STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
+ STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
+'
+
+do_stage_append() {
+ install -m 0755 Parser/pgen ${STAGING_BINDIR_NATIVE}/pgen
+}