aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-pygtk-1.2_0.6.12.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/python/python-pygtk-1.2_0.6.12.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/python/python-pygtk-1.2_0.6.12.bb')
-rw-r--r--recipes/python/python-pygtk-1.2_0.6.12.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/python/python-pygtk-1.2_0.6.12.bb b/recipes/python/python-pygtk-1.2_0.6.12.bb
new file mode 100644
index 0000000000..0b153ce1e5
--- /dev/null
+++ b/recipes/python/python-pygtk-1.2_0.6.12.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Python Bindings for GTK+ 1.2"
+HOMEPAGE = "http://www.gtk.org"
+SECTION = "devel/python"
+LICENSE = "LGPL"
+DEPENDS = "gtk+-1.2"
+RDEPENDS = "python-shell python-re"
+SRCNAME = "pygtk"
+PR = "r3"
+
+SRC_URI = "ftp://ftp.gtk.org/pub/gtk/python/v1.2/${SRCNAME}-${PV}.tar.gz \
+ file://remove-imlib-et-al.patch;patch=1 \
+ file://acinclude.m4"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit autotools_stage pkgconfig distutils-base
+
+EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
+ echo ${LDFLAGS} > /tmp/ldflags
+ rm -f aclocal.m4
+}
+
+FILES_${PN}-dev += "${datadir}/pygtk"