aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-10-13 07:18:03 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-10-13 15:13:02 +0200
commit917c5db519263cd30bb5522365dc72aa1606fcc5 (patch)
tree0dc3757461f5cdacb7c3ad6f4ec3e8809fca5398 /recipes/python
parent6620f48c6198c65e6c2c49d732ef4c5f4d9179a1 (diff)
downloadopenembedded-917c5db519263cd30bb5522365dc72aa1606fcc5.tar.gz
python-setuptools: add newer version 06c11
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-setuptools_0.6c11.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/python/python-setuptools_0.6c11.bb b/recipes/python/python-setuptools_0.6c11.bb
new file mode 100644
index 0000000000..bede20377d
--- /dev/null
+++ b/recipes/python/python-setuptools_0.6c11.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Download, build, install, upgrade, and uninstall Python packages"
+HOMEPAGE = "http://cheeseshop.python.org/pypi/setuptools"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "MIT"
+SRCNAME = "setuptools"
+PR = "ml2"
+DEPENDS += "python"
+DEPENDS_virtclass-native += "python-native"
+
+SRC_URI = "\
+ http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz\
+"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_install_prepend() {
+ install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
+}
+
+RDEPENDS_${PN} = "\
+ python-distutils \
+ python-compression \
+"
+
+SRC_URI[md5sum] = "7df2a529a074f613b509fb44feefe74e"
+SRC_URI[sha256sum] = "630fea9b726320b73ee3ca6ff61732cb32675b0389be658080fe46383b87a1d3"
+
+BBCLASSEXTEND = "native"
+
+NATIVE_INSTALL_WORKS = "1"