aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorFahad Usman <fahad_usman@mentor.com>2010-09-24 05:24:25 +0000
committerKhem Raj <raj.khem@gmail.com>2010-09-27 16:52:39 -0700
commit073f3eb34b6cc28c54e79b9113376324e433ba50 (patch)
tree7d4be309e7352f709e2f6fb02b4c33fca51cdb36 /recipes/python
parente701b369d20e645e9126aeb2c23c929f48cf9374 (diff)
downloadopenembedded-073f3eb34b6cc28c54e79b9113376324e433ba50.tar.gz
python-epydoc_3.0.1.bb: merged native and non-native recipes
* removed the python-epydoc-native_3.0.1.bb file * added DEPENDS_pn-python-epydoc-native = "python-native" and added DEPENDS_pn-python-epydoc = "python" * added BBCLASSEXTEND = "native" * added NATIVE_INSTALL_WORKS = "1" * bunped PR Signed-off-by: Fahad Usman <fahad_usman@mentor.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-epydoc-native_3.0.1.bb11
-rw-r--r--recipes/python/python-epydoc_3.0.1.bb8
2 files changed, 7 insertions, 12 deletions
diff --git a/recipes/python/python-epydoc-native_3.0.1.bb b/recipes/python/python-epydoc-native_3.0.1.bb
deleted file mode 100644
index c9d6813853..0000000000
--- a/recipes/python/python-epydoc-native_3.0.1.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-require python-epydoc_${PV}.bb
-DEPENDS = "python-native"
-inherit native
-
-do_stage() {
- distutils_stage_all
-}
-
-
-SRC_URI[md5sum] = "cdd6f6c76dd8bab5e653a343a0544294"
-SRC_URI[sha256sum] = "d4e5c8d90937d01b05170f592c1fa9b29e9ed0498dfe7f0eb2a3af61725b6ad1"
diff --git a/recipes/python/python-epydoc_3.0.1.bb b/recipes/python/python-epydoc_3.0.1.bb
index a2b66e3062..6a2e5910a9 100644
--- a/recipes/python/python-epydoc_3.0.1.bb
+++ b/recipes/python/python-epydoc_3.0.1.bb
@@ -4,7 +4,9 @@ PRIORITY = "optional"
LICENSE = "MIT"
HOMEPAGE = "http://epydoc.sourceforge.net/"
SRCNAME = "epydoc"
-DEPENDS = "python"
+DEPENDS_pn-python-epydoc = "python"
+DEPENDS_pn-python-epydoc-native = "python-native"
+PR = "r1"
SRC_URI = "http://downloads.sourceforge.net/project/${SRCNAME}/${SRCNAME}/${PV}/${SRCNAME}-${PV}.tar.gz"
S = "${WORKDIR}/${SRCNAME}-${PV}"
@@ -13,3 +15,7 @@ inherit distutils
SRC_URI[md5sum] = "cdd6f6c76dd8bab5e653a343a0544294"
SRC_URI[sha256sum] = "d4e5c8d90937d01b05170f592c1fa9b29e9ed0498dfe7f0eb2a3af61725b6ad1"
+
+BBCLASSEXTEND = "native"
+
+NATIVE_INSTALL_WORKS = "1"