aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorEric BENARD <eric@eukrea.com>2010-09-14 09:39:33 +0000
committerEric Bénard <eric@eukrea.com>2010-09-14 21:55:09 +0200
commit203eb8601efb01177e26ede374f315c5eaed990c (patch)
tree8b6e4d22c25e3af3c49e239f7a6df06994b903e1 /recipes/python
parente6094c0b001107649d6105751df2c00c5cdba2d9 (diff)
downloadopenembedded-203eb8601efb01177e26ede374f315c5eaed990c.tar.gz
python-native: configure unicode to ucs4
* while trying to run gdb from an SDK created by OE, I got the following errors: /usr/local/angstrom/arm/bin/arm-angstrom-linux-gnueabi-gdb: undefined symbol: PyUnicodeUCS2_FromEncodedObject * the reason is that the workstation (ubuntu 10.04 or 9.01)'s Python is compiled using ucs4 and the python-native used to create arm-angstrom-linux-gnueabi-gdb is using ucs2, the problem is detailed here : http://docs.python.org/faq/extending#when-importing-module-x-why-do-i-get-undefined-symbol-pyunicodeucs2 * configuring python-native with ucs=4 solves this problem. Signed-off-by: Eric Bénard <eric@eukrea.com> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-native_2.6.5.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes/python/python-native_2.6.5.bb b/recipes/python/python-native_2.6.5.bb
index 66573e9bfd..999335cd65 100644
--- a/recipes/python/python-native_2.6.5.bb
+++ b/recipes/python/python-native_2.6.5.bb
@@ -20,6 +20,10 @@ S = "${WORKDIR}/Python-${PV}"
inherit native
+EXTRA_OECONF_append = '\
+ --enable-unicode=ucs4 \
+'
+
EXTRA_OEMAKE = '\
BUILD_SYS="" \
HOST_SYS="" \