aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-09-21 14:41:05 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-09-23 11:00:28 +0200
commit6caf7a47277016fa8ed52bad90911b46c7af0be8 (patch)
tree58bf01193c037ef6595af50a7d605284d145a805 /recipes/python
parentfe16dc2f97b75bf68fb0dfe5df27a87657e240af (diff)
downloadopenembedded-6caf7a47277016fa8ed52bad90911b46c7af0be8.tar.gz
python-cython: upgrade to 0.13, drop legacy staging, use BBCLASSEXTEND for native
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-cython-native_0.12.1.bb10
-rw-r--r--recipes/python/python-cython_0.13.bb (renamed from recipes/python/python-cython_0.12.1.bb)9
2 files changed, 5 insertions, 14 deletions
diff --git a/recipes/python/python-cython-native_0.12.1.bb b/recipes/python/python-cython-native_0.12.1.bb
deleted file mode 100644
index d42d1fdd7b..0000000000
--- a/recipes/python/python-cython-native_0.12.1.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-require python-cython_${PV}.bb
-inherit native
-DEPENDS = "python-native"
-RDEPENDS_${PN} = ""
-
-do_stage() {
- PYTHONPATH=${STAGING_BINDIR} BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
- STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \
- ${STAGING_BINDIR}/python setup.py install --prefix=${STAGING_BINDIR}/.. --install-data=${STAGING_DATADIR}
-}
diff --git a/recipes/python/python-cython_0.12.1.bb b/recipes/python/python-cython_0.13.bb
index b3e9d8b811..61ad71887d 100644
--- a/recipes/python/python-cython_0.12.1.bb
+++ b/recipes/python/python-cython_0.13.bb
@@ -5,12 +5,13 @@ SECTION = "devel/python"
PRIORITY = "optional"
LICENSE = "GPL"
SRCNAME = "Cython"
-PR = "ml0"
+BBCLASSEXTEND = "native"
+NATIVE_INSTALL_WORKS = "1"
-SRC_URI = "http://www.cython.org/release/${SRCNAME}-${PV}.tar.gz;name=archive"
+SRC_URI = "http://www.cython.org/release/${SRCNAME}-${PV}.tar.gz"
S = "${WORKDIR}/${SRCNAME}-${PV}"
-SRC_URI[archive.md5sum] = "cf9f98e982258f8516620277975016f3"
-SRC_URI[archive.sha256sum] = "0f384ec20c579b80d1960a5795d6517a6885305efa9964bcbf6a7b8da88b9c77"
+SRC_URI[md5sum] = "ed2ec5e0df60a6b8e500bedf93bb1feb"
+SRC_URI[sha256sum] = "a30d5e26c82ec65d65703c7cf312161a21b30339addc1a42d3b2965dea254ca6"
inherit distutils