aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-24 13:01:00 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:54:52 -0700
commit6fe7cef27069415f2eba36bc640cf59013d4979b (patch)
treeb0cb8845ddc6b8bcffc50e08a2eeae98e049be98 /recipes/python
parentbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (diff)
downloadopenembedded-6fe7cef27069415f2eba36bc640cf59013d4979b.tar.gz
Make the do_patch apply=yes param implicit if extension is .diff/.patch
For .diff/.patch you need to apply manually, you can specify apply=no. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-edje_svn.bb2
-rw-r--r--recipes/python/python-gst_0.10.10.bb4
-rw-r--r--recipes/python/python-gst_0.10.17.bb4
-rw-r--r--recipes/python/python-imaging_1.1.6.bb2
-rw-r--r--recipes/python/python-ldap_2.3.9.bb2
-rw-r--r--recipes/python/python-m2crypto_0.18.2.bb2
-rw-r--r--recipes/python/python-mysqldb_1.2.1.bb4
-rw-r--r--recipes/python/python-native_2.6.1.bb16
-rw-r--r--recipes/python/python-native_2.6.4.bb18
-rw-r--r--recipes/python/python-numeric_23.7.bb2
-rw-r--r--recipes/python/python-numpy_1.1.1.bb4
-rw-r--r--recipes/python/python-pycairo_1.4.0.bb2
-rw-r--r--recipes/python/python-pycairo_1.8.0.bb2
-rw-r--r--recipes/python/python-pycodes_1.2.bb2
-rw-r--r--recipes/python/python-pycurl_7.18.2.bb2
-rw-r--r--recipes/python/python-pycurl_7.19.0.bb2
-rw-r--r--recipes/python/python-pygobject-native_2.14.2.bb2
-rw-r--r--recipes/python/python-pygobject-native_2.16.0.bb2
-rw-r--r--recipes/python/python-pygobject-native_2.20.0.bb2
-rw-r--r--recipes/python/python-pygobject_2.14.2.bb4
-rw-r--r--recipes/python/python-pygobject_2.16.0.bb2
-rw-r--r--recipes/python/python-pygobject_2.20.0.bb2
-rw-r--r--recipes/python/python-pygtk-1.2_0.6.12.bb2
-rw-r--r--recipes/python/python-pygtk_2.10.4.bb8
-rw-r--r--recipes/python/python-pygtk_2.16.0.bb2
-rw-r--r--recipes/python/python-pyid3lib_0.5.1.bb2
-rw-r--r--recipes/python/python-pylinda_0.6.bb2
-rw-r--r--recipes/python/python-pyode_1.2.0.bb2
-rw-r--r--recipes/python/python-pyqt_4.4.3.bb4
-rw-r--r--recipes/python/python-pyrex_0.9.8.5.bb2
-rw-r--r--recipes/python/python-pyro_3.8.1.bb2
-rw-r--r--recipes/python/python-pysqlite2_2.4.0.bb2
-rw-r--r--recipes/python/python-setuptools_0.6c9.bb2
-rw-r--r--recipes/python/python-soappy_0.11.6.bb2
-rw-r--r--recipes/python/python-traits_3.0.3.bb2
-rw-r--r--recipes/python/python-twisted_2.5.0.bb2
-rw-r--r--recipes/python/python-vorbis_1.4.bb2
-rw-r--r--recipes/python/python_2.6.1.bb26
-rw-r--r--recipes/python/python_2.6.2.bb22
-rw-r--r--recipes/python/python_2.6.4.bb24
40 files changed, 97 insertions, 97 deletions
diff --git a/recipes/python/python-edje_svn.bb b/recipes/python/python-edje_svn.bb
index 0e29de183d..793db0c437 100644
--- a/recipes/python/python-edje_svn.bb
+++ b/recipes/python/python-edje_svn.bb
@@ -3,4 +3,4 @@ SRCREV = "${EFL_SRCREV}"
DEPENDS += "edje python-evas"
RDEPENDS += "python-evas"
-SRC_URI += "file://0001-fix-unicode-conversion.patch;apply=yes"
+SRC_URI += "file://0001-fix-unicode-conversion.patch"
diff --git a/recipes/python/python-gst_0.10.10.bb b/recipes/python/python-gst_0.10.10.bb
index d060b92949..d56c201064 100644
--- a/recipes/python/python-gst_0.10.10.bb
+++ b/recipes/python/python-gst_0.10.10.bb
@@ -6,8 +6,8 @@ PR = "ml4"
SRC_URI = "\
http://gstreamer.freedesktop.org/src/gst-python/gst-python-${PV}.tar.bz2 \
- file://python-path.patch;apply=yes \
- file://import-gobject-instead-of-pygtk.patch;apply=yes \
+ file://python-path.patch \
+ file://import-gobject-instead-of-pygtk.patch \
"
S = "${WORKDIR}/gst-python-${PV}"
diff --git a/recipes/python/python-gst_0.10.17.bb b/recipes/python/python-gst_0.10.17.bb
index 6aa13f258f..622da92c57 100644
--- a/recipes/python/python-gst_0.10.17.bb
+++ b/recipes/python/python-gst_0.10.17.bb
@@ -7,8 +7,8 @@ PR = "r1"
SRC_URI = "\
http://gstreamer.freedesktop.org/src/gst-python/gst-python-${PV}.tar.bz2 \
- file://python-path.patch;apply=yes \
- file://import-gobject-instead-of-pygtk.patch;apply=yes \
+ file://python-path.patch \
+ file://import-gobject-instead-of-pygtk.patch \
"
S = "${WORKDIR}/gst-python-${PV}"
diff --git a/recipes/python/python-imaging_1.1.6.bb b/recipes/python/python-imaging_1.1.6.bb
index 4929c7779f..cf8f348edf 100644
--- a/recipes/python/python-imaging_1.1.6.bb
+++ b/recipes/python/python-imaging_1.1.6.bb
@@ -8,7 +8,7 @@ SRCNAME = "Imaging"
PR = "ml1"
SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \
- file://path.patch;apply=yes"
+ file://path.patch"
S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils
diff --git a/recipes/python/python-ldap_2.3.9.bb b/recipes/python/python-ldap_2.3.9.bb
index ea1fd7a6ce..f7f3cbe94e 100644
--- a/recipes/python/python-ldap_2.3.9.bb
+++ b/recipes/python/python-ldap_2.3.9.bb
@@ -6,7 +6,7 @@ HOMEPAGE = "http://www.python-ldap.org/"
DEPENDS = "python openldap"
SRC_URI = "http://pypi.python.org/packages/source/p/${PN}/${PN}-${PV}.tar.gz \
- file://setup.cfg.patch;apply=yes"
+ file://setup.cfg.patch"
inherit setuptools
diff --git a/recipes/python/python-m2crypto_0.18.2.bb b/recipes/python/python-m2crypto_0.18.2.bb
index 30717abe6f..84e870d8e4 100644
--- a/recipes/python/python-m2crypto_0.18.2.bb
+++ b/recipes/python/python-m2crypto_0.18.2.bb
@@ -8,7 +8,7 @@ PR = "ml1"
SRC_URI = "\
http://chandlerproject.org/pub/Projects/MeTooCrypto/m2crypto-${PV}.tar.gz \
- file://install.patch;apply=yes \
+ file://install.patch \
"
S = "${WORKDIR}/m2crypto-0.18.2"
diff --git a/recipes/python/python-mysqldb_1.2.1.bb b/recipes/python/python-mysqldb_1.2.1.bb
index 1722d18579..ca5e217401 100644
--- a/recipes/python/python-mysqldb_1.2.1.bb
+++ b/recipes/python/python-mysqldb_1.2.1.bb
@@ -9,8 +9,8 @@ inherit distutils
SRC_URI = "\
${SOURCEFORGE_MIRROR}/mysql-python/MySQL-python-${PV}_p2.tar.gz \
- file://mysqlpath.patch;apply=yes \
- file://site.patch;apply=yes \
+ file://mysqlpath.patch \
+ file://site.patch \
"
S = "${WORKDIR}/${SRCNAME}-${PV}_p2"
diff --git a/recipes/python/python-native_2.6.1.bb b/recipes/python/python-native_2.6.1.bb
index 12c622ba10..44da281d62 100644
--- a/recipes/python/python-native_2.6.1.bb
+++ b/recipes/python/python-native_2.6.1.bb
@@ -4,14 +4,14 @@ PR = "${INC_PR}.2"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
- file://00-fix-bindir-libdir-for-cross.patch;apply=yes \
- file://04-default-is-optimized.patch;apply=yes \
- file://05-enable-ctypes-cross-build.patch;apply=yes \
- file://10-distutils-fix-swig-parameter.patch;apply=yes \
- file://11-distutils-never-modify-shebang-line.patch;apply=yes \
- file://12-distutils-prefix-is-inside-staging-area.patch;apply=yes \
- file://debug.patch;apply=yes \
- file://nohostlibs.patch;apply=yes \
+ file://00-fix-bindir-libdir-for-cross.patch \
+ file://04-default-is-optimized.patch \
+ file://05-enable-ctypes-cross-build.patch \
+ file://10-distutils-fix-swig-parameter.patch \
+ file://11-distutils-never-modify-shebang-line.patch \
+ file://12-distutils-prefix-is-inside-staging-area.patch \
+ file://debug.patch \
+ file://nohostlibs.patch \
"
S = "${WORKDIR}/Python-${PV}"
diff --git a/recipes/python/python-native_2.6.4.bb b/recipes/python/python-native_2.6.4.bb
index 9c8ce54d6f..4205312978 100644
--- a/recipes/python/python-native_2.6.4.bb
+++ b/recipes/python/python-native_2.6.4.bb
@@ -4,15 +4,15 @@ PR = "${INC_PR}.3"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2;name=archive \
- file://00-fix-bindir-libdir-for-cross.patch;apply=yes \
- file://04-default-is-optimized.patch;apply=yes \
- file://05-enable-ctypes-cross-build.patch;apply=yes \
- file://06-ctypes-libffi-fix-configure.patch;apply=yes \
- file://10-distutils-fix-swig-parameter.patch;apply=yes \
- file://11-distutils-never-modify-shebang-line.patch;apply=yes \
- file://12-distutils-prefix-is-inside-staging-area.patch;apply=yes \
- file://debug.patch;apply=yes \
- file://nohostlibs.patch;apply=yes \
+ file://00-fix-bindir-libdir-for-cross.patch \
+ file://04-default-is-optimized.patch \
+ file://05-enable-ctypes-cross-build.patch \
+ file://06-ctypes-libffi-fix-configure.patch \
+ file://10-distutils-fix-swig-parameter.patch \
+ file://11-distutils-never-modify-shebang-line.patch \
+ file://12-distutils-prefix-is-inside-staging-area.patch \
+ file://debug.patch \
+ file://nohostlibs.patch \
"
S = "${WORKDIR}/Python-${PV}"
diff --git a/recipes/python/python-numeric_23.7.bb b/recipes/python/python-numeric_23.7.bb
index 86c0f14f24..a49e0e156b 100644
--- a/recipes/python/python-numeric_23.7.bb
+++ b/recipes/python/python-numeric_23.7.bb
@@ -5,7 +5,7 @@ LICENSE = "PSF"
PR = "ml1"
SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/Numeric-${PV}.tar.gz \
- file://no-lapack.patch;apply=yes"
+ file://no-lapack.patch"
S = "${WORKDIR}/Numeric-${PV}"
inherit distutils
diff --git a/recipes/python/python-numpy_1.1.1.bb b/recipes/python/python-numpy_1.1.1.bb
index 97a881244d..f5c23e055f 100644
--- a/recipes/python/python-numpy_1.1.1.bb
+++ b/recipes/python/python-numpy_1.1.1.bb
@@ -5,8 +5,8 @@ LICENSE = "PSF"
PR = "ml0"
SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \
- file://unbreak-assumptions.diff;apply=yes \
- file://trycompile.diff;apply=yes \
+ file://unbreak-assumptions.diff \
+ file://trycompile.diff \
file://config.h \
file://numpyconfig.h \
"
diff --git a/recipes/python/python-pycairo_1.4.0.bb b/recipes/python/python-pycairo_1.4.0.bb
index be2a7cdb9b..94bb3380e4 100644
--- a/recipes/python/python-pycairo_1.4.0.bb
+++ b/recipes/python/python-pycairo_1.4.0.bb
@@ -6,7 +6,7 @@ DEPENDS = "cairo"
PR = "ml3"
SRC_URI = "http://cairographics.org/releases/pycairo-${PV}.tar.gz \
- file://fix-setup-py.patch;apply=yes"
+ file://fix-setup-py.patch"
S = "${WORKDIR}/pycairo-${PV}"
inherit distutils pkgconfig
diff --git a/recipes/python/python-pycairo_1.8.0.bb b/recipes/python/python-pycairo_1.8.0.bb
index cbdade84ea..6437c373d1 100644
--- a/recipes/python/python-pycairo_1.8.0.bb
+++ b/recipes/python/python-pycairo_1.8.0.bb
@@ -9,7 +9,7 @@ PR = "ml0"
DEFAULT_PREFERENCE = "-1"
SRC_URI = "http://cairographics.org/releases/pycairo-${PV}.tar.gz \
- file://fix-setup-py.patch;apply=yes"
+ file://fix-setup-py.patch"
S = "${WORKDIR}/pycairo-${PV}"
inherit distutils pkgconfig
diff --git a/recipes/python/python-pycodes_1.2.bb b/recipes/python/python-pycodes_1.2.bb
index 6ebd632086..fa260422ec 100644
--- a/recipes/python/python-pycodes_1.2.bb
+++ b/recipes/python/python-pycodes_1.2.bb
@@ -8,7 +8,7 @@ SRCNAME = "pycodes"
PR = "ml1"
SRC_URI = "http://web.mit.edu/~emin/www/source_code/pycodes/pycodes-1-2.tar.gz \
- file://no-docs.patch;apply=yes"
+ file://no-docs.patch"
S = "${WORKDIR}/${SRCNAME}"
inherit distutils
diff --git a/recipes/python/python-pycurl_7.18.2.bb b/recipes/python/python-pycurl_7.18.2.bb
index c319e6d298..c66e94cbe9 100644
--- a/recipes/python/python-pycurl_7.18.2.bb
+++ b/recipes/python/python-pycurl_7.18.2.bb
@@ -8,7 +8,7 @@ PR = "ml2"
SRC_URI = "\
http://${SRCNAME}.sourceforge.net/download/${SRCNAME}-${PV}.tar.gz \
- file://no-static-link.patch;apply=yes \
+ file://no-static-link.patch \
"
S = "${WORKDIR}/${SRCNAME}-${PV}"
diff --git a/recipes/python/python-pycurl_7.19.0.bb b/recipes/python/python-pycurl_7.19.0.bb
index 73da6daf63..3551b32b28 100644
--- a/recipes/python/python-pycurl_7.19.0.bb
+++ b/recipes/python/python-pycurl_7.19.0.bb
@@ -8,7 +8,7 @@ PR = "ml2"
SRC_URI = "\
http://${SRCNAME}.sourceforge.net/download/${SRCNAME}-${PV}.tar.gz;name=archive \
- file://no-static-link.patch;apply=yes \
+ file://no-static-link.patch \
"
S = "${WORKDIR}/${SRCNAME}-${PV}"
SRC_URI[archive.md5sum] = "919d58fe37e69fe87ce4534d8b6a1c7b"
diff --git a/recipes/python/python-pygobject-native_2.14.2.bb b/recipes/python/python-pygobject-native_2.14.2.bb
index eb58153299..2853a55723 100644
--- a/recipes/python/python-pygobject-native_2.14.2.bb
+++ b/recipes/python/python-pygobject-native_2.14.2.bb
@@ -7,7 +7,7 @@ inherit native
SRC_URI = "\
ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
- file://python-path.patch;apply=yes \
+ file://python-path.patch \
"
do_stage_append() {
diff --git a/recipes/python/python-pygobject-native_2.16.0.bb b/recipes/python/python-pygobject-native_2.16.0.bb
index 5f38091d9b..27d5adbd8e 100644
--- a/recipes/python/python-pygobject-native_2.16.0.bb
+++ b/recipes/python/python-pygobject-native_2.16.0.bb
@@ -9,7 +9,7 @@ inherit native
SRC_URI = "\
ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
-# file://python-path.patch;apply=yes \
+# file://python-path.patch \
"
do_stage_append() {
diff --git a/recipes/python/python-pygobject-native_2.20.0.bb b/recipes/python/python-pygobject-native_2.20.0.bb
index 6e422b5aec..02ff86e3fc 100644
--- a/recipes/python/python-pygobject-native_2.20.0.bb
+++ b/recipes/python/python-pygobject-native_2.20.0.bb
@@ -8,7 +8,7 @@ PARALLEL_MAKE = ""
SRC_URI = "\
ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
-# file://python-path.patch;apply=yes \
+# file://python-path.patch \
"
export GOBJECT_INTROSPECTION_CFLAGS="-pthread -I${STAGING_INCDIR}/gobject-introspection-1.0 -I${STAGING_INCDIR}/glib-2.0 -I${STAGING_LIBDIR}/glib-2.0/include"
diff --git a/recipes/python/python-pygobject_2.14.2.bb b/recipes/python/python-pygobject_2.14.2.bb
index d049037cdb..155c5d99d3 100644
--- a/recipes/python/python-pygobject_2.14.2.bb
+++ b/recipes/python/python-pygobject_2.14.2.bb
@@ -9,8 +9,8 @@ MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1
SRC_URI = "\
ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
- file://python-path.patch;apply=yes \
- file://generate-constants.patch;apply=yes \
+ file://python-path.patch \
+ file://generate-constants.patch \
"
S = "${WORKDIR}/pygobject-${PV}"
diff --git a/recipes/python/python-pygobject_2.16.0.bb b/recipes/python/python-pygobject_2.16.0.bb
index 4febf4cb12..fc920c72b1 100644
--- a/recipes/python/python-pygobject_2.16.0.bb
+++ b/recipes/python/python-pygobject_2.16.0.bb
@@ -9,7 +9,7 @@ MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1
SRC_URI = "\
ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
- file://generate-constants.patch;apply=yes \
+ file://generate-constants.patch \
"
S = "${WORKDIR}/pygobject-${PV}"
diff --git a/recipes/python/python-pygobject_2.20.0.bb b/recipes/python/python-pygobject_2.20.0.bb
index 139e0b0310..f8d4bf0659 100644
--- a/recipes/python/python-pygobject_2.20.0.bb
+++ b/recipes/python/python-pygobject_2.20.0.bb
@@ -10,7 +10,7 @@ MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1
SRC_URI = "\
ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
- file://generate-constants.patch;apply=yes \
+ file://generate-constants.patch \
"
S = "${WORKDIR}/pygobject-${PV}"
diff --git a/recipes/python/python-pygtk-1.2_0.6.12.bb b/recipes/python/python-pygtk-1.2_0.6.12.bb
index b58845070c..f8dcdd0bd9 100644
--- a/recipes/python/python-pygtk-1.2_0.6.12.bb
+++ b/recipes/python/python-pygtk-1.2_0.6.12.bb
@@ -8,7 +8,7 @@ SRCNAME = "pygtk"
PR = "r3"
SRC_URI = "ftp://ftp.gtk.org/pub/gtk/python/v1.2/${SRCNAME}-${PV}.tar.gz \
- file://remove-imlib-et-al.patch;apply=yes \
+ file://remove-imlib-et-al.patch \
file://acinclude.m4"
S = "${WORKDIR}/${SRCNAME}-${PV}"
diff --git a/recipes/python/python-pygtk_2.10.4.bb b/recipes/python/python-pygtk_2.10.4.bb
index e37646d1bd..daf854cfa5 100644
--- a/recipes/python/python-pygtk_2.10.4.bb
+++ b/recipes/python/python-pygtk_2.10.4.bb
@@ -10,10 +10,10 @@ PR = "ml12"
MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/${MAJ_VER}/${SRCNAME}-${PV}.tar.bz2 \
- file://fix-gtkunixprint.patch;apply=yes \
- file://prevent_to_get_display_during_import.patch;apply=yes \
- file://nodocs.patch;apply=yes \
- file://gdk_display.patch;apply=yes;striplevel=0 \
+ file://fix-gtkunixprint.patch \
+ file://prevent_to_get_display_during_import.patch \
+ file://nodocs.patch \
+ file://gdk_display.patch;striplevel=0 \
file://acinclude.m4"
S = "${WORKDIR}/${SRCNAME}-${PV}"
diff --git a/recipes/python/python-pygtk_2.16.0.bb b/recipes/python/python-pygtk_2.16.0.bb
index 5522c1a3bc..eaea9af4bb 100644
--- a/recipes/python/python-pygtk_2.16.0.bb
+++ b/recipes/python/python-pygtk_2.16.0.bb
@@ -10,7 +10,7 @@ PR = "r1"
MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/${MAJ_VER}/${SRCNAME}-${PV}.tar.bz2;name=pygtk \
- file://fix-gtkunixprint.patch;apply=yes \
+ file://fix-gtkunixprint.patch \
file://acinclude.m4"
S = "${WORKDIR}/${SRCNAME}-${PV}"
diff --git a/recipes/python/python-pyid3lib_0.5.1.bb b/recipes/python/python-pyid3lib_0.5.1.bb
index 19d9bf810c..3a3e7bb274 100644
--- a/recipes/python/python-pyid3lib_0.5.1.bb
+++ b/recipes/python/python-pyid3lib_0.5.1.bb
@@ -8,7 +8,7 @@ PR = "r2"
SRC_URI = "\
${SOURCEFORGE_MIRROR}/pyid3lib/${SRCNAME}-${PV}.tar.bz2\
- file://gcc4-fix.patch;apply=yes \
+ file://gcc4-fix.patch \
"
S = "${WORKDIR}/${SRCNAME}-${PV}"
diff --git a/recipes/python/python-pylinda_0.6.bb b/recipes/python/python-pylinda_0.6.bb
index 05e8a05a09..a0dac36f25 100644
--- a/recipes/python/python-pylinda_0.6.bb
+++ b/recipes/python/python-pylinda_0.6.bb
@@ -7,7 +7,7 @@ SRCNAME = "linda"
PR = "r1"
SRC_URI = "http://www.handhelds.org/~aquadran/distro/latest/sources/linda-${PV}.tar.gz \
- file://honor-datadir.patch;apply=yes"
+ file://honor-datadir.patch"
S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils
diff --git a/recipes/python/python-pyode_1.2.0.bb b/recipes/python/python-pyode_1.2.0.bb
index 702acd79b6..3b00de84d3 100644
--- a/recipes/python/python-pyode_1.2.0.bb
+++ b/recipes/python/python-pyode_1.2.0.bb
@@ -8,7 +8,7 @@ SRCNAME = "PyODE"
PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/pyode/${SRCNAME}-${PV}.tar.bz2 \
- file://install.patch;apply=yes"
+ file://install.patch"
S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils
diff --git a/recipes/python/python-pyqt_4.4.3.bb b/recipes/python/python-pyqt_4.4.3.bb
index d2970764a1..a0003aa95e 100644
--- a/recipes/python/python-pyqt_4.4.3.bb
+++ b/recipes/python/python-pyqt_4.4.3.bb
@@ -13,11 +13,11 @@ PYQT_OE_VERSION = "Qt_4_4_1"
SRC_URI = "\
http://cvs.fedora.redhat.com/repo/pkgs/PyQt4/PyQt-x11-gpl-4.4.3.tar.gz/89e84c36a8520bf8b3a8a2b20e765154/PyQt-x11-gpl-4.4.3.tar.gz \
- file://cross-compile.patch;apply=yes \
+ file://cross-compile.patch \
file://01_configure.dpatch;apply=yes \
file://02_htmllinks.dpatch;apply=yes \
\
- file://assistantclient-fix.patch;apply=yes \
+ file://assistantclient-fix.patch \
"
S = "${WORKDIR}/PyQt-x11-gpl-${PV}"
diff --git a/recipes/python/python-pyrex_0.9.8.5.bb b/recipes/python/python-pyrex_0.9.8.5.bb
index 2d98c90ce7..c354b11839 100644
--- a/recipes/python/python-pyrex_0.9.8.5.bb
+++ b/recipes/python/python-pyrex_0.9.8.5.bb
@@ -9,7 +9,7 @@ PR = "ml1"
SRC_URI = "\
http://www.cosc.canterbury.ac.nz/greg.ewing/python/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
- file://pyrex-fix-optimized-mode.patch;apply=yes \
+ file://pyrex-fix-optimized-mode.patch \
"
S = "${WORKDIR}/${SRCNAME}-${PV}"
diff --git a/recipes/python/python-pyro_3.8.1.bb b/recipes/python/python-pyro_3.8.1.bb
index 41d2c1abb9..a36fe9b64f 100644
--- a/recipes/python/python-pyro_3.8.1.bb
+++ b/recipes/python/python-pyro_3.8.1.bb
@@ -10,7 +10,7 @@ PR = "ml0"
SRC_URI = "\
${SOURCEFORGE_MIRROR}/pyro/Pyro-${PV}.tar.gz \
- file://pyro-unattended-install.patch;apply=yes;striplevel=0 \
+ file://pyro-unattended-install.patch;striplevel=0 \
"
S = "${WORKDIR}/Pyro-${PV}"
diff --git a/recipes/python/python-pysqlite2_2.4.0.bb b/recipes/python/python-pysqlite2_2.4.0.bb
index 562479b77b..3ed8940bc8 100644
--- a/recipes/python/python-pysqlite2_2.4.0.bb
+++ b/recipes/python/python-pysqlite2_2.4.0.bb
@@ -7,7 +7,7 @@ SRCNAME = "pysqlite"
PR = "ml2"
SRC_URI = "http://initd.org/pub/software/pysqlite/releases/2.4/${PV}/${SRCNAME}-${PV}.tar.gz \
- file://fix-setup.patch;apply=yes"
+ file://fix-setup.patch"
S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils
diff --git a/recipes/python/python-setuptools_0.6c9.bb b/recipes/python/python-setuptools_0.6c9.bb
index c704205108..df24384aa8 100644
--- a/recipes/python/python-setuptools_0.6c9.bb
+++ b/recipes/python/python-setuptools_0.6c9.bb
@@ -9,7 +9,7 @@ PR = "ml0"
SRC_URI = "\
http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz\
- file://fix-log-usage.patch;apply=yes \
+ file://fix-log-usage.patch \
"
S = "${WORKDIR}/${SRCNAME}-${PV}"
diff --git a/recipes/python/python-soappy_0.11.6.bb b/recipes/python/python-soappy_0.11.6.bb
index 36677f6f0f..93e9fd18ce 100644
--- a/recipes/python/python-soappy_0.11.6.bb
+++ b/recipes/python/python-soappy_0.11.6.bb
@@ -8,7 +8,7 @@ SRCNAME = "SOAPpy"
PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/pywebsvcs/${SRCNAME}-${PV}.tar.gz \
- file://fix-future.patch;apply=yes \
+ file://fix-future.patch \
file://fpconst.py"
S = "${WORKDIR}/${SRCNAME}-${PV}"
diff --git a/recipes/python/python-traits_3.0.3.bb b/recipes/python/python-traits_3.0.3.bb
index e8c5baa73e..83ee814665 100644
--- a/recipes/python/python-traits_3.0.3.bb
+++ b/recipes/python/python-traits_3.0.3.bb
@@ -8,7 +8,7 @@ inherit setuptools
SRC_URI = "\
http://pypi.python.org/packages/source/T/Traits/Traits-${PV}.tar.gz \
-# file://fix-import-pyface.diff;apply=yes \
+# file://fix-import-pyface.diff \
"
S = "${WORKDIR}/Traits-${PV}"
diff --git a/recipes/python/python-twisted_2.5.0.bb b/recipes/python/python-twisted_2.5.0.bb
index e678bb7e2e..d8f24587a2 100644
--- a/recipes/python/python-twisted_2.5.0.bb
+++ b/recipes/python/python-twisted_2.5.0.bb
@@ -8,7 +8,7 @@ LICENSE = "LGPL"
PR = "r9"
SRC_URI = "http://tmrc.mit.edu/mirror/twisted/Twisted/2.5/Twisted-${PV}.tar.bz2 \
- file://remove-zope-check.patch;apply=yes"
+ file://remove-zope-check.patch"
S = "${WORKDIR}/Twisted-${PV}"
inherit distutils
diff --git a/recipes/python/python-vorbis_1.4.bb b/recipes/python/python-vorbis_1.4.bb
index 0d3ecf76f0..5ff8d4a469 100644
--- a/recipes/python/python-vorbis_1.4.bb
+++ b/recipes/python/python-vorbis_1.4.bb
@@ -7,7 +7,7 @@ SRCNAME = "pyvorbis"
PR = "ml0"
SRC_URI = "http://www.andrewchatham.com/pyogg/download/${SRCNAME}-${PV}.tar.gz \
- file://disable-oggcheck.patch;apply=yes"
+ file://disable-oggcheck.patch"
S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils
diff --git a/recipes/python/python_2.6.1.bb b/recipes/python/python_2.6.1.bb
index d7995ca927..fea600826f 100644
--- a/recipes/python/python_2.6.1.bb
+++ b/recipes/python/python_2.6.1.bb
@@ -6,23 +6,23 @@ PR = "${INC_PR}.0"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
- file://00-fix-bindir-libdir-for-cross.patch;apply=yes \
- file://01-use-proper-tools-for-cross-build.patch;apply=yes \
- file://02-remove-test-for-cross.patch;apply=yes \
- file://03-fix-tkinter-detection.patch;apply=yes \
- file://04-default-is-optimized.patch;apply=yes \
- file://05-enable-ctypes-cross-build.patch;apply=yes \
- file://06-libffi-enable-default-mips.patch;apply=yes \
- file://07-export-grammer.patch;apply=yes \
- file://99-ignore-optimization-flag.patch;apply=yes \
+ file://00-fix-bindir-libdir-for-cross.patch \
+ file://01-use-proper-tools-for-cross-build.patch \
+ file://02-remove-test-for-cross.patch \
+ file://03-fix-tkinter-detection.patch \
+ file://04-default-is-optimized.patch \
+ file://05-enable-ctypes-cross-build.patch \
+ file://06-libffi-enable-default-mips.patch \
+ file://07-export-grammer.patch \
+ file://99-ignore-optimization-flag.patch \
\
# not yet pushed forward
# sitecustomize, sitebranding
\
-# file://05-install.patch;apply=yes \
-# file://06-fix-urllib-exception.patch;apply=yes \
-# file://16-bug1179-imageop.patch;apply=yes \
-# file://13-set-wakeup-fix.patch;apply=yes \
+# file://05-install.patch \
+# file://06-fix-urllib-exception.patch \
+# file://16-bug1179-imageop.patch \
+# file://13-set-wakeup-fix.patch \
\
file://sitecustomize.py \
"
diff --git a/recipes/python/python_2.6.2.bb b/recipes/python/python_2.6.2.bb
index 275ecbc46e..8a14db5e7d 100644
--- a/recipes/python/python_2.6.2.bb
+++ b/recipes/python/python_2.6.2.bb
@@ -7,21 +7,21 @@ PR = "${INC_PR}.0"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
- file://00-fix-bindir-libdir-for-cross.patch;apply=yes \
- file://01-use-proper-tools-for-cross-build.patch;apply=yes \
- file://02-remove-test-for-cross.patch;apply=yes \
- file://03-fix-tkinter-detection.patch;apply=yes \
- file://04-default-is-optimized.patch;apply=yes \
- file://05-enable-ctypes-cross-build.patch;apply=yes \
- file://99-ignore-optimization-flag.patch;apply=yes \
+ file://00-fix-bindir-libdir-for-cross.patch \
+ file://01-use-proper-tools-for-cross-build.patch \
+ file://02-remove-test-for-cross.patch \
+ file://03-fix-tkinter-detection.patch \
+ file://04-default-is-optimized.patch \
+ file://05-enable-ctypes-cross-build.patch \
+ file://99-ignore-optimization-flag.patch \
\
# not yet pushed forward
# sitebranding
\
-# file://05-install.patch;apply=yes \
-# file://06-fix-urllib-exception.patch;apply=yes \
-# file://16-bug1179-imageop.patch;apply=yes \
-# file://13-set-wakeup-fix.patch;apply=yes \
+# file://05-install.patch \
+# file://06-fix-urllib-exception.patch \
+# file://16-bug1179-imageop.patch \
+# file://13-set-wakeup-fix.patch \
\
file://sitecustomize.py \
"
diff --git a/recipes/python/python_2.6.4.bb b/recipes/python/python_2.6.4.bb
index efd90bdb73..84234f7e4d 100644
--- a/recipes/python/python_2.6.4.bb
+++ b/recipes/python/python_2.6.4.bb
@@ -7,22 +7,22 @@ PR = "${INC_PR}.1"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2;name=archive \
- file://00-fix-bindir-libdir-for-cross.patch;apply=yes \
- file://01-use-proper-tools-for-cross-build.patch;apply=yes \
- file://02-remove-test-for-cross.patch;apply=yes \
- file://03-fix-tkinter-detection.patch;apply=yes \
- file://04-default-is-optimized.patch;apply=yes \
- file://05-enable-ctypes-cross-build.patch;apply=yes \
- file://06-ctypes-libffi-fix-configure.patch;apply=yes \
- file://99-ignore-optimization-flag.patch;apply=yes \
+ file://00-fix-bindir-libdir-for-cross.patch \
+ file://01-use-proper-tools-for-cross-build.patch \
+ file://02-remove-test-for-cross.patch \
+ file://03-fix-tkinter-detection.patch \
+ file://04-default-is-optimized.patch \
+ file://05-enable-ctypes-cross-build.patch \
+ file://06-ctypes-libffi-fix-configure.patch \
+ file://99-ignore-optimization-flag.patch \
\
# not yet pushed forward
# sitebranding
\
-# file://05-install.patch;apply=yes \
-# file://06-fix-urllib-exception.patch;apply=yes \
-# file://16-bug1179-imageop.patch;apply=yes \
-# file://13-set-wakeup-fix.patch;apply=yes \
+# file://05-install.patch \
+# file://06-fix-urllib-exception.patch \
+# file://16-bug1179-imageop.patch \
+# file://13-set-wakeup-fix.patch \
\
file://sitecustomize.py \
"