aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-01-15 15:31:00 -0800
committerKhem Raj <raj.khem@gmail.com>2011-01-15 15:31:00 -0800
commit700b75e7661062aa93cf81205b78c8bf7609922d (patch)
tree81841146275bcf0e115f520949cf04a6f9bf0688 /recipes/python
parent3358de515426596e9f4e6137da75a5968873fdb4 (diff)
downloadopenembedded-700b75e7661062aa93cf81205b78c8bf7609922d.tar.gz
python: Fix configure tests when using --enable-ipv6
* Add cross compile awareness to configure test in 2.6 * Cache ac_cv_buggy_getaddrinfo for all which is used by python 2.7 onwards Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-2.6.5/ipv6-cross.patch13
-rw-r--r--recipes/python/python_2.6.5.bb3
2 files changed, 15 insertions, 1 deletions
diff --git a/recipes/python/python-2.6.5/ipv6-cross.patch b/recipes/python/python-2.6.5/ipv6-cross.patch
new file mode 100644
index 0000000000..3d2ac5ed90
--- /dev/null
+++ b/recipes/python/python-2.6.5/ipv6-cross.patch
@@ -0,0 +1,13 @@
+Index: Python-2.6.5/configure.in
+===================================================================
+--- Python-2.6.5.orig/configure.in 2011-01-15 14:42:42.068656002 -0800
++++ Python-2.6.5/configure.in 2011-01-15 15:18:39.668656002 -0800
+@@ -2951,7 +2951,7 @@
+ buggygetaddrinfo=yes
+ ])
+
+-if test "$buggygetaddrinfo" = "yes"; then
++if test "$buggygetaddrinfo" = "yes" -a x"$cross_compiling" != "xyes"; then
+ if test "$ipv6" = "yes"; then
+ echo 'Fatal: You must get working getaddrinfo() function.'
+ echo ' or you can specify "--disable-ipv6"'.
diff --git a/recipes/python/python_2.6.5.bb b/recipes/python/python_2.6.5.bb
index f5808f1beb..d7d42a7016 100644
--- a/recipes/python/python_2.6.5.bb
+++ b/recipes/python/python_2.6.5.bb
@@ -3,7 +3,7 @@ DEPENDS = "python-native db gdbm openssl readline sqlite3 tcl zlib\
${@base_contains('DISTRO_FEATURES', 'tk', 'tk', '', d)}"
DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
# set to .0 on every increase of INC_PR
-PR = "${INC_PR}.2"
+PR = "${INC_PR}.3"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
@@ -16,6 +16,7 @@ SRC_URI = "\
file://05-enable-ctypes-cross-build.patch \
file://06-ctypes-libffi-fix-configure.patch \
file://99-ignore-optimization-flag.patch \
+ file://ipv6-cross.patch \
file://sitecustomize.py \
"
SRC_URI[md5sum] = "6bef0417e71a1a1737ccf5750420fdb3"