aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2011-01-06 20:48:27 +0000
committerAndreas Oberritter <obi@opendreambox.org>2011-01-06 15:52:00 +0100
commit87b86f347ebf9c80be055e5f74aa59b24bb1ff4d (patch)
treefcacfa3bf365f5fcd18cd4fef682cb1ed28a83d4 /recipes/python
parentd120a61ed69a01a252b42ccb11e417aec433d563 (diff)
downloadopenembedded-87b86f347ebf9c80be055e5f74aa59b24bb1ff4d.tar.gz
python-wifi: add recipe for version 0.5.0
* package previously unpackaged files into -doc and -examples Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Acked-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Michael 'Mickey' Lauer <mlauer@vanille-media.de> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-wifi_0.5.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/python/python-wifi_0.5.0.bb b/recipes/python/python-wifi_0.5.0.bb
new file mode 100644
index 0000000000..faa3b43ef4
--- /dev/null
+++ b/recipes/python/python-wifi_0.5.0.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Provides access to Linux Wireless Extensions"
+HOMEPAGE = "http://pythonwifi.wikispot.org/"
+SECTION = "devel/python"
+LICENSE = "LGPLv2+"
+LICENSE_${PN}-examples = "GPLv2+"
+RDEPENDS_${PN} = "python-ctypes python-datetime"
+
+SRC_URI = "http://download.berlios.de/pythonwifi/${P}.tar.bz2"
+SRC_URI[md5sum] = "8fe7fd0a4edce1f9bedaff4acb7fd500"
+SRC_URI[sha256sum] = "3e3f645d37ab20450f60c785cec5f21b330f28a6c46c7c1b0898305dd7a34b26"
+
+inherit setuptools
+
+do_install_append() {
+ install -d ${D}${docdir}/${PN}
+ mv ${D}${datadir}/README ${D}${docdir}/${PN}
+ mv ${D}${datadir}/INSTALL ${D}${docdir}/${PN}
+ mv ${D}${datadir}/docs/* ${D}${docdir}/${PN}
+ install -d ${D}${sbindir}
+ mv ${D}${datadir}/examples/* ${D}${sbindir}
+}
+
+PACKAGES =+ "${PN}-examples"
+
+FILES_${PN}-examples = "${sbindir}"