aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-09-20 07:59:17 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-09-24 18:51:13 +0200
commitd33ca8e16602a72d99f47a465bb56a613273cbc6 (patch)
tree129a79ffffff2611e36d7fcac94f4263306a399a /recipes/python
parente86bc83bc243626dff59f5c64659874290e00d3e (diff)
downloadopenembedded-d33ca8e16602a72d99f47a465bb56a613273cbc6.tar.gz
EFL: bump SRCREV
* python-efl: python EFL bindings are now using autotools instead of setuptools started with r52282 * python-efl: prefix includedir value returned from pkg-config --variable=includedir with STAGING_DIR_HOST * python-efl: don't install .svn files with examples * python-edje: update patch for unicode conversion * elmdentica: jump back to EFL_SRCREV * ecore: rebased patch, see http://patchwork.openembedded.org/patch/2626/ for discussion if it's still really needed Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-edje/0001-fix-unicode-conversion.patch11
-rw-r--r--recipes/python/python-efl.inc14
2 files changed, 15 insertions, 10 deletions
diff --git a/recipes/python/python-edje/0001-fix-unicode-conversion.patch b/recipes/python/python-edje/0001-fix-unicode-conversion.patch
index 7964e097d1..3b0cdc627c 100644
--- a/recipes/python/python-edje/0001-fix-unicode-conversion.patch
+++ b/recipes/python/python-edje/0001-fix-unicode-conversion.patch
@@ -11,7 +11,7 @@ diff --git a/edje/edje.c_edje_object.pxi b/edje/edje.c_edje_object.pxi
index 0f4da68..21c237e 100644
--- a/edje/edje.c_edje_object.pxi
+++ b/edje/edje.c_edje_object.pxi
-@@ -391,17 +391,20 @@ cdef public class Edje(evas.c_evas.Object) [object PyEdje, type PyEdje_Type]:
+@@ -415,17 +415,20 @@
else:
raise TypeError("func must be callable or None")
@@ -26,7 +26,7 @@ index 0f4da68..21c237e 100644
def part_text_get(self, char *part):
- "@rtype: str"
+ "@rtype: unicode"
- cdef char *s
+ cdef const_char_ptr s
s = edje_object_part_text_get(self.obj, part)
if s == NULL:
return None
@@ -34,8 +34,5 @@ index 0f4da68..21c237e 100644
- return s
+ return s.decode("utf8")
- def part_swallow(self, char *part, c_evas.Object obj):
- """Swallows an object into the edje
---
-1.5.6.3
-
+ def part_text_select_all(self, char *part):
+ edje_object_part_text_select_all(self.obj, part)
diff --git a/recipes/python/python-efl.inc b/recipes/python/python-efl.inc
index 745ba57cc6..9845fbff36 100644
--- a/recipes/python/python-efl.inc
+++ b/recipes/python/python-efl.inc
@@ -10,11 +10,20 @@ RDEPENDS_${PN} += "python-lang"
PV = "0.3.1+svnr${SRCPV}"
PR = "ml1"
-inherit setuptools
+# necessary to let the call for python-config succeed
+export BUILD_SYS
+export HOST_SYS
+
+inherit autotools pkgconfig distutils-base
SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk/BINDINGS/python;module=${PN};proto=http"
S = "${WORKDIR}/${PN}"
+do_configure_prepend() {
+ # prefix CYTHON_.*_INCLUDEDIR with path to STAGING_DIR_HOST also use $PKG_CONFIG instead of pkg-config directly
+ sed -i "s#\`\$PKG_CONFIG --variable=includedir \"python-evas#${STAGING_DIR_HOST}\`\$PKG_CONFIG --variable=includedir \"python-evas#g" ${S}/configure.ac
+}
+
do_install_append() {
if [ -e examples ]; then
for i in `find examples -name "*.edc"`; do
@@ -27,8 +36,7 @@ do_install_append() {
cd ${S}
install -d ${D}${datadir}/${PN}/
cp -a examples ${D}${datadir}/${PN}/
- find ${D}${datadir}/${PN}/examples -name "CVS" | xargs rm -rf
- find ${D}${datadir}/${PN}/examples -name ".cvsignore" | xargs rm -f
+ find ${D}${datadir}/${PN}/examples -name ".svn" | xargs rm -rf
fi
}