aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorFahad Usman <fahad_usman@mentor.com>2010-09-23 21:51:26 +0000
committerKhem Raj <raj.khem@gmail.com>2010-09-27 16:51:57 -0700
commite701b369d20e645e9126aeb2c23c929f48cf9374 (patch)
tree9236f435cb91de9cc8284d11f303e833168ff220 /recipes/python
parenteb30ef6d8ef030ed9c1ba581798204eb4e1c313b (diff)
downloadopenembedded-e701b369d20e645e9126aeb2c23c929f48cf9374.tar.gz
python-pyrex_0.9.8.5.bb: merged native and non-native recipes
* removed the python-pyrex-native_0.9.8.5.bb file * added DEPENDS_pn-python-pyrex-native = "python-native" * added BBCLASSEXTEND = "native" * added NATIVE_INSTALL_WORKS = "1" * bunped PR Signed-off-by: Fahad Usman <fahad_usman@mentor.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-pyrex-native_0.9.8.5.bb13
-rw-r--r--recipes/python/python-pyrex_0.9.8.5.bb7
2 files changed, 6 insertions, 14 deletions
diff --git a/recipes/python/python-pyrex-native_0.9.8.5.bb b/recipes/python/python-pyrex-native_0.9.8.5.bb
deleted file mode 100644
index 109b49ed15..0000000000
--- a/recipes/python/python-pyrex-native_0.9.8.5.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-require python-pyrex_${PV}.bb
-inherit native
-DEPENDS = "python-native"
-RDEPENDS_${PN} = ""
-
-do_stage() {
- BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
- STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \
- ${STAGING_BINDIR}/python setup.py install --prefix=${STAGING_BINDIR}/.. --install-data=${STAGING_DATADIR}
-}
-
-SRC_URI[md5sum] = "3b3d8397c2c9a58fc59a90e2b49c651a"
-SRC_URI[sha256sum] = "dd60bc66b1627d3cbd0950499017dfd57a0705bb12493bb0de2a7b9b5c0873bc"
diff --git a/recipes/python/python-pyrex_0.9.8.5.bb b/recipes/python/python-pyrex_0.9.8.5.bb
index c354b11839..34af4f889f 100644
--- a/recipes/python/python-pyrex_0.9.8.5.bb
+++ b/recipes/python/python-pyrex_0.9.8.5.bb
@@ -5,7 +5,8 @@ SECTION = "devel/python"
PRIORITY = "optional"
LICENSE = "GPL"
SRCNAME = "Pyrex"
-PR = "ml1"
+DEPENDS_pn-python-pyrex-native = "python-native"
+PR = "ml2"
SRC_URI = "\
http://www.cosc.canterbury.ac.nz/greg.ewing/python/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
@@ -17,3 +18,7 @@ inherit distutils
SRC_URI[md5sum] = "3b3d8397c2c9a58fc59a90e2b49c651a"
SRC_URI[sha256sum] = "dd60bc66b1627d3cbd0950499017dfd57a0705bb12493bb0de2a7b9b5c0873bc"
+
+BBCLASSEXTEND = "native"
+
+NATIVE_INSTALL_WORKS = "1"