aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-09-14 21:45:36 +0200
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-09-16 14:46:51 +0200
commit2a3d5c21971587a47b203359ed37a125b37aac39 (patch)
tree29550a2ba11cde32ad3e89274c3ba053bde9dfc7 /recipes/python
parenta7144f8e73c4058e7f94769681b20508006fce53 (diff)
downloadopenembedded-2a3d5c21971587a47b203359ed37a125b37aac39.tar.gz
python-dbus: add some more dependencies
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-dbus_0.83.0.bb20
1 files changed, 12 insertions, 8 deletions
diff --git a/recipes/python/python-dbus_0.83.0.bb b/recipes/python/python-dbus_0.83.0.bb
index 7bc81f0396..02b73e64bf 100644
--- a/recipes/python/python-dbus_0.83.0.bb
+++ b/recipes/python/python-dbus_0.83.0.bb
@@ -3,20 +3,24 @@ SECTION = "devel/python"
HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
LICENSE = "MIT"
DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native"
-PR = "ml1"
+PR = "ml2"
SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz"
S = "${WORKDIR}/dbus-python-${PV}"
-inherit distutils-base autotools pkgconfig
+inherit distutils-base autotools_stage pkgconfig
export BUILD_SYS
export HOST_SYS
-do_stage() {
- autotools_stage_all
-}
+RDEPENDS_${PN} = "\
+ python-io \
+ python-lang \
+ python-logging \
+ python-threading \
+ python-xml \
+"
-RDEPENDS = "python-io python-logging python-stringold python-threading python-xml"
-
-FILES_${PN}-dev += "${libdir}/pkgconfig
+FILES_${PN}-dev += "\
+ ${libdir}/pkgconfig \
+"