aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 09:11:24 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 09:57:31 +0100
commit93288ed203d9253ce7cf3ffd8e72bf0059e54255 (patch)
tree06dd73d631fa03554256003bff03e64625778bba /recipes/python
parent5953dfd42fa5a2e524f5fa4bebcd4b27c5f7a4ed (diff)
downloadopenembedded-93288ed203d9253ce7cf3ffd8e72bf0059e54255.tar.gz
python-webdav: new recipe from SHR
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-webdav_0.1.2.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes/python/python-webdav_0.1.2.bb b/recipes/python/python-webdav_0.1.2.bb
new file mode 100644
index 0000000000..efc74f9183
--- /dev/null
+++ b/recipes/python/python-webdav_0.1.2.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "This project aims to provide an object-oriented Python WebDAV client-side library\
+ based on Python`s standard httplib and Greg Stein`s davlib.\
+ The client shall fully support RFCs 4918 (basic specification),\
+ 3744 (access control), and 3253 (versioning)."
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "Apache License V2.0"
+HOMEPAGE = "http://sourceforge.net/projects/pythonwebdavlib/"
+SRCNAME = "Python_WebDAV_Library"
+DEPENDS = "python"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/pythonwebdavlib/Python%20WebDAV%20Library%20-%20${PV}/${SRCNAME}-${PV}.zip"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils