aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-07-22 14:09:54 +0200
committerKoen Kooi <koen@openembedded.org>2010-07-22 14:09:54 +0200
commitcb7b0a0540db8607a85e59640f6b2537001089eb (patch)
tree893d6073436e688d00aca9ef862efd8091ff182e /recipes/python
parentf48b09244716223abdf447d49ed0f36b19370111 (diff)
downloadopenembedded-cb7b0a0540db8607a85e59640f6b2537001089eb.tar.gz
python-pygtk2: install .pc file
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-pygtk_2.16.0.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes/python/python-pygtk_2.16.0.bb b/recipes/python/python-pygtk_2.16.0.bb
index 1b0a12b636..699bd5d659 100644
--- a/recipes/python/python-pygtk_2.16.0.bb
+++ b/recipes/python/python-pygtk_2.16.0.bb
@@ -6,7 +6,7 @@ RDEPENDS_${PN} = "python-shell python-pycairo python-pygobject"
PROVIDES = "python-pygtk2"
SRCNAME = "pygtk"
LICENSE = "LGPL"
-PR = "r2"
+PR = "r3"
MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/${MAJ_VER}/${SRCNAME}-${PV}.tar.bz2;name=pygtk \
@@ -38,6 +38,8 @@ do_install_append() {
find ${D} -name "*.la"|xargs rm -f
rm -f ${D}/${bindir}/pygtk-codegen-2.0
rm -rf ${D}/${libdir}/pkgconfig
+ install -d ${D}${libdir}/pkgconfig
+ install -m 0644 ${S}/*.pc ${D}${libdir}/pkgconfig
}
# dirty fix #2: fix build system paths leaking in