aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorTom Hayward <tom@harbortronics.com>2010-07-11 11:47:54 -0700
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-07-13 17:47:54 +0200
commitf7f8bfbd02f86af63f5f6e23c555e61d5294e54e (patch)
treef7613637ac40d7b7ed3d625d68ffba72340b5e09 /recipes/python
parentcb007c1e0d05ae673a589db69030511b68ccf757 (diff)
downloadopenembedded-f7f8bfbd02f86af63f5f6e23c555e61d5294e54e.tar.gz
python-django: added recipe for 1.2.1, based on 1.0.2 recipe.
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-django_1.2.1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/python/python-django_1.2.1.bb b/recipes/python/python-django_1.2.1.bb
new file mode 100644
index 0000000000..0dff6a8430
--- /dev/null
+++ b/recipes/python/python-django_1.2.1.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Python Web framework"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "BSD"
+SRCNAME = "Django"
+RELEASE = "1.2"
+PR = "r0"
+
+SRC_URI = "http://media.djangoproject.com/releases/${RELEASE}/${SRCNAME}-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+DISTUTILS_INSTALL_ARGS = "--root=${D} --prefix=${prefix}"
+
+# TODO: huge package, increase granularity
+
+RDEPENDS_${PN} = "\
+ python-email \
+ python-html \
+ python-netserver \
+ python-numbers \
+ python-pickle \
+ python-pprint \
+ python-shell \
+ python-sqlite3 \
+ python-textutils \
+ python-threading \
+ python-unixadmin \
+ python-xml \
+"
+
+SRC_URI[md5sum] = "2351efb20f6b7b5d9ce80fa4cb1bd9ca"
+SRC_URI[sha256sum] = "eaa29f2344568cc871c4517a348de0d5c39fbd055b4c998cd4a80601bb51e7b9"