aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-08-25 20:44:13 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2009-03-19 20:22:35 +0100
commit7fe23916b92d01915c7497edcac55fee9ab67091 (patch)
treedd59cf2fa6db9441813e098b1833bc101e046fe6 /recipes/python
parent5089082042e867cb6e660687bf55d7cef176b793 (diff)
downloadopenembedded-7fe23916b92d01915c7497edcac55fee9ab67091.tar.gz
Add python-urlgrabber, python-iniparser, yum-metadata-parser and native variants (from Poky)
OE changes: python-iniparse-native: use distutils_stage_all python-urlgrabber-native: use distutils_stage_all yum-metadata-parser-native: use distutils_stage_all
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-iniparse-native_0.2.3.bb9
-rw-r--r--recipes/python/python-iniparse_0.2.3.bb11
-rw-r--r--recipes/python/python-urlgrabber-native_3.1.0.bb9
-rw-r--r--recipes/python/python-urlgrabber_3.1.0.bb11
-rw-r--r--recipes/python/yum-metadata-parser-native_1.1.2.bb9
-rw-r--r--recipes/python/yum-metadata-parser_1.1.2.bb13
6 files changed, 62 insertions, 0 deletions
diff --git a/recipes/python/python-iniparse-native_0.2.3.bb b/recipes/python/python-iniparse-native_0.2.3.bb
new file mode 100644
index 0000000000..68dd2184a8
--- /dev/null
+++ b/recipes/python/python-iniparse-native_0.2.3.bb
@@ -0,0 +1,9 @@
+require python-iniparse_${PV}.bb
+inherit native
+DEPENDS = "python-native"
+RDEPENDS = ""
+PR = "r1"
+
+do_stage() {
+ distutils_stage_all
+}
diff --git a/recipes/python/python-iniparse_0.2.3.bb b/recipes/python/python-iniparse_0.2.3.bb
new file mode 100644
index 0000000000..27a38f4249
--- /dev/null
+++ b/recipes/python/python-iniparse_0.2.3.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "iniparse is a INI parser for Python"
+HOMEPAGE = "http://code.google.com/p/iniparse/"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://iniparse.googlecode.com/files/iniparse-${PV}.tar.gz"
+S = "${WORKDIR}/iniparse-${PV}"
+
+inherit distutils
diff --git a/recipes/python/python-urlgrabber-native_3.1.0.bb b/recipes/python/python-urlgrabber-native_3.1.0.bb
new file mode 100644
index 0000000000..5c2af551c0
--- /dev/null
+++ b/recipes/python/python-urlgrabber-native_3.1.0.bb
@@ -0,0 +1,9 @@
+require python-urlgrabber_${PV}.bb
+inherit native
+DEPENDS = "python-native"
+RDEPENDS = ""
+PR = "r1"
+
+do_stage() {
+ distutils_stage_all
+}
diff --git a/recipes/python/python-urlgrabber_3.1.0.bb b/recipes/python/python-urlgrabber_3.1.0.bb
new file mode 100644
index 0000000000..a8ccf8ae57
--- /dev/null
+++ b/recipes/python/python-urlgrabber_3.1.0.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "urlgrabber is a pure python package that drastically simplifies the fetching of files."
+HOMEPAGE = "http://linux.duke.edu/projects/urlgrabber/"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://linux.duke.edu/projects/urlgrabber/download/urlgrabber-${PV}.tar.gz"
+S = "${WORKDIR}/urlgrabber-${PV}"
+
+inherit distutils
diff --git a/recipes/python/yum-metadata-parser-native_1.1.2.bb b/recipes/python/yum-metadata-parser-native_1.1.2.bb
new file mode 100644
index 0000000000..15d26a18ce
--- /dev/null
+++ b/recipes/python/yum-metadata-parser-native_1.1.2.bb
@@ -0,0 +1,9 @@
+require yum-metadata-parser_${PV}.bb
+inherit native
+DEPENDS = "python-native sqlite3-native glib-2.0-native libxml2-native"
+RDEPENDS = ""
+PR = "r1"
+
+do_stage() {
+ distutils_stage_all
+}
diff --git a/recipes/python/yum-metadata-parser_1.1.2.bb b/recipes/python/yum-metadata-parser_1.1.2.bb
new file mode 100644
index 0000000000..24de7615bc
--- /dev/null
+++ b/recipes/python/yum-metadata-parser_1.1.2.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "C-based metadata parser to quickly parse xml metadata into sqlite databases."
+HOMEPAGE = "http://linux.duke.edu/projects/yum/download.ptml"
+SECTION = "devel/python"
+PRIORITY = "optional"
+DEPENDS = "python sqlite3 glib-2.0 libxml2"
+LICENSE = "GPL"
+
+SRC_URI = "http://linux.duke.edu/projects/yum/download/yum-metadata-parser/yum-metadata-parser-${PV}.tar.gz"
+S = "${WORKDIR}/yum-metadata-parser-${PV}"
+
+TARGET_CFLAGS += "-I${STAGING_LIBDIR}/glib-2.0"
+
+inherit distutils