aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorElena Grandi <elena.valhalla@gmail.com>2009-07-01 12:57:12 +0200
committerElena Grandi <elena.valhalla@gmail.com>2009-07-01 12:57:12 +0200
commit645418b10be153f65ef42e0e2158f89d2618536f (patch)
tree23e0d365d0cd049043a218484cae3acd7263251d /recipes/python
parenta2ba9341af9cbb19593f120b52dee81788f03b9c (diff)
downloadopenembedded-645418b10be153f65ef42e0e2158f89d2618536f.tar.gz
python-pygtksourceview 2.6.0: new recipe
python bindings for gtksourceview
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-pygtksourceview_2.6.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/python/python-pygtksourceview_2.6.0.bb b/recipes/python/python-pygtksourceview_2.6.0.bb
new file mode 100644
index 0000000000..0c2b335d1e
--- /dev/null
+++ b/recipes/python/python-pygtksourceview_2.6.0.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Python gtksourceview Bindings"
+SECTION = "devel/python"
+HOMEPAGE = "http://projects.gnome.org/gtksourceview/pygtksourceview.html"
+PRIORITY = "optional"
+DEPENDS = "gtksourceview python-pygtk"
+SRCNAME = "pygtksourceview"
+LICENSE = "LGPL"
+PR = "r0"
+
+MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
+SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtksourceview/${MAJ_VER}/${SRCNAME}-${PV}.tar.bz2"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit autotools pkgconfig distutils-base
+
+EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
+