aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-08-05 14:38:23 -0700
committerKhem Raj <raj.khem@gmail.com>2009-08-05 14:38:23 -0700
commitc24a415882ab8ff1d8cc3d02c14ad384ab0eb965 (patch)
tree8b97bb6d29a08d5ad4210560e053f2e4fc2dfd7e /recipes/python
parent4b3eefe53ff29779d6f1080f1f686d3eceba9fad (diff)
downloadopenembedded-c24a415882ab8ff1d8cc3d02c14ad384ab0eb965.tar.gz
python-native_2.6.1.bb: Unset LIBC
LIBC is used internally by python configure if it gets it from enviromment it honors it. Coincidently we also use LIBC in OE to denote one of uclibc eglibc or glibc to be system C library It conflicts if somehow LIBC=<something> is set in the envronment so we pass empty LIBC for native recipe. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-native_2.6.1.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes/python/python-native_2.6.1.bb b/recipes/python/python-native_2.6.1.bb
index 00d87e6f59..cc949e1c2c 100644
--- a/recipes/python/python-native_2.6.1.bb
+++ b/recipes/python/python-native_2.6.1.bb
@@ -1,7 +1,7 @@
require python.inc
DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native"
-PR .= ".1"
+PR .= ".2"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
@@ -21,6 +21,7 @@ exec_prefix = "${STAGING_DIR_NATIVE}/${layout_exec_prefix}"
EXTRA_OEMAKE = '\
BUILD_SYS="" \
HOST_SYS="" \
+ LIBC="" \
STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
'