aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 09:09:29 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 09:57:24 +0100
commit23decb4d14b0a58cfae88eca9b2ec6487af05a2b (patch)
treeab2201fdc55ce89f3c2f60ba096faf55b5671fc5 /recipes/python
parente347d30bd16ab0172db37b73716d802a9294b3ab (diff)
downloadopenembedded-23decb4d14b0a58cfae88eca9b2ec6487af05a2b.tar.gz
pyring: new recipe from SHR
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/pyring_1.1.10.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/python/pyring_1.1.10.bb b/recipes/python/pyring_1.1.10.bb
new file mode 100644
index 0000000000..211801debf
--- /dev/null
+++ b/recipes/python/pyring_1.1.10.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Python keyring"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS = "python python-pygtk python-xml python-netclient python-numeric pydes"
+
+ARCH_pyring = "all"
+
+SRC_URI = "http://handheldshell.com/software/pyring_${PV}.tgz "
+
+inherit distutils
+
+S = ${WORKDIR}/pyring-${PV}
+
+do_configure_prepend() {
+ cp ${S}/setup_freerunner.py ${S}/setup.py
+ exit 0
+}
+
+FILES_${PN} += "${datadir}"
+