aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-10-07 22:21:26 +0200
committerKoen Kooi <koen@openembedded.org>2009-10-07 23:20:10 +0200
commitcc3a65820157e2d3c8384c6db4e0f3f8d6b56f3e (patch)
tree248d9fad9e97ab95cd12ec8253a5e00aa49d2523 /recipes/python
parentf5d88d0f924e52828a70e7390b0c460f0f3b59bb (diff)
downloadopenembedded-cc3a65820157e2d3c8384c6db4e0f3f8d6b56f3e.tar.gz
gstreamer: update some bits
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-gst_0.10.10.bb6
-rw-r--r--recipes/python/python-gst_0.10.17.bb36
2 files changed, 40 insertions, 2 deletions
diff --git a/recipes/python/python-gst_0.10.10.bb b/recipes/python/python-gst_0.10.10.bb
index faef7cb5f1..0de87d6f42 100644
--- a/recipes/python/python-gst_0.10.10.bb
+++ b/recipes/python/python-gst_0.10.10.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Python Gstreamer bindings"
SECTION = "devel/python"
LICENSE = "LGPL"
DEPENDS = "gstreamer gst-plugins-base python-pygobject"
-PR = "ml3"
+PR = "ml4"
SRC_URI = "\
http://gstreamer.freedesktop.org/src/gst-python/gst-python-${PV}.tar.bz2 \
@@ -11,7 +11,9 @@ SRC_URI = "\
"
S = "${WORKDIR}/gst-python-${PV}"
-inherit autotools distutils-base pkgconfig
+inherit autotools pkgconfig distutils-base
+
+require fix-path.inc
EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
diff --git a/recipes/python/python-gst_0.10.17.bb b/recipes/python/python-gst_0.10.17.bb
new file mode 100644
index 0000000000..5695e6e04e
--- /dev/null
+++ b/recipes/python/python-gst_0.10.17.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Python Gstreamer bindings"
+SECTION = "devel/python"
+LICENSE = "LGPL"
+DEPENDS = "gstreamer gst-plugins-base python-pygobject"
+
+SRC_URI = "\
+ http://gstreamer.freedesktop.org/src/gst-python/gst-python-${PV}.tar.bz2 \
+ file://python-path.patch;patch=1 \
+ file://import-gobject-instead-of-pygtk.patch;patch=1 \
+"
+S = "${WORKDIR}/gst-python-${PV}"
+
+inherit autotools pkgconfig distutils-base
+
+require fix-path.inc
+
+EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
+
+do_configure_prepend() {
+ install -d ${S}/m4
+ install -m 0644 ${S}/common/m4/*.m4 ${S}/m4/
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+PACKAGES =+ "${PN}-examples"
+
+FILES_${PN} += "${datadir}/gst-python"
+FILES_${PN}-dev += "\
+ ${datadir}/gst-python/0.10/defs \
+ ${libdir}/${PYTHON_DIR}/site-packages/gst-0.10/gst/*.la \
+"
+FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/gst-0.10/gst/.debug/ ${libdir}/gstreamer-0.10/.debug/"
+FILES_${PN}-examples = "${datadir}/gst-python/0.10/examples"