aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qemu
diff options
context:
space:
mode:
authorThomas Zimmermann <ml@vdm-design.de>2010-03-15 16:42:14 +0100
committerThomas Zimmermann <ml@vdm-design.de>2010-03-15 16:42:14 +0100
commite19f00968b9d865088ef3a45a85825c5fc17edc5 (patch)
tree2d94d0259550e8854af716b1aa62d09d3e8443f2 /recipes/qemu
parente59a08839ee428f7548ff4e6eb01ebb64f2cd6ee (diff)
downloadopenembedded-e19f00968b9d865088ef3a45a85825c5fc17edc5.tar.gz
qemu: fix build without zlib headers installed on buildhost
*qemu-native fails to build without zlib-dev package installed on buildhost *configure script just adds -I. and -I${SRC_DIR} to QEMU_CFLAGS to build checks, so it fails to build without headers installed on host *change DEPENDS from zlib to zlib-native to install zlib headers in staging Signed-off-by: Thomas Zimmermann <ml@vdm-design.de>
Diffstat (limited to 'recipes/qemu')
-rw-r--r--recipes/qemu/qemu_0.12.3.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes/qemu/qemu_0.12.3.bb b/recipes/qemu/qemu_0.12.3.bb
index 035b1a5b3a..bc5c251641 100644
--- a/recipes/qemu/qemu_0.12.3.bb
+++ b/recipes/qemu/qemu_0.12.3.bb
@@ -1,5 +1,5 @@
LICENSE = "GPL"
-DEPENDS = "zlib"
+DEPENDS = "zlib-native"
PR = "r0"
@@ -32,5 +32,6 @@ EXTRA_OECONF += "--disable-sdl --disable-strip"
inherit autotools
do_configure() {
+ export QEMU_CFLAGS="-I${STAGING_INCDIR_NATIVE} ${QEMU_CFLAGS}"
${S}/configure --prefix=${prefix} ${EXTRA_OECONF}
}