summaryrefslogtreecommitdiffstats
path: root/recipes/qiv
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/qiv
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/qiv')
-rw-r--r--recipes/qiv/files/makefile.patch22
-rw-r--r--recipes/qiv/qiv_1.9.bb20
2 files changed, 42 insertions, 0 deletions
diff --git a/recipes/qiv/files/makefile.patch b/recipes/qiv/files/makefile.patch
new file mode 100644
index 0000000000..42707be9b9
--- /dev/null
+++ b/recipes/qiv/files/makefile.patch
@@ -0,0 +1,22 @@
+--- /tmp/Makefile 2006-09-02 13:04:25.000000000 +0200
++++ qiv-1.9/Makefile 2006-09-02 13:05:05.255780000 +0200
+@@ -4,7 +4,7 @@
+ ######################################################################
+
+ # Directory where qiv will be installed under.
+-PREFIX = /usr/local
++PREFIX = /usr/
+
+ # Font to use for statusbar in fullscreen mode
+ STATUSBAR_FONT = "fixed"
+@@ -53,10 +53,6 @@
+ # Do not edit below here!
+ ######################################################################
+
+-CC = gcc
+-CFLAGS = -O2 -Wall -fomit-frame-pointer -finline-functions \
+- -fcaller-saves -ffast-math -fno-strength-reduce \
+- -fthread-jumps #-march=pentium #-DSTAT_MACROS_BROKEN
+
+ INCLUDES = `imlib-config --cflags-gdk`
+ LIBS = `imlib-config --libs-gdk`
diff --git a/recipes/qiv/qiv_1.9.bb b/recipes/qiv/qiv_1.9.bb
new file mode 100644
index 0000000000..17138452a5
--- /dev/null
+++ b/recipes/qiv/qiv_1.9.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Qiv is a very small and pretty fast gdk/Imlib image viewer."
+LICENSE = "GPLv2"
+SECTION = "x11/graphics"
+DEPENDS = "gtk+-1.2 imlib"
+PR = "r1"
+
+SRC_URI = "http://www.klografx.net/qiv/download/qiv-1.9-src.tgz \
+ file://makefile.patch;patch=1 \
+ "
+inherit pkgconfig binconfig
+
+CFLAGS += " -lSM -lICE -lXdmcp"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man1/
+
+ install -s -m 0755 qiv ${D}${bindir}/qiv
+ install -m 0644 qiv.1 ${D}${mandir}/man1/qiv.1
+}