aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qmake
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-09-03 15:22:46 -0700
committerKhem Raj <raj.khem@gmail.com>2009-09-03 15:34:56 -0700
commit558f6d44365f062523fbba3926ab46e5cd1984b8 (patch)
tree67123ae2247951ded269701de07cb06977e1e94a /recipes/qmake
parentb9feafad3e4f1cac5e0eb4d6da498febdea7d5ae (diff)
downloadopenembedded-558f6d44365f062523fbba3926ab46e5cd1984b8.tar.gz
OpenEmbedded: Switch to using linux-uclibceabi and linux-gnu for TARGET_OS
* Bump the ABI_LAYOUT. Build from scratch will be needed. * Replace using TARGET_OS from linux->linux-gnu. * Replace using linux-uclibcgnueabi->linux-uclibceabi. * Add 'eabi' to DISTRO_FEATURES (only for minimal and micro). * Use eabi and BASE_PACKAGE_ARCH to compute real TARGET_OS. * Fix the micro conf to get console image building. * Fix the linux-uclibcgnueabi overrides in all recipes. Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Phill Blundell <pb@reciva.com> Acked-by: Michael 'Mickey' Lauer <mickey@vanille-media.de>
Diffstat (limited to 'recipes/qmake')
-rw-r--r--recipes/qmake/qmake-native_1.07a.bb2
-rw-r--r--recipes/qmake/qmake2-native.inc2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes/qmake/qmake-native_1.07a.bb b/recipes/qmake/qmake-native_1.07a.bb
index a80bb1bb92..bb3e79bca2 100644
--- a/recipes/qmake/qmake-native_1.07a.bb
+++ b/recipes/qmake/qmake-native_1.07a.bb
@@ -18,7 +18,7 @@ EXTRA_OEMAKE = "-e"
do_configure() {
# Install the OE build templates
- for template in linux-oe-g++ linux-uclibc-oe-g++ linux-gnueabi-oe-g++ linux-uclibcgnueabi-oe-g++
+ for template in linux-oe-g++ linux-uclibc-oe-g++ linux-gnueabi-oe-g++ linux-uclibceabi-oe-g++
do
install -d ${S}/mkspecs/$template
install -m 0644 ${WORKDIR}/linux-oe-qmake.conf ${S}/mkspecs/$template/qmake.conf
diff --git a/recipes/qmake/qmake2-native.inc b/recipes/qmake/qmake2-native.inc
index f84da2ad52..990820066a 100644
--- a/recipes/qmake/qmake2-native.inc
+++ b/recipes/qmake/qmake2-native.inc
@@ -26,7 +26,7 @@ do_configure() {
# Make sure we regenerate all Makefiles
find ${S} -name "Makefile" | xargs rm
# Install the OE build templates
- for template in linux-oe-g++ linux-uclibc-oe-g++ linux-gnueabi-oe-g++ linux-uclibcgnueabi-oe-g++
+ for template in linux-oe-g++ linux-uclibc-oe-g++ linux-gnueabi-oe-g++ linux-uclibceabi-oe-g++
do
install -d ${S}/mkspecs/$template
install -m 0644 ${WORKDIR}/linux-oe-qmake.conf ${S}/mkspecs/$template/qmake.conf