aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qplot/qplot_2.0.1+cvs20020420.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/qplot/qplot_2.0.1+cvs20020420.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/qplot/qplot_2.0.1+cvs20020420.bb')
-rw-r--r--recipes/qplot/qplot_2.0.1+cvs20020420.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/qplot/qplot_2.0.1+cvs20020420.bb b/recipes/qplot/qplot_2.0.1+cvs20020420.bb
new file mode 100644
index 0000000000..515eefaafc
--- /dev/null
+++ b/recipes/qplot/qplot_2.0.1+cvs20020420.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "QPlot is an Advanced Matematical Calculator for Qt/Embedded based Palmtop Environments"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://qplot.sourceforge.net/"
+SRCDATE = "20020420"
+#Change to form x.y.z+cvs${SRCDATE} when 2.0.1 changes in PV
+PV = "2.0.1-cvs-${SRCDATE}"
+PR = "r1"
+
+SRC_URI = "cvs://anonymous@qplot.cvs.sourceforge.net/cvsroot/qplot;module=qplot \
+ file://gcc3.patch;patch=1"
+S = "${WORKDIR}/qplot"
+
+inherit palmtop
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/apps/Applications \
+ ${D}${palmtopdir}/pics \
+ ${D}${palmtopdir}/lib \
+ ${D}${palmtopdir}/plugins/inputmethods
+ install -m 755 qplotmain/qplot ${D}${palmtopdir}/bin/qplot
+ install -m 644 qplotmain/qplot.png ${D}${palmtopdir}/pics/
+ install -m 644 qplotmain/qplot-const.b ${D}${palmtopdir}/lib/
+ install -m 644 qplotmain/qplot-math.b ${D}${palmtopdir}/lib/
+ oe_libinstall -so -C qplotmath libqplotmath ${D}${palmtopdir}/plugins/inputmethods/
+ install -m 644 qplot.desktop ${D}${palmtopdir}/apps/Applications/qplot.desktop
+}