aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qt4/qt4-x11-free_4.4.3.bb
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2009-03-25 17:00:59 +0100
committerJeremy Lainé <jeremy.laine@m4x.org>2009-03-25 17:00:59 +0100
commitac41ae95b1dbe54c05adf494c0fa44b3abbfeca3 (patch)
treea34220ed25168022c53d9cb5697f3666a427b30c /recipes/qt4/qt4-x11-free_4.4.3.bb
parent82b9cae9c7298e430843f6d547abfaf9ff26eed0 (diff)
downloadopenembedded-ac41ae95b1dbe54c05adf494c0fa44b3abbfeca3.tar.gz
qt4: consolidate include files into qt4.inc
Diffstat (limited to 'recipes/qt4/qt4-x11-free_4.4.3.bb')
-rw-r--r--recipes/qt4/qt4-x11-free_4.4.3.bb31
1 files changed, 29 insertions, 2 deletions
diff --git a/recipes/qt4/qt4-x11-free_4.4.3.bb b/recipes/qt4/qt4-x11-free_4.4.3.bb
index 2e3b005166..d4d476917e 100644
--- a/recipes/qt4/qt4-x11-free_4.4.3.bb
+++ b/recipes/qt4/qt4-x11-free_4.4.3.bb
@@ -1,3 +1,30 @@
-require qt4-x11-free.inc
-PR = "r6"
+DESCRIPTION = "Qt is a versatile cross-platform application framework -- this is the X11 version."
+SECTION = "x11/libs"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.trolltech.com"
+LICENSE = "GPL QPL"
+DEPENDS += "virtual/libx11 fontconfig xft libxext libxrender libxrandr libxcursor"
+PROVIDES = "qt4x11"
+PR = "r7"
+SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-x11-opensource-src-${PV}.tar.gz \
+ file://0001-cross-compile.patch;patch=1 \
+ file://0002-fix-resinit-declaration.patch;patch=1 \
+ file://0003-no-tools.patch;patch=1 \
+ file://0004-no-qmake.patch;patch=1 \
+ file://0005-fix-mkspecs.patch;patch=1 \
+ file://0006-freetype-host-includes.patch;patch=1 \
+ file://0007-openssl-host-includes.patch;patch=1 \
+ file://0008-qt-lib-infix.patch;patch=1"
+S = "${WORKDIR}/qt-x11-opensource-src-${PV}"
+
+
+QT_CONFIG_FLAGS += "-no-xinerama -no-tablet -no-xkb -no-opengl"
+QT_BASE_NAME = "qt4"
+QT_BASE_LIB = "libqt"
+QT_DIR_NAME = "qt4"
+QT_LIBINFIX = ""
+
+require qt4.inc
+
+inherit qt4x11