aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qt4
diff options
context:
space:
mode:
authorEric Bénard <eric@eukrea.com>2010-09-09 13:05:23 +0200
committerEric Bénard <eric@eukrea.com>2010-09-09 23:28:27 +0200
commite0535b507e222d698c30607f146705791a41efff (patch)
treeb36f05cc72121cf7767b639d80eb2a4e6b4cc0d3 /recipes/qt4
parentf24466c861dddd404fb74d1eefab28fa7ac450ac (diff)
downloadopenembedded-e0535b507e222d698c30607f146705791a41efff.tar.gz
fix bitbake ERRORS for machine not having virtual/egl
* several recipes depend on virtual/egl which currently has only one provider : powervr-drivers/libgles-omap. This provider sets COMPATIBLE_MACHINE to a few TI based machines. When building for machines which don't provide virtual/egl, we get the following errors : ERROR: '['path_to/openembedded/recipes/qt4/qt4-embedded-gles_4.6.3.bb']' RDEPENDS/RRECOMMENDS or otherwise requires the runtime entity 'qt4-embedded-gles' but it wasn't found in any PACKAGE or RPROVIDES variables of any buildable targets. ERROR: '[]' RDEPENDS/RRECOMMENDS or otherwise requires the runtime entity 'virtual/egl' but it wasn't found in any PACKAGE or RPROVIDES variables * This patch creates a egl.inc which contains the compatible machines for recipes depending on virtual/egl and thus will workaround this error. Signed-off-by: Eric Bénard <eric@eukrea.com> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/qt4')
-rw-r--r--recipes/qt4/qt4-embedded-gles_4.6.0.bb1
-rw-r--r--recipes/qt4/qt4-embedded-gles_4.6.2.bb1
-rw-r--r--recipes/qt4/qt4-embedded-gles_4.6.3.bb1
-rw-r--r--recipes/qt4/qt4-x11-free-gles_4.5.2.bb1
-rw-r--r--recipes/qt4/qt4-x11-free-gles_4.6.0.bb1
-rw-r--r--recipes/qt4/qt4-x11-free-gles_4.6.2.bb1
-rw-r--r--recipes/qt4/qt4-x11-free-gles_4.6.3.bb1
7 files changed, 7 insertions, 0 deletions
diff --git a/recipes/qt4/qt4-embedded-gles_4.6.0.bb b/recipes/qt4/qt4-embedded-gles_4.6.0.bb
index 3b3ea153f1..3e132bf753 100644
--- a/recipes/qt4/qt4-embedded-gles_4.6.0.bb
+++ b/recipes/qt4/qt4-embedded-gles_4.6.0.bb
@@ -10,3 +10,4 @@ require qt-4.6.0.inc
FILESPATHPKG .= ":qt4-embedded-${PV}:qt4-embedded"
DEPENDS += "virtual/egl"
+require recipes/egl/egl.inc
diff --git a/recipes/qt4/qt4-embedded-gles_4.6.2.bb b/recipes/qt4/qt4-embedded-gles_4.6.2.bb
index 21c461a11c..0b047fc5de 100644
--- a/recipes/qt4/qt4-embedded-gles_4.6.2.bb
+++ b/recipes/qt4/qt4-embedded-gles_4.6.2.bb
@@ -11,3 +11,4 @@ SRC_URI += "file://cursor-hack.diff"
FILESPATHPKG .= ":qt4-embedded-${PV}:qt4-embedded"
DEPENDS += "virtual/egl"
+require recipes/egl/egl.inc
diff --git a/recipes/qt4/qt4-embedded-gles_4.6.3.bb b/recipes/qt4/qt4-embedded-gles_4.6.3.bb
index 21c461a11c..0b047fc5de 100644
--- a/recipes/qt4/qt4-embedded-gles_4.6.3.bb
+++ b/recipes/qt4/qt4-embedded-gles_4.6.3.bb
@@ -11,3 +11,4 @@ SRC_URI += "file://cursor-hack.diff"
FILESPATHPKG .= ":qt4-embedded-${PV}:qt4-embedded"
DEPENDS += "virtual/egl"
+require recipes/egl/egl.inc
diff --git a/recipes/qt4/qt4-x11-free-gles_4.5.2.bb b/recipes/qt4/qt4-x11-free-gles_4.5.2.bb
index 3fe721810f..57e15242ed 100644
--- a/recipes/qt4/qt4-x11-free-gles_4.5.2.bb
+++ b/recipes/qt4/qt4-x11-free-gles_4.5.2.bb
@@ -11,6 +11,7 @@ require qt4-x11-free_${PV}.bb
PR = "${INC_PR}.3"
DEPENDS += "virtual/egl"
+require recipes/egl/egl.inc
PROVIDES += "qt4-x11-free"
#SRC_URI += "file://sgx-hack.patch"
SRC_URI += "file://hack-out-pg_config.patch"
diff --git a/recipes/qt4/qt4-x11-free-gles_4.6.0.bb b/recipes/qt4/qt4-x11-free-gles_4.6.0.bb
index dfd53e53a9..0821595f88 100644
--- a/recipes/qt4/qt4-x11-free-gles_4.6.0.bb
+++ b/recipes/qt4/qt4-x11-free-gles_4.6.0.bb
@@ -13,4 +13,5 @@ QT_CONFIG_FLAGS += " \
FILESPATHPKG .= ":qt4-x11-free-${PV}:qt4-x11-free"
DEPENDS += "virtual/egl"
+require recipes/egl/egl.inc
PROVIDES += "qt4-x11-free"
diff --git a/recipes/qt4/qt4-x11-free-gles_4.6.2.bb b/recipes/qt4/qt4-x11-free-gles_4.6.2.bb
index 307770f0dc..b7cbde5591 100644
--- a/recipes/qt4/qt4-x11-free-gles_4.6.2.bb
+++ b/recipes/qt4/qt4-x11-free-gles_4.6.2.bb
@@ -13,4 +13,5 @@ QT_CONFIG_FLAGS += " \
FILESPATHPKG .= ":qt4-x11-free-${PV}:qt4-x11-free"
DEPENDS += "virtual/egl"
+require recipes/egl/egl.inc
PROVIDES += "qt4-x11-free"
diff --git a/recipes/qt4/qt4-x11-free-gles_4.6.3.bb b/recipes/qt4/qt4-x11-free-gles_4.6.3.bb
index 307770f0dc..b7cbde5591 100644
--- a/recipes/qt4/qt4-x11-free-gles_4.6.3.bb
+++ b/recipes/qt4/qt4-x11-free-gles_4.6.3.bb
@@ -13,4 +13,5 @@ QT_CONFIG_FLAGS += " \
FILESPATHPKG .= ":qt4-x11-free-${PV}:qt4-x11-free"
DEPENDS += "virtual/egl"
+require recipes/egl/egl.inc
PROVIDES += "qt4-x11-free"