summaryrefslogtreecommitdiffstats
path: root/recipes/qt4
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-07-01 10:28:05 +0200
committerKoen Kooi <koen@openembedded.org>2010-07-01 11:02:55 +0200
commit04d4e77616c3b3712ba8ebe4412f140892449907 (patch)
tree80ef411562f93dd7e9de57c15a1abbffdce10a23 /recipes/qt4
parentb4c03a78b3b8c58aefbbf4d32c356d128a7ebf1a (diff)
downloadopenembedded-04d4e77616c3b3712ba8ebe4412f140892449907.tar.gz
qt4-embedded 4.7.0b1: add WIP recipe
qt4-e 4.7b1: make it thru configure, fail in do_compile now: | qxml.cpp:(.text._ZN7QVectorI7QStringE7reallocEii[QVector<QString>::realloc(int, int)]+0x2c4): undefined reference to `qBadAlloc()'
Diffstat (limited to 'recipes/qt4')
-rw-r--r--recipes/qt4/qt4-embedded/0006-freetype-host-includes.patch20
-rw-r--r--recipes/qt4/qt4-embedded_4.7.0-beta1.bb16
2 files changed, 36 insertions, 0 deletions
diff --git a/recipes/qt4/qt4-embedded/0006-freetype-host-includes.patch b/recipes/qt4/qt4-embedded/0006-freetype-host-includes.patch
new file mode 100644
index 0000000000..987c425138
--- /dev/null
+++ b/recipes/qt4/qt4-embedded/0006-freetype-host-includes.patch
@@ -0,0 +1,20 @@
+From c9ab62bd9a56643574b3ae6e59e0ca776d4860d2 Mon Sep 17 00:00:00 2001
+From: Michael Krelin <hacker@klever.net>
+Date: Mon, 4 Jun 2007 14:48:50 +0200
+Subject: [PATCH] freetype host includes
+
+---
+ config.tests/unix/freetype/freetype.pri | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+Index: qt-embedded-linux-opensource-src-4.5.0/config.tests/unix/freetype/freetype.pri
+===================================================================
+--- qt-embedded-linux-opensource-src-4.5.0.orig/config.tests/unix/freetype/freetype.pri 2009-02-25 22:32:32.000000000 +0100
++++ qt-embedded-linux-opensource-src-4.5.0/config.tests/unix/freetype/freetype.pri 2009-03-26 17:14:16.000000000 +0100
+@@ -1,5 +1,5 @@
+ !cross_compile {
+- TRY_INCLUDEPATHS = /include /usr/include $$QMAKE_INCDIR $$QMAKE_INCDIR_X11 $$INCLUDEPATH
++ TRY_INCLUDEPATHS = $$QMAKE_INCDIR $$QMAKE_INCDIR_X11 $$INCLUDEPATH
+ # LSB doesn't allow using headers from /include or /usr/include
+ linux-lsb-g++:TRY_INCLUDEPATHS = $$QMAKE_INCDIR $$QMAKE_INCDIR_X11 $$INCLUDEPATH
+ for(p, TRY_INCLUDEPATHS) {
diff --git a/recipes/qt4/qt4-embedded_4.7.0-beta1.bb b/recipes/qt4/qt4-embedded_4.7.0-beta1.bb
new file mode 100644
index 0000000000..1dbb4aa4bf
--- /dev/null
+++ b/recipes/qt4/qt4-embedded_4.7.0-beta1.bb
@@ -0,0 +1,16 @@
+DEFAULT_PREFERENCE = "-1"
+
+require qt4-embedded.inc
+
+SRCVER = "4.7.0-beta1"
+PV = "4.6.2+${SRCVER}"
+PR = "${INC_PR}.0"
+
+QT_CONFIG_FLAGS_append_armv6 = " -no-neon "
+
+require qt-${PV}.inc
+
+QT_CONFIG_FLAGS += " \
+ -exceptions \
+"
+