summaryrefslogtreecommitdiffstats
path: root/recipes/qt4
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-07-09 09:29:15 +0200
committerKoen Kooi <koen@openembedded.org>2009-07-09 09:29:15 +0200
commit09ba978139d5990f873d26c81fff7b1eb3c4e920 (patch)
treec35122968fbccade71796b27ac18f661d401900d /recipes/qt4
parentea73bad66e153a56e13c4b3d0f72beed3b5ab13f (diff)
downloadopenembedded-09ba978139d5990f873d26c81fff7b1eb3c4e920.tar.gz
qt4-x11-free-gles: add an OopenGL ES1 version of qt4-x11-free
* currently sgx specific, but making it generic is easy
Diffstat (limited to 'recipes/qt4')
-rw-r--r--recipes/qt4/qt4-x11-free-gles-4.5.2/sgx-hack.patch20
-rw-r--r--recipes/qt4/qt4-x11-free-gles_4.5.2.bb23
-rw-r--r--recipes/qt4/qt4-x11-free.inc4
-rw-r--r--recipes/qt4/qt4.inc1
4 files changed, 46 insertions, 2 deletions
diff --git a/recipes/qt4/qt4-x11-free-gles-4.5.2/sgx-hack.patch b/recipes/qt4/qt4-x11-free-gles-4.5.2/sgx-hack.patch
new file mode 100644
index 0000000000..77f0e2a2fd
--- /dev/null
+++ b/recipes/qt4/qt4-x11-free-gles-4.5.2/sgx-hack.patch
@@ -0,0 +1,20 @@
+--- /tmp/qegl_p.h 2009-07-09 08:42:12.000000000 +0200
++++ qt-x11-opensource-src-4.5.2/src/opengl/qegl_p.h 2009-07-09 08:42:30.000000000 +0200
+@@ -65,7 +65,7 @@
+ #else
+ #include <GLES/egl.h>
+ #endif
+-#if !defined(EGL_VERSION_1_3) && !defined(QEGL_NATIVE_TYPES_DEFINED)
++//#if !defined(EGL_VERSION_1_3) && !defined(QEGL_NATIVE_TYPES_DEFINED)
+ #undef EGLNativeWindowType
+ #undef EGLNativePixmapType
+ #undef EGLNativeDisplayType
+@@ -73,7 +73,7 @@
+ typedef NativePixmapType EGLNativePixmapType;
+ typedef NativeDisplayType EGLNativeDisplayType;
+ #define QEGL_NATIVE_TYPES_DEFINED 1
+-#endif
++//#endif
+ QT_END_INCLUDE_NAMESPACE
+
+ class QX11Info;
diff --git a/recipes/qt4/qt4-x11-free-gles_4.5.2.bb b/recipes/qt4/qt4-x11-free-gles_4.5.2.bb
new file mode 100644
index 0000000000..55a8b907ab
--- /dev/null
+++ b/recipes/qt4/qt4-x11-free-gles_4.5.2.bb
@@ -0,0 +1,23 @@
+# recipe to build GLES gfxdriver
+
+FILESPATHPKG =. "qt4-x11-free-${PV}:qt4-x11-free:"
+
+QT_GLFLAGS = "-opengl es1"
+
+require qt4-x11-free_${PV}.bb
+
+DEPENDS += "virtual/egl"
+SRC_URI += "file://sgx-hack.patch;patch=1"
+
+export EXTRA_QMAKE_MUNGE = " glmunge "
+
+glmunge() {
+sed -e /QMAKE_INCDIR_OPENGL/d -e /QMAKE_LIBDIR_OPENGL/d -e /QMAKE_LIBS_OPENGL/d -e /QMAKE_LIBS_OPENGL_QT/d -i mkspecs/${OE_QMAKE_PLATFORM}/qmake.conf
+echo "QMAKE_INCDIR_OPENGL = ${STAGING_INCDIR}/GLES/" >> mkspecs/${OE_QMAKE_PLATFORM}/qmake.conf
+echo "QMAKE_LIBDIR_OPENGL = ${STAGING_LIBDIR}" >> mkspecs/${OE_QMAKE_PLATFORM}/qmake.conf
+echo "QMAKE_LIBS_OPENGL = -lEGL -lGLES_CM -lIMGegl -lsrv_um" >> mkspecs/${OE_QMAKE_PLATFORM}/qmake.conf
+echo "QMAKE_LIBS_OPENGL_QT = -lEGL -lGLES_CM -lIMGegl -lsrv_um" >> mkspecs/${OE_QMAKE_PLATFORM}/qmake.conf
+}
+
+
+
diff --git a/recipes/qt4/qt4-x11-free.inc b/recipes/qt4/qt4-x11-free.inc
index a021b6fc13..52db1872ef 100644
--- a/recipes/qt4/qt4-x11-free.inc
+++ b/recipes/qt4/qt4-x11-free.inc
@@ -21,8 +21,8 @@ SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-x11-opensource-src-${PV}.tar.gz
"
S = "${WORKDIR}/qt-x11-opensource-src-${PV}"
-
-QT_CONFIG_FLAGS += "-no-xinerama -no-xkb -no-opengl"
+QT_GLFLAGS ?= "-no-opengl"
+QT_CONFIG_FLAGS += "-no-xinerama -no-xkb ${QT_GLFLAGS}"
QT_BASE_NAME = "qt4"
QT_BASE_LIB = "libqt"
QT_DIR_NAME = "qt4"
diff --git a/recipes/qt4/qt4.inc b/recipes/qt4/qt4.inc
index 98c11fdf2a..427bbaecb4 100644
--- a/recipes/qt4/qt4.inc
+++ b/recipes/qt4/qt4.inc
@@ -196,6 +196,7 @@ python populate_packages_prepend() {
qtopia_split('decorations', 'decoration', '^libqdecoration(.*)\.so$')
qtopia_split('designer', 'designer', '^lib(.*)\.so$')
qtopia_split('gfxdrivers', 'gfxdriver', '^libq(.*)\.so$')
+ qtopia_split('graphicssystems','graphicssystems', '^libq(.*)\.so$')
qtopia_split('mousedrivers', 'mousedriver', '^libq(.*)mousedriver\.so$')
qtopia_split('iconengines', 'iconengine', '^libq(.*)\.so$')
qtopia_split('imageformats', 'imageformat', '^libq(.*)\.so$')