summaryrefslogtreecommitdiffstats
path: root/recipes/qt4
diff options
context:
space:
mode:
authorIhar Hrachyshka <ihar.hrachyshka@gmail.com>2009-06-03 05:37:15 +0000
committerDenys Dmytriyenko <denis@denix.org>2009-06-09 23:21:35 -0400
commit399cbecbebdd106797306e17a5e4dd5af08d55c8 (patch)
tree628273fe3ca388a05a10aa744b1461f2f0151f11 /recipes/qt4
parenta82e4ac8f6eae126a03a2e515d42fdb804c15046 (diff)
downloadopenembedded-399cbecbebdd106797306e17a5e4dd5af08d55c8.tar.gz
qt4-x11-free: generalize recipes, port them to INC_PR
Signed-off-by: Ihar Hrachyshka <ihar.hrachyshka@gmail.com> Acked-by: Tom Rini <trini@embeddedalley.com> Acked-by: Denys Dmytriyenko <denis@denix.org>
Diffstat (limited to 'recipes/qt4')
-rw-r--r--recipes/qt4/qt4-x11-free.inc34
-rw-r--r--recipes/qt4/qt4-x11-free/0003-no-tools.patch18
-rw-r--r--recipes/qt4/qt4-x11-free/0006-freetype-host-includes.patch20
-rw-r--r--recipes/qt4/qt4-x11-free/0007-openssl-host-includes.patch20
-rw-r--r--recipes/qt4/qt4-x11-free/0008-qt-lib-infix.patch34
-rw-r--r--recipes/qt4/qt4-x11-free_4.4.3.bb35
-rw-r--r--recipes/qt4/qt4-x11-free_4.5.1.bb33
7 files changed, 132 insertions, 62 deletions
diff --git a/recipes/qt4/qt4-x11-free.inc b/recipes/qt4/qt4-x11-free.inc
new file mode 100644
index 0000000000..23fa33f118
--- /dev/null
+++ b/recipes/qt4/qt4-x11-free.inc
@@ -0,0 +1,34 @@
+DESCRIPTION = "Qt is a versatile cross-platform application framework -- this is the X11 version."
+SECTION = "x11/libs"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.trolltech.com"
+LICENSE = "GPL QPL"
+DEPENDS += "virtual/libx11 fontconfig xft libxext libxrender libxrandr libxcursor"
+PROVIDES = "qt4x11"
+
+INC_PR = "r10"
+
+SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-x11-opensource-src-${PV}.tar.gz \
+ file://0001-cross-compile.patch;patch=1 \
+ file://0002-fix-resinit-declaration.patch;patch=1 \
+ file://0003-no-tools.patch;patch=1 \
+ file://0004-no-qmake.patch;patch=1 \
+ file://0006-freetype-host-includes.patch;patch=1 \
+ file://0007-openssl-host-includes.patch;patch=1 \
+ file://0008-qt-lib-infix.patch;patch=1 \
+ file://g++.conf \
+ file://linux.conf \
+ "
+S = "${WORKDIR}/qt-x11-opensource-src-${PV}"
+
+
+QT_CONFIG_FLAGS += "-no-xinerama -no-xkb -no-opengl"
+QT_BASE_NAME = "qt4"
+QT_BASE_LIB = "libqt"
+QT_DIR_NAME = "qt4"
+QT_LIBINFIX = ""
+
+require qt4.inc
+
+inherit qt4x11
+
diff --git a/recipes/qt4/qt4-x11-free/0003-no-tools.patch b/recipes/qt4/qt4-x11-free/0003-no-tools.patch
new file mode 100644
index 0000000000..3829ffcdc5
--- /dev/null
+++ b/recipes/qt4/qt4-x11-free/0003-no-tools.patch
@@ -0,0 +1,18 @@
+Index: qt-embedded-linux-opensource-src-4.5.0/src/src.pro
+===================================================================
+--- qt-embedded-linux-opensource-src-4.5.0.orig/src/src.pro 2009-02-25 22:32:41.000000000 +0100
++++ qt-embedded-linux-opensource-src-4.5.0/src/src.pro 2009-03-26 17:11:07.000000000 +0100
+@@ -6,12 +6,9 @@
+ wince*:{
+ SRC_SUBDIRS += src_corelib src_xml src_gui src_sql src_network src_script src_testlib
+ } else {
+- SRC_SUBDIRS += src_tools_bootstrap src_tools_moc src_tools_rcc src_tools_uic src_corelib src_xml src_network src_gui src_sql src_script src_testlib
++ SRC_SUBDIRS += src_corelib src_xml src_network src_gui src_sql src_script src_testlib
+ contains(QT_CONFIG, qt3support): SRC_SUBDIRS += src_qt3support
+ contains(QT_CONFIG, dbus):SRC_SUBDIRS += src_dbus
+- !cross_compile {
+- contains(QT_CONFIG, qt3support): SRC_SUBDIRS += src_tools_uic3
+- }
+ }
+ win32:!contains(QT_EDITION, OpenSource|Console): {
+ SRC_SUBDIRS += src_activeqt
diff --git a/recipes/qt4/qt4-x11-free/0006-freetype-host-includes.patch b/recipes/qt4/qt4-x11-free/0006-freetype-host-includes.patch
new file mode 100644
index 0000000000..987c425138
--- /dev/null
+++ b/recipes/qt4/qt4-x11-free/0006-freetype-host-includes.patch
@@ -0,0 +1,20 @@
+From c9ab62bd9a56643574b3ae6e59e0ca776d4860d2 Mon Sep 17 00:00:00 2001
+From: Michael Krelin <hacker@klever.net>
+Date: Mon, 4 Jun 2007 14:48:50 +0200
+Subject: [PATCH] freetype host includes
+
+---
+ config.tests/unix/freetype/freetype.pri | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+Index: qt-embedded-linux-opensource-src-4.5.0/config.tests/unix/freetype/freetype.pri
+===================================================================
+--- qt-embedded-linux-opensource-src-4.5.0.orig/config.tests/unix/freetype/freetype.pri 2009-02-25 22:32:32.000000000 +0100
++++ qt-embedded-linux-opensource-src-4.5.0/config.tests/unix/freetype/freetype.pri 2009-03-26 17:14:16.000000000 +0100
+@@ -1,5 +1,5 @@
+ !cross_compile {
+- TRY_INCLUDEPATHS = /include /usr/include $$QMAKE_INCDIR $$QMAKE_INCDIR_X11 $$INCLUDEPATH
++ TRY_INCLUDEPATHS = $$QMAKE_INCDIR $$QMAKE_INCDIR_X11 $$INCLUDEPATH
+ # LSB doesn't allow using headers from /include or /usr/include
+ linux-lsb-g++:TRY_INCLUDEPATHS = $$QMAKE_INCDIR $$QMAKE_INCDIR_X11 $$INCLUDEPATH
+ for(p, TRY_INCLUDEPATHS) {
diff --git a/recipes/qt4/qt4-x11-free/0007-openssl-host-includes.patch b/recipes/qt4/qt4-x11-free/0007-openssl-host-includes.patch
new file mode 100644
index 0000000000..3409cc0bf2
--- /dev/null
+++ b/recipes/qt4/qt4-x11-free/0007-openssl-host-includes.patch
@@ -0,0 +1,20 @@
+From d45943adb443ad4b85ca4504952dee743c675e1e Mon Sep 17 00:00:00 2001
+From: Michael Krelin <hacker@klever.net>
+Date: Mon, 4 Jun 2007 14:58:34 +0200
+Subject: [PATCH] openssl host includes
+
+---
+ config.tests/unix/openssl/openssl.pri | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+Index: qt-embedded-linux-opensource-src-4.5.0/config.tests/unix/openssl/openssl.pri
+===================================================================
+--- qt-embedded-linux-opensource-src-4.5.0.orig/config.tests/unix/openssl/openssl.pri 2009-02-25 22:32:32.000000000 +0100
++++ qt-embedded-linux-opensource-src-4.5.0/config.tests/unix/openssl/openssl.pri 2009-03-26 17:16:28.000000000 +0100
+@@ -1,5 +1,5 @@
+ !cross_compile {
+- TRY_INCLUDEPATHS = /include /usr/include /usr/local/include $$QMAKE_INCDIR $$INCLUDEPATH
++ TRY_INCLUDEPATHS = $$QMAKE_INCDIR $$INCLUDEPATH
+ # LSB doesn't allow using headers from /include or /usr/include
+ linux-lsb-g++:TRY_INCLUDEPATHS = $$QMAKE_INCDIR $$INCLUDEPATH
+ for(p, TRY_INCLUDEPATHS) {
diff --git a/recipes/qt4/qt4-x11-free/0008-qt-lib-infix.patch b/recipes/qt4/qt4-x11-free/0008-qt-lib-infix.patch
new file mode 100644
index 0000000000..3efaff37d3
--- /dev/null
+++ b/recipes/qt4/qt4-x11-free/0008-qt-lib-infix.patch
@@ -0,0 +1,34 @@
+Index: qt-embedded-linux-opensource-src-4.5.0/mkspecs/features/uitools.prf
+===================================================================
+--- qt-embedded-linux-opensource-src-4.5.0.orig/mkspecs/features/uitools.prf 2009-02-25 22:32:34.000000000 +0100
++++ qt-embedded-linux-opensource-src-4.5.0/mkspecs/features/uitools.prf 2009-03-26 17:17:27.000000000 +0100
+@@ -2,10 +2,10 @@
+ qt:load(qt)
+
+ # Include the correct version of the UiLoader library
+-QTUITOOLS_LINKAGE = -lQtUiTools
++QTUITOOLS_LINKAGE = -lQtUiTools$${QT_LIBINFIX}
+ CONFIG(debug, debug|release) {
+- mac: QTUITOOLS_LINKAGE = -lQtUiTools_debug
+- win32: QTUITOOLS_LINKAGE = -lQtUiToolsd
++ mac: QTUITOOLS_LINKAGE = -lQtUiTools$${QT_LIBINFIX}_debug
++ win32: QTUITOOLS_LINKAGE = -lQtUiTools$${QT_LIBINFIX}d
+ }
+ LIBS += $$QTUITOOLS_LINKAGE
+
+Index: qt-embedded-linux-opensource-src-4.5.0/tools/designer/src/uitools/uitools.pro
+===================================================================
+--- qt-embedded-linux-opensource-src-4.5.0.orig/tools/designer/src/uitools/uitools.pro 2009-02-25 22:32:42.000000000 +0100
++++ qt-embedded-linux-opensource-src-4.5.0/tools/designer/src/uitools/uitools.pro 2009-03-26 17:17:27.000000000 +0100
+@@ -1,5 +1,5 @@
+ TEMPLATE = lib
+-TARGET = $$qtLibraryTarget(QtUiTools)
++TARGET = QtUiTools
+ QT += xml
+ CONFIG += qt staticlib
+ DESTDIR = ../../../../lib
+@@ -39,3 +39,4 @@
+ QMAKE_PKGCONFIG_REQUIRES += QtXml
+ }
+
++TARGET = $$qtLibraryTarget($$TARGET$$QT_LIBINFIX) #do this towards the end
diff --git a/recipes/qt4/qt4-x11-free_4.4.3.bb b/recipes/qt4/qt4-x11-free_4.4.3.bb
index 08a56a47c3..a3538c9199 100644
--- a/recipes/qt4/qt4-x11-free_4.4.3.bb
+++ b/recipes/qt4/qt4-x11-free_4.4.3.bb
@@ -1,32 +1,3 @@
-DESCRIPTION = "Qt is a versatile cross-platform application framework -- this is the X11 version."
-SECTION = "x11/libs"
-PRIORITY = "optional"
-HOMEPAGE = "http://www.trolltech.com"
-LICENSE = "GPL QPL"
-DEPENDS += "virtual/libx11 fontconfig xft libxext libxrender libxrandr libxcursor"
-PROVIDES = "qt4x11"
-PR = "r10"
-
-SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-x11-opensource-src-${PV}.tar.gz \
- file://0001-cross-compile.patch;patch=1 \
- file://0002-fix-resinit-declaration.patch;patch=1 \
- file://0003-no-tools.patch;patch=1 \
- file://0004-no-qmake.patch;patch=1 \
- file://0006-freetype-host-includes.patch;patch=1 \
- file://0007-openssl-host-includes.patch;patch=1 \
- file://0008-qt-lib-infix.patch;patch=1 \
- file://g++.conf \
- file://linux.conf \
- "
-S = "${WORKDIR}/qt-x11-opensource-src-${PV}"
-
-
-QT_CONFIG_FLAGS += "-no-xinerama -no-tablet -no-xkb -no-opengl"
-QT_BASE_NAME = "qt4"
-QT_BASE_LIB = "libqt"
-QT_DIR_NAME = "qt4"
-QT_LIBINFIX = ""
-
-require qt4.inc
-
-inherit qt4x11
+include qt4-x11-free.inc
+PR = "${INC_PR}.1"
+QT_CONFIG_FLAGS += "-no-tablet"
diff --git a/recipes/qt4/qt4-x11-free_4.5.1.bb b/recipes/qt4/qt4-x11-free_4.5.1.bb
index af3a7c702c..1cc637a548 100644
--- a/recipes/qt4/qt4-x11-free_4.5.1.bb
+++ b/recipes/qt4/qt4-x11-free_4.5.1.bb
@@ -1,31 +1,4 @@
-DESCRIPTION = "Qt is a versatile cross-platform application framework -- this is the X11 version."
-SECTION = "x11/libs"
-PRIORITY = "optional"
-HOMEPAGE = "http://www.trolltech.com"
-LICENSE = "GPL LGPL QPL"
-DEPENDS += "virtual/libx11 fontconfig xft libxext libxrender libxrandr libxcursor"
-PROVIDES = "qt4x11"
+include qt4-x11-free.inc
+LICENSE += "LGPL"
+PR = "${INC_PR}.1"
-SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-x11-opensource-src-${PV}.tar.gz \
- file://0001-cross-compile.patch;patch=1 \
- file://0002-fix-resinit-declaration.patch;patch=1 \
- file://${PV}/0003-no-tools.patch;patch=1 \
- file://0004-no-qmake.patch;patch=1 \
- file://${PV}/0006-freetype-host-includes.patch;patch=1 \
- file://${PV}/0007-openssl-host-includes.patch;patch=1 \
- file://${PV}/0008-qt-lib-infix.patch;patch=1 \
- file://g++.conf \
- file://linux.conf \
- "
-S = "${WORKDIR}/qt-x11-opensource-src-${PV}"
-
-
-QT_CONFIG_FLAGS += "-no-xinerama -no-xkb -no-opengl"
-QT_BASE_NAME = "qt4"
-QT_BASE_LIB = "libqt"
-QT_DIR_NAME = "qt4"
-QT_LIBINFIX = ""
-
-require qt4.inc
-
-inherit qt4x11