summaryrefslogtreecommitdiffstats
path: root/recipes/qt4
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-23 20:23:53 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:53:41 -0700
commitbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (patch)
tree96f28e2f5133d68c3e3dadabaa2339340671454f /recipes/qt4
parentfab0af3aefee22b21541e403d3c356a6979bfa63 (diff)
downloadopenembedded-bf7d0467a0788a7fcc1c96e0dc35a25ae09278a0.tar.gz
Rename url params patch=<ignored>/pnum=<n> to apply={yes,no}/striplevel=<n>
I think this makes the behavior rather more clear. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/qt4')
-rw-r--r--recipes/qt4/qt-4.6.0.inc70
-rw-r--r--recipes/qt4/qt-4.6.2.inc20
-rw-r--r--recipes/qt4/qt4-embedded-gles_4.5.2.bb.disabled2
-rw-r--r--recipes/qt4/qt4-embedded-gles_4.6.2.bb2
-rw-r--r--recipes/qt4/qt4-embedded.inc18
-rw-r--r--recipes/qt4/qt4-embedded_4.5.2.bb4
-rw-r--r--recipes/qt4/qt4-tools-native.inc2
-rw-r--r--recipes/qt4/qt4-tools-native_4.4.3.bb4
-rw-r--r--recipes/qt4/qt4-tools-native_4.5.2.bb4
-rw-r--r--recipes/qt4/qt4-tools-sdk_4.5.2.bb4
-rw-r--r--recipes/qt4/qt4-tools-sdk_4.6.0.bb4
-rw-r--r--recipes/qt4/qt4-tools-sdk_4.6.2.bb4
-rw-r--r--recipes/qt4/qt4-x11-free-gles_4.5.2.bb4
-rw-r--r--recipes/qt4/qt4-x11-free-gles_git.bb.disabled16
-rw-r--r--recipes/qt4/qt4-x11-free.inc16
-rw-r--r--recipes/qt4/qt4-x11-free_4.5.2.bb2
16 files changed, 88 insertions, 88 deletions
diff --git a/recipes/qt4/qt-4.6.0.inc b/recipes/qt4/qt-4.6.0.inc
index c273a81397..60c9ecdd37 100644
--- a/recipes/qt4/qt-4.6.0.inc
+++ b/recipes/qt4/qt-4.6.0.inc
@@ -3,46 +3,46 @@ DEFAULT_PREFERENCE = "-1"
FILESPATHPKG .= ":qt-${PV}"
SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-everywhere-opensource-src-${PV}.tar.gz \
- file://0001-cross-compile.patch;patch=1 \
- file://0002-fix-resinit-declaration.patch;patch=1 \
- file://0004-no-qmake.patch;patch=1 \
- file://0006-freetype-host-includes.patch;patch=1 \
- file://0008-qt-lib-infix.patch;patch=1 \
- file://0009-support-2bpp.patch;patch=1 \
- file://0010-no-simpledecoration-example.patch;patch=1 \
- file://fix-config-tests.patch;patch=1 \
+ file://0001-cross-compile.patch;apply=yes \
+ file://0002-fix-resinit-declaration.patch;apply=yes \
+ file://0004-no-qmake.patch;apply=yes \
+ file://0006-freetype-host-includes.patch;apply=yes \
+ file://0008-qt-lib-infix.patch;apply=yes \
+ file://0009-support-2bpp.patch;apply=yes \
+ file://0010-no-simpledecoration-example.patch;apply=yes \
+ file://fix-config-tests.patch;apply=yes \
file://g++.conf \
file://linux.conf \
"
# Patches for '4.6' qt branch
SRC_URI += "\
- file://0860-Added-caching-of-vectorpaths-to-the-GL-paint-engine.patch;patch=1 \
- file://0917-Better-check-for-EGL-extension-strings.patch;patch=1 \
- file://0919-Rebind-window-surface-fbo-after-native-GL-rendering.patch;patch=1 \
- file://0943-Fixed-OpenGL-graphicssystem-issues-for-OpenGL-ES-2.0.patch;patch=1 \
- file://0945-Add-EGL_BUFFER_SIZE-to-QEglProperties-reduceConfigur.patch;patch=1 \
- file://0946-Fix-WA_TranslucentBackground-for-QGLWidgets-on-X11-E.patch;patch=1 \
- file://0947-Compressed-texture-binding-for-QtOpenGL-ETC1-and-PVR.patch;patch=1 \
- file://0951-Detect-GL2-paint-engine-based-on-fragment-shaders-no.patch;patch=1 \
- file://0971-Fix-GL_BGRA-formats-under-OpenGL-ES-systems.patch;patch=1 \
- file://0991-QGtkStyle-support-for-the-inner-border-property-in-G.patch;patch=1 \
- file://0992-Make-sure-a-context-is-current-when-loading-compress.patch;patch=1 \
- file://0993-Fix-upside-down-PVR-compressed-textures.patch;patch=1 \
- file://0996-Export-QGLShareRegister-because-qgl_share_reg-is-exp.patch;patch=1 \
- file://0998-Set-stacking-class-for-stays-on-top-windows-in-DFB.patch;patch=1 \
- file://0999-Enable-customizing-of-DirectFB-layer-to-use.patch;patch=1 \
- file://1008-GLES-2-should-not-use-a-multisampled-format-by-defau.patch;patch=1 \
- file://1115-Fix-QGLWidgets-created-with-an-alpha-channel-on-X11-.patch;patch=1 \
- file://1118-Fix-EGL-surface-leaks-when-re-parenting-QGLWidget-on.patch;patch=1 \
- file://1136-Disable-depth-testing-during-the-2D-QGLWidget-render.patch;patch=1 \
- file://1149-GL2Engine-Don-t-mark-brush-as-dirty-if-it-hasn-t-cha.patch;patch=1 \
- file://1157-Align-GL_RGB-lines-on-a-4-byte-boundary-when-uploadi.patch;patch=1 \
-# file://1165-NEON-configure-detection-and-initial-blend-function-.patch;patch=1 \
- file://1175-Fix-memory-leak-of-QGLGlyphCoord-objects-in-the-Open.patch;patch=1 \
- file://1197-Add-GLfloat-2-2-GLfloat-3-3-uniform-setters-to-QGLSh.patch;patch=1 \
- file://1198-Handle-broken-shaders-better-in-the-GL2-engine-s-sha.patch;patch=1 \
- file://1205-Fix-text-rendering-on-GL2-paint-engine.patch;patch=1 \
+ file://0860-Added-caching-of-vectorpaths-to-the-GL-paint-engine.patch;apply=yes \
+ file://0917-Better-check-for-EGL-extension-strings.patch;apply=yes \
+ file://0919-Rebind-window-surface-fbo-after-native-GL-rendering.patch;apply=yes \
+ file://0943-Fixed-OpenGL-graphicssystem-issues-for-OpenGL-ES-2.0.patch;apply=yes \
+ file://0945-Add-EGL_BUFFER_SIZE-to-QEglProperties-reduceConfigur.patch;apply=yes \
+ file://0946-Fix-WA_TranslucentBackground-for-QGLWidgets-on-X11-E.patch;apply=yes \
+ file://0947-Compressed-texture-binding-for-QtOpenGL-ETC1-and-PVR.patch;apply=yes \
+ file://0951-Detect-GL2-paint-engine-based-on-fragment-shaders-no.patch;apply=yes \
+ file://0971-Fix-GL_BGRA-formats-under-OpenGL-ES-systems.patch;apply=yes \
+ file://0991-QGtkStyle-support-for-the-inner-border-property-in-G.patch;apply=yes \
+ file://0992-Make-sure-a-context-is-current-when-loading-compress.patch;apply=yes \
+ file://0993-Fix-upside-down-PVR-compressed-textures.patch;apply=yes \
+ file://0996-Export-QGLShareRegister-because-qgl_share_reg-is-exp.patch;apply=yes \
+ file://0998-Set-stacking-class-for-stays-on-top-windows-in-DFB.patch;apply=yes \
+ file://0999-Enable-customizing-of-DirectFB-layer-to-use.patch;apply=yes \
+ file://1008-GLES-2-should-not-use-a-multisampled-format-by-defau.patch;apply=yes \
+ file://1115-Fix-QGLWidgets-created-with-an-alpha-channel-on-X11-.patch;apply=yes \
+ file://1118-Fix-EGL-surface-leaks-when-re-parenting-QGLWidget-on.patch;apply=yes \
+ file://1136-Disable-depth-testing-during-the-2D-QGLWidget-render.patch;apply=yes \
+ file://1149-GL2Engine-Don-t-mark-brush-as-dirty-if-it-hasn-t-cha.patch;apply=yes \
+ file://1157-Align-GL_RGB-lines-on-a-4-byte-boundary-when-uploadi.patch;apply=yes \
+# file://1165-NEON-configure-detection-and-initial-blend-function-.patch;apply=yes \
+ file://1175-Fix-memory-leak-of-QGLGlyphCoord-objects-in-the-Open.patch;apply=yes \
+ file://1197-Add-GLfloat-2-2-GLfloat-3-3-uniform-setters-to-QGLSh.patch;apply=yes \
+ file://1198-Handle-broken-shaders-better-in-the-GL2-engine-s-sha.patch;apply=yes \
+ file://1205-Fix-text-rendering-on-GL2-paint-engine.patch;apply=yes \
"
S = "${WORKDIR}/qt-everywhere-opensource-src-${PV}"
@@ -74,7 +74,7 @@ do_install_append() {
LICENSE = "LGPLv2.1 GPLv3"
SRC_URI += " \
- file://hack-out-pg_config.patch;patch=1"
+ file://hack-out-pg_config.patch;apply=yes"
SRC_URI[md5sum] = "2a7b5126f2450d8525af355fc4c12ad6"
SRC_URI[sha256sum] = "55259c813324f6383cbd441aa2f23e01c320b6d63fbe3b5d52a7715055d28589"
diff --git a/recipes/qt4/qt-4.6.2.inc b/recipes/qt4/qt-4.6.2.inc
index ffd7a1d431..38535836a8 100644
--- a/recipes/qt4/qt-4.6.2.inc
+++ b/recipes/qt4/qt-4.6.2.inc
@@ -3,15 +3,15 @@ DEFAULT_PREFERENCE = "-1"
FILESPATHPKG .= ":qt-${PV}"
SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-everywhere-opensource-src-${PV}.tar.gz \
- file://0001-cross-compile.patch;patch=1 \
- file://0002-fix-resinit-declaration.patch;patch=1 \
- file://0004-no-qmake.patch;patch=1 \
- file://0006-freetype-host-includes.patch;patch=1 \
- file://0008-qt-lib-infix.patch;patch=1 \
- file://0009-support-2bpp.patch;patch=1 \
- file://0010-no-simpledecoration-example.patch;patch=1 \
- file://fix-config-tests.patch;patch=1 \
- file://qt-config.patch;patch=1 \
+ file://0001-cross-compile.patch;apply=yes \
+ file://0002-fix-resinit-declaration.patch;apply=yes \
+ file://0004-no-qmake.patch;apply=yes \
+ file://0006-freetype-host-includes.patch;apply=yes \
+ file://0008-qt-lib-infix.patch;apply=yes \
+ file://0009-support-2bpp.patch;apply=yes \
+ file://0010-no-simpledecoration-example.patch;apply=yes \
+ file://fix-config-tests.patch;apply=yes \
+ file://qt-config.patch;apply=yes \
file://g++.conf \
file://linux.conf \
"
@@ -61,7 +61,7 @@ do_install_append() {
LICENSE = "LGPLv2.1 GPLv3"
SRC_URI += " \
- file://hack-out-pg_config.patch;patch=1"
+ file://hack-out-pg_config.patch;apply=yes"
SRC_URI[md5sum] = "eb651ee4b157c01696aa56777fc6e0e5"
SRC_URI[sha256sum] = "176f51ddb06dce67ab4b2efc6b327dc21ed8f764c5d97acc15ff1f907c2affae"
diff --git a/recipes/qt4/qt4-embedded-gles_4.5.2.bb.disabled b/recipes/qt4/qt4-embedded-gles_4.5.2.bb.disabled
index a888e7d6be..06a2815cd4 100644
--- a/recipes/qt4/qt4-embedded-gles_4.5.2.bb.disabled
+++ b/recipes/qt4/qt4-embedded-gles_4.5.2.bb.disabled
@@ -10,7 +10,7 @@ LICENSE = "LGPLv2.1 GPLv3"
DEPENDS += "virtual/egl"
PROVIDES += "qt4-embedded"
-SRC_URI += "file://sgx-hack.patch;patch=1"
+SRC_URI += "file://sgx-hack.patch;apply=yes"
export EXTRA_QMAKE_MUNGE = " glmunge "
diff --git a/recipes/qt4/qt4-embedded-gles_4.6.2.bb b/recipes/qt4/qt4-embedded-gles_4.6.2.bb
index 098a558c4e..6cd5b53006 100644
--- a/recipes/qt4/qt4-embedded-gles_4.6.2.bb
+++ b/recipes/qt4/qt4-embedded-gles_4.6.2.bb
@@ -6,7 +6,7 @@ QT_GLFLAGS = "-opengl es2 -depths 16,24,32 -plugin-gfx-powervr"
require qt-${PV}.inc
-SRC_URI += "file://cursor-hack.diff;patch=1"
+SRC_URI += "file://cursor-hack.diff;apply=yes"
FILESPATHPKG .= ":qt4-embedded-${PV}:qt4-embedded"
diff --git a/recipes/qt4/qt4-embedded.inc b/recipes/qt4/qt4-embedded.inc
index 888b1b8ad8..a3dd9949c4 100644
--- a/recipes/qt4/qt4-embedded.inc
+++ b/recipes/qt4/qt4-embedded.inc
@@ -12,15 +12,15 @@ QT_DIR_NAME = "qtopia"
QT_LIBINFIX = "E"
SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-${PV}.tar.bz2 \
- file://0001-cross-compile.patch;patch=1 \
- file://0002-fix-resinit-declaration.patch;patch=1 \
- file://0003-no-tools.patch;patch=1 \
- file://0004-no-qmake.patch;patch=1 \
- file://0006-freetype-host-includes.patch;patch=1 \
- file://0007-openssl-host-includes.patch;patch=1 \
- file://0008-qt-lib-infix.patch;patch=1 \
- file://0009-support-2bpp.patch;patch=1 \
- file://fix-config-tests.patch;patch=1 \
+ file://0001-cross-compile.patch;apply=yes \
+ file://0002-fix-resinit-declaration.patch;apply=yes \
+ file://0003-no-tools.patch;apply=yes \
+ file://0004-no-qmake.patch;apply=yes \
+ file://0006-freetype-host-includes.patch;apply=yes \
+ file://0007-openssl-host-includes.patch;apply=yes \
+ file://0008-qt-lib-infix.patch;apply=yes \
+ file://0009-support-2bpp.patch;apply=yes \
+ file://fix-config-tests.patch;apply=yes \
file://g++.conf \
file://linux.conf \
"
diff --git a/recipes/qt4/qt4-embedded_4.5.2.bb b/recipes/qt4/qt4-embedded_4.5.2.bb
index ab876ece78..672992c78d 100644
--- a/recipes/qt4/qt4-embedded_4.5.2.bb
+++ b/recipes/qt4/qt4-embedded_4.5.2.bb
@@ -3,8 +3,8 @@ require qt4-embedded.inc
PR = "${INC_PR}.1"
LICENSE = "LGPLv2.1 GPLv3"
-SRC_URI += "file://0010-no-simpledecoration-example.patch;patch=1 \
- file://hack-out-pg_config.patch;patch=1"
+SRC_URI += "file://0010-no-simpledecoration-example.patch;apply=yes \
+ file://hack-out-pg_config.patch;apply=yes"
SRC_URI[md5sum] = "62186345c609a72b89f16d83bc7a130f"
SRC_URI[sha256sum] = "272301a27e2f7bcd44c8d09f496e1c749c80b86d9489ea9c30bb265bf2dd02fc"
diff --git a/recipes/qt4/qt4-tools-native.inc b/recipes/qt4/qt4-tools-native.inc
index 9bfffe3bf0..8cb5597106 100644
--- a/recipes/qt4/qt4-tools-native.inc
+++ b/recipes/qt4/qt4-tools-native.inc
@@ -10,7 +10,7 @@ INC_PR = "r7"
inherit native
SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-everywhere-opensource-src-${PV}.tar.gz \
- file://qt-config.patch;patch=1 \
+ file://qt-config.patch;apply=yes \
file://g++.conf \
file://linux.conf"
S = "${WORKDIR}/qt-everywhere-opensource-src-${PV}"
diff --git a/recipes/qt4/qt4-tools-native_4.4.3.bb b/recipes/qt4/qt4-tools-native_4.4.3.bb
index 5bd97bb001..ee899f7e1a 100644
--- a/recipes/qt4/qt4-tools-native_4.4.3.bb
+++ b/recipes/qt4/qt4-tools-native_4.4.3.bb
@@ -2,8 +2,8 @@ require qt4-tools-native.inc
# Older releases have different source archive name, than .inc
SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-${PV}.tar.bz2 \
- file://configure-lflags.patch;patch=1 \
- file://qt-config.patch;patch=1 \
+ file://configure-lflags.patch;apply=yes \
+ file://qt-config.patch;apply=yes \
file://g++.conf \
file://linux.conf"
diff --git a/recipes/qt4/qt4-tools-native_4.5.2.bb b/recipes/qt4/qt4-tools-native_4.5.2.bb
index 8d33af0129..0b68d1406c 100644
--- a/recipes/qt4/qt4-tools-native_4.5.2.bb
+++ b/recipes/qt4/qt4-tools-native_4.5.2.bb
@@ -2,8 +2,8 @@ require qt4-tools-native.inc
# Older releases have different source archive name, than .inc
SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-${PV}.tar.bz2 \
- file://configure-lflags.patch;patch=1 \
- file://qt-config.patch;patch=1 \
+ file://configure-lflags.patch;apply=yes \
+ file://qt-config.patch;apply=yes \
file://g++.conf \
file://linux.conf"
diff --git a/recipes/qt4/qt4-tools-sdk_4.5.2.bb b/recipes/qt4/qt4-tools-sdk_4.5.2.bb
index 858b2abfd2..861970f321 100644
--- a/recipes/qt4/qt4-tools-sdk_4.5.2.bb
+++ b/recipes/qt4/qt4-tools-sdk_4.5.2.bb
@@ -8,8 +8,8 @@ LICENSE = "LGPLv2.1 GPLv3"
inherit sdk
SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-${PV}.tar.bz2 \
- file://configure-lflags.patch;patch=1 \
- file://qt-config.patch;patch=1 \
+ file://configure-lflags.patch;apply=yes \
+ file://qt-config.patch;apply=yes \
file://g++.conf \
file://linux.conf"
S = "${WORKDIR}/qt-embedded-linux-opensource-src-${PV}"
diff --git a/recipes/qt4/qt4-tools-sdk_4.6.0.bb b/recipes/qt4/qt4-tools-sdk_4.6.0.bb
index 7482a6aec9..dbb2b9d840 100644
--- a/recipes/qt4/qt4-tools-sdk_4.6.0.bb
+++ b/recipes/qt4/qt4-tools-sdk_4.6.0.bb
@@ -9,8 +9,8 @@ DEFAULT_PREFERENCE = "-1"
inherit sdk
SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-everywhere-opensource-src-${PV}.tar.gz \
- file://configure-lflags.patch;patch=1 \
- file://qt-config.patch;patch=1 \
+ file://configure-lflags.patch;apply=yes \
+ file://qt-config.patch;apply=yes \
file://g++.conf \
file://linux.conf"
diff --git a/recipes/qt4/qt4-tools-sdk_4.6.2.bb b/recipes/qt4/qt4-tools-sdk_4.6.2.bb
index 26b49c8523..987fbbc84e 100644
--- a/recipes/qt4/qt4-tools-sdk_4.6.2.bb
+++ b/recipes/qt4/qt4-tools-sdk_4.6.2.bb
@@ -11,8 +11,8 @@ inherit sdk
PR = "r1"
SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-everywhere-opensource-src-${PV}.tar.gz \
- file://configure-lflags.patch;patch=1 \
- file://qt-config.patch;patch=1 \
+ file://configure-lflags.patch;apply=yes \
+ file://qt-config.patch;apply=yes \
file://g++.conf \
file://linux.conf"
diff --git a/recipes/qt4/qt4-x11-free-gles_4.5.2.bb b/recipes/qt4/qt4-x11-free-gles_4.5.2.bb
index a3f60bf982..286392008d 100644
--- a/recipes/qt4/qt4-x11-free-gles_4.5.2.bb
+++ b/recipes/qt4/qt4-x11-free-gles_4.5.2.bb
@@ -12,8 +12,8 @@ PR = "${INC_PR}.3"
DEPENDS += "virtual/egl"
PROVIDES += "qt4-x11-free"
-#SRC_URI += "file://sgx-hack.patch;patch=1"
-SRC_URI += "file://hack-out-pg_config.patch;patch=1"
+#SRC_URI += "file://sgx-hack.patch;apply=yes"
+SRC_URI += "file://hack-out-pg_config.patch;apply=yes"
export EXTRA_QMAKE_MUNGE = " glmunge "
diff --git a/recipes/qt4/qt4-x11-free-gles_git.bb.disabled b/recipes/qt4/qt4-x11-free-gles_git.bb.disabled
index 59778910b5..db45208472 100644
--- a/recipes/qt4/qt4-x11-free-gles_git.bb.disabled
+++ b/recipes/qt4/qt4-x11-free-gles_git.bb.disabled
@@ -13,17 +13,17 @@ DEPENDS += "virtual/egl"
SRCREV = "9ec431c"
SRC_URI = "git://git.gitorious.org/qt/qt.git;protocol=http \
- file://0001-cross-compile.patch;patch=1 \
- file://0002-fix-resinit-declaration.patch;patch=1 \
- file://0003-no-tools.patch;patch=1 \
- file://0004-no-qmake.patch;patch=1 \
- file://0006-freetype-host-includes.patch;patch=1 \
- file://0007-openssl-host-includes.patch;patch=1 \
- file://0008-qt-lib-infix.patch;patch=1 \
+ file://0001-cross-compile.patch;apply=yes \
+ file://0002-fix-resinit-declaration.patch;apply=yes \
+ file://0003-no-tools.patch;apply=yes \
+ file://0004-no-qmake.patch;apply=yes \
+ file://0006-freetype-host-includes.patch;apply=yes \
+ file://0007-openssl-host-includes.patch;apply=yes \
+ file://0008-qt-lib-infix.patch;apply=yes \
file://g++.conf \
file://linux.conf \
"
-#SRC_URI += "file://sgx-hack.patch;patch=1"
+#SRC_URI += "file://sgx-hack.patch;apply=yes"
S = "${WORKDIR}/git"
diff --git a/recipes/qt4/qt4-x11-free.inc b/recipes/qt4/qt4-x11-free.inc
index d8dfa5c225..3403565146 100644
--- a/recipes/qt4/qt4-x11-free.inc
+++ b/recipes/qt4/qt4-x11-free.inc
@@ -8,14 +8,14 @@ DEPENDS += "virtual/libx11 fontconfig xft libxext libxrender libxrandr libxcurso
INC_PR = "r17"
SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-x11-opensource-src-${PV}.tar.gz \
- file://0001-cross-compile.patch;patch=1 \
- file://0002-fix-resinit-declaration.patch;patch=1 \
- file://0003-no-tools.patch;patch=1 \
- file://0004-no-qmake.patch;patch=1 \
- file://0006-freetype-host-includes.patch;patch=1 \
- file://0007-openssl-host-includes.patch;patch=1 \
- file://0008-qt-lib-infix.patch;patch=1 \
- file://fix-config-tests.patch;patch=1 \
+ file://0001-cross-compile.patch;apply=yes \
+ file://0002-fix-resinit-declaration.patch;apply=yes \
+ file://0003-no-tools.patch;apply=yes \
+ file://0004-no-qmake.patch;apply=yes \
+ file://0006-freetype-host-includes.patch;apply=yes \
+ file://0007-openssl-host-includes.patch;apply=yes \
+ file://0008-qt-lib-infix.patch;apply=yes \
+ file://fix-config-tests.patch;apply=yes \
file://g++.conf \
file://linux.conf \
"
diff --git a/recipes/qt4/qt4-x11-free_4.5.2.bb b/recipes/qt4/qt4-x11-free_4.5.2.bb
index 7099310d14..2ee968a4a9 100644
--- a/recipes/qt4/qt4-x11-free_4.5.2.bb
+++ b/recipes/qt4/qt4-x11-free_4.5.2.bb
@@ -2,7 +2,7 @@ require qt4-x11-free.inc
LICENSE = "LGPLv2.1 GPLv3"
PR = "${INC_PR}.3"
-SRC_URI += "file://hack-out-pg_config.patch;patch=1"
+SRC_URI += "file://hack-out-pg_config.patch;apply=yes"
SRC_URI[md5sum] = "d8bcc070a58db25c228b7729ffad4550"
SRC_URI[sha256sum] = "4e4c8619335cac14ba0c52d1555fab549a562fb774c1c08dcbd2be9de38120a2"