summaryrefslogtreecommitdiffstats
path: root/recipes/qt4
diff options
context:
space:
mode:
authorValentin Longchamp <valentin.longchamp@epfl.ch>2010-03-15 07:04:04 +0000
committerKoen Kooi <koen@openembedded.org>2010-03-15 18:14:17 +0100
commitebac0f7b1b6287ca0d6315176a6070b013836032 (patch)
tree32a624a13510abc57716f62a75693d3b51d6a5d8 /recipes/qt4
parent87b74b371b6c1d64c508c028d0633e9ad4ce1df3 (diff)
downloadopenembedded-ebac0f7b1b6287ca0d6315176a6070b013836032.tar.gz
Do not generate NEON code for qt-4.6.2 embedded on armv6
http://bugreports.qt.nokia.com/browse/QTBUG-8749 Neon code is generated for armv6 processor, where it should be armv7 only. This results in illegal instructions with some of the qt4 libraries. The current solution is not optimal, I just needed a quick fix for my arch and I don't have the needed knowledge in OE to fix it cleanly, but I wanted to point this issue out. But at least other arch (armv5 and armv4) should have the same problem and receive the same fix. Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/qt4')
-rw-r--r--recipes/qt4/qt4-embedded_4.6.2.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes/qt4/qt4-embedded_4.6.2.bb b/recipes/qt4/qt4-embedded_4.6.2.bb
index 94ecd01bc6..8583752d6d 100644
--- a/recipes/qt4/qt4-embedded_4.6.2.bb
+++ b/recipes/qt4/qt4-embedded_4.6.2.bb
@@ -1,6 +1,8 @@
require qt4-embedded.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
+
+QT_CONFIG_FLAGS_append_armv6 = " -no-neon "
require qt-${PV}.inc