aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qte/qte-mt-static_2.3.10.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/qte/qte-mt-static_2.3.10.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/qte/qte-mt-static_2.3.10.bb')
-rw-r--r--recipes/qte/qte-mt-static_2.3.10.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/qte/qte-mt-static_2.3.10.bb b/recipes/qte/qte-mt-static_2.3.10.bb
new file mode 100644
index 0000000000..68ab2aceab
--- /dev/null
+++ b/recipes/qte/qte-mt-static_2.3.10.bb
@@ -0,0 +1,22 @@
+require qte-common_${PV}.inc
+PR = "r8"
+
+DEFAULT_PREFERENCE = "-1"
+
+EXTRA_OECONF += "-static -thread"
+
+do_stage() {
+ rm -rf ${STAGING_DIR_HOST}/qt2
+ install -d ${STAGING_DIR_HOST}/qt2/lib
+ oe_libinstall -a -C lib libqte-mt ${STAGING_DIR_HOST}/qt2/lib
+ rm -f include/qxt.h
+ install -d ${STAGING_DIR_HOST}/qt2/include
+ cp -pfLR include/* ${STAGING_DIR_HOST}/qt2/include
+ cp -pPR lib/fonts ${STAGING_DIR_HOST}/qt2/lib/
+}
+
+do_install() {
+ :
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"