aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qte
diff options
context:
space:
mode:
authorPaul Eggleton <bluelightning@bluelightning.org>2009-11-08 15:23:09 +0000
committerPaul Eggleton <bluelightning@bluelightning.org>2009-11-08 15:23:09 +0000
commit5ef8dc482d56fdf0c59d9ce0eed32088611d491a (patch)
tree53e6d1dc4b9417046e091ee1db92d871d97d2155 /recipes/qte
parent009d351d727ea44a12b47dc33e5d0da788f2feab (diff)
downloadopenembedded-5ef8dc482d56fdf0c59d9ce0eed32088611d491a.tar.gz
qte: fix build failure with modern kernels due to removal of asm/page.h
Diffstat (limited to 'recipes/qte')
-rw-r--r--recipes/qte/qte-2.3.10/fix-qte-asm-include.patch19
-rw-r--r--recipes/qte/qte-2.3.10/kernel-asm-page.patch20
-rw-r--r--recipes/qte/qte-common_2.3.10.inc2
-rw-r--r--recipes/qte/qte-mt-static_2.3.10.bb2
-rw-r--r--recipes/qte/qte-mt_2.3.10.bb2
-rw-r--r--recipes/qte/qte_2.3.10.bb2
6 files changed, 23 insertions, 24 deletions
diff --git a/recipes/qte/qte-2.3.10/fix-qte-asm-include.patch b/recipes/qte/qte-2.3.10/fix-qte-asm-include.patch
new file mode 100644
index 0000000000..951bd82461
--- /dev/null
+++ b/recipes/qte/qte-2.3.10/fix-qte-asm-include.patch
@@ -0,0 +1,19 @@
+--- a/src/kernel/qpixmapcache.cpp 2005-01-23 14:00:46.000000000 +0000
++++ b/src/kernel/qpixmapcache.cpp 2009-11-05 22:49:44.000000000 +0000
+@@ -119,13 +119,13 @@
+ #include <time.h>
+ #include <stdio.h>
+ #include <signal.h>
++#include <unistd.h>
+
+ #ifdef THROW_AWAY_UNUSED_PAGES
+ # include <sys/mman.h> // madvise
+-# include <asm/page.h> // PAGE_SIZE,PAGE_MASK,PAGE_ALIGN
+-# ifndef PAGE_ALIGN
++# define PAGE_SIZE getpagesize()
++# define PAGE_MASK (~(PAGE_SIZE-1))
+ # define PAGE_ALIGN(addr) (((addr)+PAGE_SIZE-1)&PAGE_MASK)
+-# endif // PAGE_ALIGN
+ #endif // THROW_AWAY_UNUSED_PAGES
+
+
diff --git a/recipes/qte/qte-2.3.10/kernel-asm-page.patch b/recipes/qte/qte-2.3.10/kernel-asm-page.patch
deleted file mode 100644
index bad2d95967..0000000000
--- a/recipes/qte/qte-2.3.10/kernel-asm-page.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff --git a/src/kernel/qpixmapcache.cpp b/src/kernel/qpixmapcache.cpp
-index c2e7d9b..8d39585 100644
---- a/src/kernel/qpixmapcache.cpp
-+++ b/src/kernel/qpixmapcache.cpp
-@@ -123,9 +123,13 @@ void cleanup_pixmap_cache();
- #ifdef THROW_AWAY_UNUSED_PAGES
- # include <sys/mman.h> // madvise
- # include <asm/page.h> // PAGE_SIZE,PAGE_MASK,PAGE_ALIGN
-+# include <unistd.h> // getpagesize()
-+# if (!defined(PAGE_ALIGN)) && defined(PAGE_SIZE) && defined(PAGE_MASK)
-+# define PAGE_ALIGN(addr) (((addr)+PAGE_SIZE-1)&PAGE_MASK)
-+# endif
- # ifndef PAGE_ALIGN
--# define PAGE_ALIGN(addr) (((addr)+PAGE_SIZE-1)&PAGE_MASK)
--# endif // PAGE_ALIGN
-+# define PAGE_ALIGN(addr) (((addr)+getpagesize()-1)&~(getpagesize()-1))
-+# endif
- #endif // THROW_AWAY_UNUSED_PAGES
-
-
diff --git a/recipes/qte/qte-common_2.3.10.inc b/recipes/qte/qte-common_2.3.10.inc
index f24a265bf0..cd2aa4f1a2 100644
--- a/recipes/qte/qte-common_2.3.10.inc
+++ b/recipes/qte/qte-common_2.3.10.inc
@@ -45,9 +45,9 @@ SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-${PV}-free.tar.gz;m
file://keyboardless-buttonmap.patch;patch=1 \
file://kernel-keymap.patch;patch=1 \
file://kernel-keymap-corgi.patch;patch=1 \
- file://kernel-asm-page.patch;patch=1 \
file://remove-unused-kbdhandler.patch;patch=1 \
file://disable-dup-rotation.patch;patch=1 \
+ file://fix-qte-asm-include.patch;patch=1 \
file://sharp_char.h \
file://switches.h "
diff --git a/recipes/qte/qte-mt-static_2.3.10.bb b/recipes/qte/qte-mt-static_2.3.10.bb
index 68ab2aceab..35640e5f3b 100644
--- a/recipes/qte/qte-mt-static_2.3.10.bb
+++ b/recipes/qte/qte-mt-static_2.3.10.bb
@@ -1,5 +1,5 @@
require qte-common_${PV}.inc
-PR = "r8"
+PR = "r9"
DEFAULT_PREFERENCE = "-1"
diff --git a/recipes/qte/qte-mt_2.3.10.bb b/recipes/qte/qte-mt_2.3.10.bb
index 71873dc51a..00e5d72e64 100644
--- a/recipes/qte/qte-mt_2.3.10.bb
+++ b/recipes/qte/qte-mt_2.3.10.bb
@@ -1,5 +1,5 @@
require qte-common_${PV}.inc
-PR = "r28"
+PR = "r29"
EXTRA_OECONF += "-thread"
diff --git a/recipes/qte/qte_2.3.10.bb b/recipes/qte/qte_2.3.10.bb
index 1183bc29bf..9a8be94a65 100644
--- a/recipes/qte/qte_2.3.10.bb
+++ b/recipes/qte/qte_2.3.10.bb
@@ -1,3 +1,3 @@
require qte-common_${PV}.inc
-PR = "r53"
+PR = "r54"