aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/quake/quake2
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/quake/quake2
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/quake/quake2')
-rw-r--r--recipes/quake/quake2/quake2-arm.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/quake/quake2/quake2-arm.patch b/recipes/quake/quake2/quake2-arm.patch
new file mode 100644
index 0000000000..02b3cb2eae
--- /dev/null
+++ b/recipes/quake/quake2/quake2-arm.patch
@@ -0,0 +1,32 @@
+--- /tmp/sys_linux.c 2008-09-09 11:50:06.000000000 +0200
++++ trunk/src/linux/sys_linux.c 2008-09-09 11:48:06.113198000 +0200
+@@ -225,6 +225,8 @@
+ const char *gamename = "gameppc.so";
+ #elif defined __sparc__
+ const char *gamename = "gamesparc.so";
++#elif defined __arm__
++ const char *gamename = "gamearm.so";
+ #else
+ #error Unknown arch
+ #endif
+--- /tmp/Makefile 2008-09-09 11:52:05.000000000 +0200
++++ trunk/Makefile 2008-09-09 11:53:26.543198000 +0200
+@@ -60,18 +60,6 @@
+ # this nice line comes from the linux kernel makefile
+ ARCH := $(shell uname -m | sed -e s/i.86/i386/ -e s/sun4u/sparc/ -e s/sparc64/sparc/ -e s/arm.*/arm/ -e s/sa110/arm/ -e s/alpha/axp/)
+
+-ifneq ($(ARCH),x86_64)
+-ifneq ($(ARCH),i386)
+-ifneq ($(ARCH),axp)
+-ifneq ($(ARCH),ppc)
+-ifneq ($(ARCH),sparc)
+-$(error arch $(ARCH) is currently not supported)
+-endif
+-endif
+-endif
+-endif
+-endif
+-
+ CC=gcc
+
+ ifndef OPT_CFLAGS