aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/quilt
diff options
context:
space:
mode:
authorYuri Bushmelev <jay4mail@gmail.com>2010-07-17 01:21:51 +0400
committerYuri Bushmelev <jay4mail@gmail.com>2010-07-17 01:37:31 +0400
commite05f5e4e8f023aea355943a1356dbb14226625e0 (patch)
treeb5f24eee6cd0dc2edd3b84996ba8aa58501ef00e /recipes/quilt
parent29e63e74ab78d8a69ac555a2223b8f4e1ac65304 (diff)
downloadopenembedded-e05f5e4e8f023aea355943a1356dbb14226625e0.tar.gz
quilt-native_0.48: Patch to properly detect newer versions of GNU patch is added.
New versions of GNU patch present themselves as "GNU patch" instead of just "patch". NOTE1: both configure.ac and configure are patched because we have no native autotools at that stage. NOTE2: encountered on ALT Linux Sisyphus (testing branch).
Diffstat (limited to 'recipes/quilt')
-rw-r--r--recipes/quilt/quilt-0.48/fix_new_GNU_patch_detection.patch36
-rw-r--r--recipes/quilt/quilt-native_0.48.bb4
2 files changed, 39 insertions, 1 deletions
diff --git a/recipes/quilt/quilt-0.48/fix_new_GNU_patch_detection.patch b/recipes/quilt/quilt-0.48/fix_new_GNU_patch_detection.patch
new file mode 100644
index 0000000000..f790f76f66
--- /dev/null
+++ b/recipes/quilt/quilt-0.48/fix_new_GNU_patch_detection.patch
@@ -0,0 +1,36 @@
+# origin: http://git.savannah.gnu.org/cgit/quilt.git/commit/?id=38df0b210c3df67f3e784af92232ae1946b98ecd
+# Properly detect newer versions of GNU patch
+# New versions of GNU patch present themselves as "GNU patch" instead of just "patch".
+
+diff --git a/configure.ac b/configure.ac
+index 9d4a62e..cc850fa 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -262,7 +262,11 @@ fi
+ AC_MSG_CHECKING([the version of $PATCH])
+ if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
+ set -- `$PATCH --version 2> /dev/null`
+- patch_version=$2
++ if test x$1 = xGNU ; then
++ patch_version=$3
++ else
++ patch_version=$2
++ fi
+ AC_MSG_RESULT($patch_version)
+ saved_IFS=$IFS; IFS='.'
+ set -- $patch_version
+--- a/configure
++++ b/configure
+@@ -5896,7 +5896,11 @@
+ echo $ECHO_N "checking the version of $PATCH... $ECHO_C" >&6; }
+ if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
+ set -- `$PATCH --version 2> /dev/null`
+- patch_version=$2
++ if test x$1 = xGNU ; then
++ patch_version=$3
++ else
++ patch_version=$2
++ fi
+ { echo "$as_me:$LINENO: result: $patch_version" >&5
+ echo "${ECHO_T}$patch_version" >&6; }
+ saved_IFS=$IFS; IFS='.'
diff --git a/recipes/quilt/quilt-native_0.48.bb b/recipes/quilt/quilt-native_0.48.bb
index e3e6cda23b..5b4449b2ac 100644
--- a/recipes/quilt/quilt-native_0.48.bb
+++ b/recipes/quilt/quilt-native_0.48.bb
@@ -1,6 +1,8 @@
require quilt-native.inc
-PR="r2"
+PR="r3"
+
+SRC_URI_append = "file://fix_new_GNU_patch_detection.patch"
SRC_URI[md5sum] = "f77adda60039ffa753f3c584a286f12b"
SRC_URI[sha256sum] = "73fd760d3b5cbf06417576591dc37d67380d189392db9000c21b7cbebee49ffc"