aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/quilt
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-04-09 15:46:05 -0700
committerKhem Raj <raj.khem@gmail.com>2009-04-09 15:46:05 -0700
commit8993791a6b99c35dca787ba695ead33f8176c29c (patch)
treefeb36fbe695550d002f9b7049c322fd67562cfa6 /recipes/quilt
parent7c5786aa50a454ae308bb1eb33f397d00930deb6 (diff)
downloadopenembedded-8993791a6b99c35dca787ba695ead33f8176c29c.tar.gz
quilt-0.48: Add new version 0.48 of quilt.
checksums.ini: Add checksum for quilt 0.48 * Adds the latest release of quilt recipes. * Move PR out of quilt.inc into respective bb files.
Diffstat (limited to 'recipes/quilt')
-rw-r--r--recipes/quilt/quilt-0.48/aclocal.patch126
-rw-r--r--recipes/quilt/quilt-0.48/install.patch13
-rw-r--r--recipes/quilt/quilt-native_0.45.bb1
-rw-r--r--recipes/quilt/quilt-native_0.46.bb1
-rw-r--r--recipes/quilt/quilt-native_0.48.bb1
-rw-r--r--recipes/quilt/quilt.inc1
-rw-r--r--recipes/quilt/quilt_0.45.bb1
-rw-r--r--recipes/quilt/quilt_0.46.bb1
-rw-r--r--recipes/quilt/quilt_0.48.bb1
9 files changed, 145 insertions, 1 deletions
diff --git a/recipes/quilt/quilt-0.48/aclocal.patch b/recipes/quilt/quilt-0.48/aclocal.patch
new file mode 100644
index 0000000000..1245f74922
--- /dev/null
+++ b/recipes/quilt/quilt-0.48/aclocal.patch
@@ -0,0 +1,126 @@
+Add the aclocal.m4 as acinclude.m4
+
+Index: quilt-0.46/acinclude.m4
+===================================================================
+--- /dev/null
++++ quilt-0.46/acinclude.m4
+@@ -0,0 +1,119 @@
++dnl Allow configure to specify a specific binary
++dnl 1: Environment variable
++dnl 2: binary name
++dnl 3: optional list of alternative binary names
++dnl 4: optional list of additional search directories
++AC_DEFUN([QUILT_COMPAT_PROG_PATH],[
++ m4_define([internal_$2_cmd],[esyscmd(ls compat/$2.in 2>/dev/null)])
++
++ AC_ARG_WITH($2, AC_HELP_STRING(
++ [--with-$2], [name of the $2 executable to use]
++ m4_if(internal_$2_cmd,[],[],[ (use --without-$2
++ to use an internal mechanism)])),
++ [
++ if test x"$withval" = xnone; then
++ AC_MSG_ERROR([Invalid configure argument. use --without-$2])
++ fi
++ if test x"$withval" != xno; then
++ AC_MSG_CHECKING(for $2)
++ $1="$withval"
++ if test -e "$$1"; then
++ if test ! -f "$$1" -a ! -h "$$1" || test ! -x "$$1"; then
++ AC_MSG_ERROR([$$1 is not an executable file])
++ fi
++ fi
++ AC_MSG_RESULT([$$1])
++ if test ! -e "$$1"; then
++ AC_MSG_WARN([$$1 does not exist])
++ fi
++ COMPAT_SYMLINKS="$COMPAT_SYMLINKS $2"
++ fi
++ ],[
++ m4_if([$3],[],[
++ AC_PATH_PROG($1,$2,,$PATH:$4)
++ ],[
++ AC_PATH_PROGS($1,$3,,$PATH:$4)
++ if test -n "$$1" -a "`expr "$$1" : '.*/\([[^/]]*\)$'`" != "$2"; then
++ COMPAT_SYMLINKS="$COMPAT_SYMLINKS $2"
++ fi
++ ])
++ m4_if([$4],[],[],[
++ if test -n "$$1"; then
++ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
++ for dir in "$4"; do
++ if test "`dirname $$1`" = "$dir"; then
++ COMPAT_SYMLINKS="$COMPAT_SYMLINKS $2"
++ break
++ fi
++ done
++ IFS="$as_save_IFS"
++ fi
++ ])
++ ])
++ if test -z "$$1"; then
++ m4_if(internal_$2_cmd,[],[
++ AC_MSG_ERROR([Please specify the location of $2 with the option '--with-$2'])
++ ],[
++ AC_MSG_WARN([Using internal $2 mechanism. Use option '--with-$2' to override])
++ COMPAT_PROGRAMS="$COMPAT_PROGRAMS $2"
++ $1=$2
++ INTERNAL_$1=1
++ ])
++ fi
++ AC_SUBST($1)
++])
++
++dnl Allow configure to specify a specific binary
++dnl This variant is for optional binaries.
++dnl 1: Environment variable
++dnl 2: binary name
++dnl 3: optional list of alternative binary names
++dnl 4: optional list of additional search directories
++AC_DEFUN([QUILT_COMPAT_PROG_PATH_OPT],[
++ AC_ARG_WITH($2, AC_HELP_STRING(
++ [--with-$2], [name of the $2 executable to use]),
++ [
++ if test x"$withval" != xno; then
++ AC_MSG_CHECKING(for $2)
++ $1="$withval"
++ if test -e "$$1"; then
++ if test ! -f "$$1" -a ! -h "$$1" || test ! -x "$$1"; then
++ AC_MSG_ERROR([$$1 is not an executable file])
++ fi
++ fi
++ AC_MSG_RESULT([$$1])
++ if test ! -e "$$1"; then
++ AC_MSG_WARN([$$1 does not exist])
++ fi
++ COMPAT_SYMLINKS="$COMPAT_SYMLINKS $2"
++ fi
++ ],[
++ m4_if([$3],[],[
++ AC_PATH_PROG($1,$2,,$PATH:$4)
++ ],[
++ AC_PATH_PROGS($1,$3,,$PATH:$4)
++ if test -n "$$1" -a "`expr "$$1" : '.*/\([[^/]]*\)$'`" != "$2"; then
++ COMPAT_SYMLINKS="$COMPAT_SYMLINKS $2"
++ fi
++ ])
++ m4_if([$4],[],[],[
++ if test -n "$$1"; then
++ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
++ for dir in "$4"; do
++ if test "`dirname $$1`" = "$dir"; then
++ COMPAT_SYMLINKS="$COMPAT_SYMLINKS $2"
++ break
++ fi
++ done
++ IFS="$as_save_IFS"
++ fi
++ ])
++ if test -z "$$1"; then
++ AC_MSG_WARN([$2 not found, some optional functionalities will be missing])
++ fi
++ ])
++ if test -z "$$1"; then
++ $1=$2
++ fi
++ AC_SUBST($1)
++])
diff --git a/recipes/quilt/quilt-0.48/install.patch b/recipes/quilt/quilt-0.48/install.patch
new file mode 100644
index 0000000000..7970f1102e
--- /dev/null
+++ b/recipes/quilt/quilt-0.48/install.patch
@@ -0,0 +1,13 @@
+Index: quilt-0.48/Makefile.in
+===================================================================
+--- quilt-0.48.orig/Makefile.in 2009-01-31 09:09:47.000000000 -0800
++++ quilt-0.48/Makefile.in 2009-04-09 15:36:25.000000000 -0700
+@@ -13,7 +13,7 @@
+ mandir := @mandir@
+ localedir := $(datadir)/locale
+ emacsdir := $(datadir)/emacs/site-lisp
+-etcdir := $(subst /usr/etc,/etc,$(prefix)/etc)
++etcdir := @sysconfdir@
+
+ INSTALL := @INSTALL@
+ POD2MAN := @POD2MAN@
diff --git a/recipes/quilt/quilt-native_0.45.bb b/recipes/quilt/quilt-native_0.45.bb
index 302df25afd..5fbaf5a7c4 100644
--- a/recipes/quilt/quilt-native_0.45.bb
+++ b/recipes/quilt/quilt-native_0.45.bb
@@ -1 +1,2 @@
require quilt-native.inc
+PR = "r2"
diff --git a/recipes/quilt/quilt-native_0.46.bb b/recipes/quilt/quilt-native_0.46.bb
index 302df25afd..5fbaf5a7c4 100644
--- a/recipes/quilt/quilt-native_0.46.bb
+++ b/recipes/quilt/quilt-native_0.46.bb
@@ -1 +1,2 @@
require quilt-native.inc
+PR = "r2"
diff --git a/recipes/quilt/quilt-native_0.48.bb b/recipes/quilt/quilt-native_0.48.bb
new file mode 100644
index 0000000000..302df25afd
--- /dev/null
+++ b/recipes/quilt/quilt-native_0.48.bb
@@ -0,0 +1 @@
+require quilt-native.inc
diff --git a/recipes/quilt/quilt.inc b/recipes/quilt/quilt.inc
index 33bc0f62ea..ce9679ded1 100644
--- a/recipes/quilt/quilt.inc
+++ b/recipes/quilt/quilt.inc
@@ -2,7 +2,6 @@ DESCRIPTION = "Tool to work with series of patches."
HOMEPAGE = "http://savannah.nongnu.org/projects/quilt/"
SECTION = "devel"
LICENSE = "GPL"
-PR = "r2"
SRC_URI = "http://download.savannah.gnu.org/releases/quilt/quilt-${PV}.tar.gz \
file://install.patch;patch=1"
diff --git a/recipes/quilt/quilt_0.45.bb b/recipes/quilt/quilt_0.45.bb
index de38f64782..99efa48fe2 100644
--- a/recipes/quilt/quilt_0.45.bb
+++ b/recipes/quilt/quilt_0.45.bb
@@ -1 +1,2 @@
require quilt-package.inc
+PR = "r2"
diff --git a/recipes/quilt/quilt_0.46.bb b/recipes/quilt/quilt_0.46.bb
index de38f64782..99efa48fe2 100644
--- a/recipes/quilt/quilt_0.46.bb
+++ b/recipes/quilt/quilt_0.46.bb
@@ -1 +1,2 @@
require quilt-package.inc
+PR = "r2"
diff --git a/recipes/quilt/quilt_0.48.bb b/recipes/quilt/quilt_0.48.bb
new file mode 100644
index 0000000000..de38f64782
--- /dev/null
+++ b/recipes/quilt/quilt_0.48.bb
@@ -0,0 +1 @@
+require quilt-package.inc