summaryrefslogtreecommitdiffstats
path: root/recipes/raw-tools
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/raw-tools
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/raw-tools')
-rw-r--r--recipes/raw-tools/exiv2_0.15.bb14
-rw-r--r--recipes/raw-tools/gtkimageview_1.3.0.bb19
-rw-r--r--recipes/raw-tools/libopenraw.inc10
-rw-r--r--recipes/raw-tools/libopenraw_0.0.2.bb4
-rw-r--r--recipes/raw-tools/ufraw_0.12.bb16
5 files changed, 63 insertions, 0 deletions
diff --git a/recipes/raw-tools/exiv2_0.15.bb b/recipes/raw-tools/exiv2_0.15.bb
new file mode 100644
index 0000000000..894abce114
--- /dev/null
+++ b/recipes/raw-tools/exiv2_0.15.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Exiv2 is a C++ library and a command line utility to access image metadata."
+LICENSE = "GPL"
+DEPENDS = "tiff zlib"
+
+SRC_URI = "http://www.exiv2.org/exiv2-${PV}.tar.gz"
+
+inherit autotools pkgconfig lib_package
+
+
+do_stage() {
+ autotools_stage_all
+}
+
+
diff --git a/recipes/raw-tools/gtkimageview_1.3.0.bb b/recipes/raw-tools/gtkimageview_1.3.0.bb
new file mode 100644
index 0000000000..aa45fe09b0
--- /dev/null
+++ b/recipes/raw-tools/gtkimageview_1.3.0.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "GtkImageView is a simple image viewer widget for GTK."
+DEPENDS = "gtk+"
+
+SRC_URI = "http://www.angstrom-distribution.org/unstable/sources/gtkimageview-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ oe_runconf
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+
diff --git a/recipes/raw-tools/libopenraw.inc b/recipes/raw-tools/libopenraw.inc
new file mode 100644
index 0000000000..1f39c2b667
--- /dev/null
+++ b/recipes/raw-tools/libopenraw.inc
@@ -0,0 +1,10 @@
+DESCRIPTION = "libopenraw is an ongoing project to provide a free software implementation for camera RAW files decoding. "
+LICENSE = "GPLv2"
+DEPENDS = "boost jpeg gtk+"
+
+inherit autotools pkgconfig lib_package
+
+PACKAGES =+ "libopenrawgnome"
+
+FILES_libopenrawgnome = "${libdir}/libopenrawgnome.so.*"
+
diff --git a/recipes/raw-tools/libopenraw_0.0.2.bb b/recipes/raw-tools/libopenraw_0.0.2.bb
new file mode 100644
index 0000000000..7a19c63bbc
--- /dev/null
+++ b/recipes/raw-tools/libopenraw_0.0.2.bb
@@ -0,0 +1,4 @@
+require libopenraw.inc
+
+SRC_URI = "http://libopenraw.freedesktop.org/download/libopenraw-${PV}.tar.gz"
+
diff --git a/recipes/raw-tools/ufraw_0.12.bb b/recipes/raw-tools/ufraw_0.12.bb
new file mode 100644
index 0000000000..b9e06a3bc5
--- /dev/null
+++ b/recipes/raw-tools/ufraw_0.12.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "The Unidentified Flying Raw (UFRaw) is a utility to read and manipulate raw images from digital cameras. "
+LICENSE = "GPL"
+
+DEPENDS = "gtk+ gtkimageview lcms exiv2 tiff"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/ufraw/ufraw-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = " --enable-extras "
+
+PACKAGES =+ "dcraw dcraw-dbg"
+FILES_dcraw = "${bindir}/dcraw"
+FILES_dcraw-bdg = "${bindir}/.debug/dcraw"
+
+