aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/reaim
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/reaim
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/reaim')
-rw-r--r--recipes/reaim/reaim/makefile-fix.patch23
-rw-r--r--recipes/reaim/reaim_7.0.1.13.bb13
2 files changed, 36 insertions, 0 deletions
diff --git a/recipes/reaim/reaim/makefile-fix.patch b/recipes/reaim/reaim/makefile-fix.patch
new file mode 100644
index 0000000000..4678d9d83f
--- /dev/null
+++ b/recipes/reaim/reaim/makefile-fix.patch
@@ -0,0 +1,23 @@
+From: Marcin Juszkiewicz <hrw@openembedded.org>
+
+1. Link with libaio
+2. Do not show instructions during do_install or bitbake will break
+
+Index: osdl-aim-7/src/Makefile.am
+===================================================================
+--- osdl-aim-7.orig/src/Makefile.am 2004-10-21 01:31:33.000000000 +0200
++++ osdl-aim-7/src/Makefile.am 2006-10-14 19:57:28.000000000 +0200
+@@ -8,7 +8,7 @@
+ LIBADD_READLINE =
+ # endif
+
+-reaim_LDADD = $(top_builddir)/lib/libltp.a $(LIBADD_READLINE)
++reaim_LDADD = $(top_builddir)/lib/libltp.a $(LIBADD_READLINE) -laio
+ reaim_SOURCES = driver.c suite.h files.h ram.c aimlist.h \
+ rand.c times_ms.c testerr.h add.c creat_clo.c drv_funcs.c \
+ div.c disk_funcs.c pipe_test.c mul.c num_fcns.c int_fcns.c \
+@@ -42,4 +42,3 @@
+ if test -f $(srcdir)/README; then \
+ $(INSTALL_DATA) $(srcdir)/README $(DESTDIR)$(datadir)/reaim; \
+ fi
+- @/bin/sh $(top_srcdir)/scripts/instruct.sh
diff --git a/recipes/reaim/reaim_7.0.1.13.bb b/recipes/reaim/reaim_7.0.1.13.bb
new file mode 100644
index 0000000000..5694a4364e
--- /dev/null
+++ b/recipes/reaim/reaim_7.0.1.13.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "The AIM Multiuser Benchmark - Suite VII \
+tests and measures the performance of Open System multiuser computers."
+HOMEPAGE = "http://re-aim-7.sourceforge.net/"
+SECTION = "console/tests"
+LICENSE = "GPL"
+DEPENDS = "libaio"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/re-aim-7/osdl-aim-${PV}.tar.gz \
+ file://makefile-fix.patch;patch=1"
+
+S = "${WORKDIR}/osdl-aim-7/"
+
+inherit autotools