aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/redland/redland_1.0.8.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-05-31 16:36:28 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-31 16:36:28 +0200
commitf4d7699218728ad76be7e2959668891d85b47a30 (patch)
tree40abf772816640bcd58ac0e60386331a2647e238 /recipes/redland/redland_1.0.8.bb
parent79d9be1d6c5a4bbf635e02e882a63fcda259c513 (diff)
downloadopenembedded-f4d7699218728ad76be7e2959668891d85b47a30.tar.gz
redland: add 1.0.8 (from poky)
Diffstat (limited to 'recipes/redland/redland_1.0.8.bb')
-rw-r--r--recipes/redland/redland_1.0.8.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/redland/redland_1.0.8.bb b/recipes/redland/redland_1.0.8.bb
new file mode 100644
index 0000000000..34e4bbc09a
--- /dev/null
+++ b/recipes/redland/redland_1.0.8.bb
@@ -0,0 +1,19 @@
+LICENSE = "GPLv2"
+SRC_URI = "http://download.librdf.org/source/redland-1.0.8.tar.gz \
+ file://crosscompile.patch;patch=1 \
+ file://sane_pkgconfig.patch;patch=1"
+
+PR = "r3"
+
+inherit autotools_stage
+
+EXTRA_OECONF = "--with-bdb-lib=${STAGING_LIBDIR} --with-bdb-include=${STAGING_INCDIR} --with-sqlite=no"
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_compile_append() {
+for i in `find ${S}/ -name "*.pc" -type f` ; do \
+ sed -i -e 's:-L${STAGING_LIBDIR}::g' -e 's:${STAGING_LIBDIR}:\$\{libdir\}:g' $i
+ done
+}
+