aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/roadmap
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/roadmap
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/roadmap')
-rw-r--r--recipes/roadmap/files/cross.patch17
-rw-r--r--recipes/roadmap/files/options.mk.patch34
-rw-r--r--recipes/roadmap/files/qt/qt2-fixes.patch10
-rw-r--r--recipes/roadmap/files/qt/qt_canvas.patch20
-rw-r--r--recipes/roadmap/files/qt/qt_main.patch61
-rw-r--r--recipes/roadmap/files/qt/roadmap_main.patch16
-rw-r--r--recipes/roadmap/files/roadmap.desktop.patch16
-rw-r--r--recipes/roadmap/files/roadmap_path.patch57
-rw-r--r--recipes/roadmap/files/zroadgps.pngbin0 -> 1949 bytes
-rw-r--r--recipes/roadmap/roadmap-gtk2.inc11
-rw-r--r--recipes/roadmap/roadmap-gtk2_1.1.0.bb12
-rw-r--r--recipes/roadmap/roadmap-gtk2_cvs.bb13
-rw-r--r--recipes/roadmap/roadmap.inc19
-rw-r--r--recipes/roadmap/zroadmap.inc23
-rw-r--r--recipes/roadmap/zroadmap_1.1.0.bb16
-rw-r--r--recipes/roadmap/zroadmap_cvs.bb13
16 files changed, 338 insertions, 0 deletions
diff --git a/recipes/roadmap/files/cross.patch b/recipes/roadmap/files/cross.patch
new file mode 100644
index 0000000000..87c8d7894b
--- /dev/null
+++ b/recipes/roadmap/files/cross.patch
@@ -0,0 +1,17 @@
+--- /tmp/options.mk 2007-08-08 12:14:11.000000000 +0200
++++ roadmap/src/options.mk 2007-08-08 12:14:35.688400000 +0200
+@@ -26,13 +26,7 @@
+
+ # if you want to cross-compile, define CROSS in config.mk. you
+ # may also have to add paths to libraries (with -L) in LDFLAGS.
+-CC = $(CROSS)gcc
+-CXX = $(CROSS)g++
+-AS = $(CROSS)as
+-AR = $(CROSS)ar
+-LD = $(CROSS)ld
+-STRIP = $(CROSS)strip
+-RANLIB = $(CROSS)ranlib
++STRIP = echo
+
+
+ # --- Build options ------------------------------------------------
diff --git a/recipes/roadmap/files/options.mk.patch b/recipes/roadmap/files/options.mk.patch
new file mode 100644
index 0000000000..196f16e31d
--- /dev/null
+++ b/recipes/roadmap/files/options.mk.patch
@@ -0,0 +1,34 @@
+--- roadmap-1.1.0/src/options.mk.old 2008-01-09 22:08:00.000000000 -0600
++++ roadmap-1.1.0/src/options.mk 2008-01-09 23:06:29.000000000 -0600
+@@ -177,10 +177,7 @@ ifeq ($(strip $(AGG)),NO)
+ else
+ LIBS += -laggfontfreetype -lagg -lfreetype
+ CFLAGS += -DAGG_PIXFMT=pixfmt_$(AGG) \
+- -I$(TOP)/agg_support \
+- -I/usr/include/agg2 \
+- -I/usr/local/include/agg2 \
+- -I/usr/include/freetype2
++ -I$(TOP)/agg_support
+ CANVAS_OBJS = roadmap_canvas_agg.o \
+ $(TOP)/agg_support/roadmap_canvas.o
+ endif
+@@ -188,7 +185,7 @@ endif
+ # bidirectional text lib
+ ifneq ($(strip $(BIDI)),NO)
+ LIBS += -lfribidi
+- CFLAGS += -DUSE_FRIBIDI -I/usr/include/fribidi
++ CFLAGS += -DUSE_FRIBIDI
+ endif
+
+ # RoadMap internal profiling
+@@ -205,8 +202,8 @@ else
+ endif
+
+
+-CFLAGS += -I$(TOP) -I/usr/local/include -DNDEBUG
++CFLAGS += -I$(TOP) -DNDEBUG
+
+-LIBS := -L/usr/local/lib $(LIBS) -lm
++LIBS := $(LIBS) -lm
+
+ CXXFLAGS = $(CFLAGS)
diff --git a/recipes/roadmap/files/qt/qt2-fixes.patch b/recipes/roadmap/files/qt/qt2-fixes.patch
new file mode 100644
index 0000000000..63c1c96e53
--- /dev/null
+++ b/recipes/roadmap/files/qt/qt2-fixes.patch
@@ -0,0 +1,10 @@
+--- src/qt/Makefile~qt2-fixes.patch
++++ src/qt/Makefile
+@@ -19,7 +19,7 @@
+
+ ifeq ($(DESKTOP),QPE)
+ CFLAGS += -I$(QTDIR)/include -DQWS
+- LIBS += -lqte -lqpe
++ LIBS += -lqpe
+ INSTALLDIR=$(QTDIR)
+ endif
diff --git a/recipes/roadmap/files/qt/qt_canvas.patch b/recipes/roadmap/files/qt/qt_canvas.patch
new file mode 100644
index 0000000000..13c775c8cb
--- /dev/null
+++ b/recipes/roadmap/files/qt/qt_canvas.patch
@@ -0,0 +1,20 @@
+--- src/qt/qt_canvas.cc.old 2007-12-08 20:29:52.000000000 -0600
++++ src/qt/qt_canvas.cc 2007-12-13 02:34:22.000000000 -0600
+@@ -122,7 +122,7 @@ void RMapCanvas::getTextExtents(const ch
+ *w = r.width();
+ *ascent = fm.ascent();
+ *descent = fm.descent();
+-#ifdef QT_NO_ROTATE
++#ifdef QT_NO_TRANSFORMATIONS
+ if (can_tilt) *can_tilt = 0;
+ #else
+ if (can_tilt) *can_tilt = 1;
+@@ -169,7 +169,7 @@ void RMapCanvas::drawString(RoadMapGuiPo
+
+ void RMapCanvas::drawStringAngle(RoadMapGuiPoint* position,
+ int center, const char* text, int angle) {
+-#ifndef QT_NO_ROTATE
++#ifndef QT_NO_TRANSFORMATIONS
+ if (!pixmap) {
+ return;
+ }
diff --git a/recipes/roadmap/files/qt/qt_main.patch b/recipes/roadmap/files/qt/qt_main.patch
new file mode 100644
index 0000000000..2f81128b34
--- /dev/null
+++ b/recipes/roadmap/files/qt/qt_main.patch
@@ -0,0 +1,61 @@
+--- src/qt/qt_main.cc.old 2007-12-08 20:32:34.000000000 -0600
++++ src/qt/qt_main.cc 2007-12-08 20:34:38.000000000 -0600
+@@ -27,6 +27,7 @@
+ #include <signal.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
++#include <unistd.h>
+ #include "qt_main.h"
+
+ static int signalFd[2];
+@@ -168,12 +169,6 @@ void RMapMainWindow::addTool(const char*
+ const char* tip,
+ RoadMapCallback callback) {
+
+-#ifndef QWS
+- // For some unknown reason, this toolbar crashes RoadMap
+- // on the Sharp Zaurus.
+- // This should be fixed and the ifndef removed.
+- // Pascal: I believe this has been fixed now.
+-
+ if (toolBar == 0) {
+ addToolbar("");
+ }
+@@ -193,20 +188,13 @@ void RMapMainWindow::addTool(const char*
+
+ connect(b, SIGNAL(clicked()), cb, SLOT(fire()));
+ }
+-#endif
+ }
+
+ void RMapMainWindow::addToolSpace(void) {
+
+-#ifndef QWS
+- // For some unknown reason, this toolbar crashes RoadMap
+- // on the Sharp Zaurus. This should be fixed and the ifndef
+- // removed.
+-
+ addTool (NULL, NULL, NULL, NULL);
+
+ toolBar->addSeparator();
+-#endif
+ }
+
+
+@@ -299,14 +287,14 @@ void RMapMainWindow::closeEvent(QCloseEv
+
+ void RMapMainWindow::signalHandler(int sig)
+ {
+- ::write(signalFd[0], &sig, sizeof(sig));
++ write(signalFd[0], &sig, sizeof(sig));
+ }
+
+ void RMapMainWindow::handleSignal()
+ {
+ snSignal->setEnabled(false);
+ int tmp;
+- ::read(signalFd[1], &tmp, sizeof(tmp));
++ read(signalFd[1], &tmp, sizeof(tmp));
+ QString action;
+ switch (tmp) {
+ case SIGTERM: action="SIGTERM"; break;
diff --git a/recipes/roadmap/files/qt/roadmap_main.patch b/recipes/roadmap/files/qt/roadmap_main.patch
new file mode 100644
index 0000000000..7b16ce28fc
--- /dev/null
+++ b/recipes/roadmap/files/qt/roadmap_main.patch
@@ -0,0 +1,16 @@
+--- src/qt/roadmap_main.cc.old 2007-12-08 15:47:05.000000000 -0600
++++ src/qt/roadmap_main.cc 2007-12-07 20:39:15.000000000 -0600
+@@ -195,11 +195,11 @@ void roadmap_main_set_cursor (int newcur
+ break;
+
+ case ROADMAP_CURSOR_WAIT:
+- mainWindow->setCursor (QCursor(Qt::WaitCursor));
++ mainWindow->setCursor (QCursor(Qt::waitCursor));
+ break;
+
+ case ROADMAP_CURSOR_CROSS:
+- mainWindow->setCursor (QCursor(Qt::CrossCursor));
++ mainWindow->setCursor (QCursor(Qt::crossCursor));
+ break;
+ }
+ }
diff --git a/recipes/roadmap/files/roadmap.desktop.patch b/recipes/roadmap/files/roadmap.desktop.patch
new file mode 100644
index 0000000000..98d5b06130
--- /dev/null
+++ b/recipes/roadmap/files/roadmap.desktop.patch
@@ -0,0 +1,16 @@
+--- src/roadmap.desktop.old 2007-12-08 23:15:45.000000000 -0600
++++ src/roadmap.desktop 2007-12-08 23:17:48.000000000 -0600
+@@ -1,11 +1,8 @@
+ [Desktop Entry]
+-Comment=RoadMap
+ Comment=Car Navigation System
+ Exec=roadmap
+-Icon=roadmap.png
++Icon=roadmap
+ Type=Application
+ Name=RoadMap
+ GenericName=Map Viewer
+-Categories=Application;Other;VectorGraphics;Graphics;Viewer;GTK;
+-FilePattern=*roadmap;*.rdm
+-
++Categories=VectorGraphics;Graphics;Viewer;GTK;
diff --git a/recipes/roadmap/files/roadmap_path.patch b/recipes/roadmap/files/roadmap_path.patch
new file mode 100644
index 0000000000..7a7ab74261
--- /dev/null
+++ b/recipes/roadmap/files/roadmap_path.patch
@@ -0,0 +1,57 @@
+--- src/unix/roadmap_path.c.old 2008-01-12 21:08:03.000000000 -0600
++++ src/unix/roadmap_path.c 2008-01-12 21:29:40.000000000 -0600
+@@ -93,23 +93,18 @@ static const char *RoadMapPathConfig[] =
+ "/opt/QtPalmtop/share/roadmap",
+ "/mnt/cf/QtPalmtop/share/roadmap",
+ "/mnt/card/QtPalmtop/share/roadmap",
+-#else
++#endif
+ /* This is for standard Unix configurations. */
+ "/etc/roadmap",
+ "/usr/local/share/roadmap",
+ "/usr/share/roadmap",
+-#endif
+ NULL
+ };
+ static const char *RoadMapPathConfigPreferred =
+ #ifdef ROADMAP_CONFIG_DIR
+ ROADMAP_CONFIG_DIR;
+ #else
+-#ifdef QWS
+- "/mnt/cf/QtPalmtop/share/roadmap";
+-#else
+- "/usr/local/share/roadmap";
+-#endif
++ "/usr/share/roadmap";
+ #endif
+
+
+@@ -123,7 +118,7 @@ static const char *RoadMapPathMaps[] = {
+ "/opt/QtPalmtop/share/roadmap/...",
+ "/mnt/cf/QtPalmtop/share/roadmap/...",
+ "/mnt/card/QtPalmtop/share/roadmap/...",
+-#else
++#endif
+ /* This is for standard Unix configurations. */
+ "&/maps/...",
+ "/var/lib/roadmap/...",
+@@ -134,19 +129,14 @@ static const char *RoadMapPathMaps[] = {
+ */
+ "/usr/local/share/roadmap/...",
+ "/usr/share/roadmap/...",
+-#endif
+ NULL
+ };
+ static const char *RoadMapPathMapsPreferred =
+ #ifdef ROADMAP_MAP_DIR
+ ROADMAP_MAP_DIR;
+ #else
+-#ifdef QWS
+- "/mnt/cf/QtPalmtop/share/roadmap";
+-#else
+ "/var/lib/roadmap";
+ #endif
+-#endif
+
+ /* The default path for the icon files (the "icons" path): */
+ static const char *RoadMapPathIcons[] = {
diff --git a/recipes/roadmap/files/zroadgps.png b/recipes/roadmap/files/zroadgps.png
new file mode 100644
index 0000000000..a77b3729b7
--- /dev/null
+++ b/recipes/roadmap/files/zroadgps.png
Binary files differ
diff --git a/recipes/roadmap/roadmap-gtk2.inc b/recipes/roadmap/roadmap-gtk2.inc
new file mode 100644
index 0000000000..6d0db5099b
--- /dev/null
+++ b/recipes/roadmap/roadmap-gtk2.inc
@@ -0,0 +1,11 @@
+require roadmap.inc
+
+SECTION = "x11/applications"
+
+DEPENDS += "agg gtk+"
+
+EXTRA_OEMAKE = "DESKTOP=GTK2 AGG=rgb565 \
+ POPT=NO SCRIPTS= BUILD= INSTALLDIR=/usr DESTDIR=${D} \
+ desktopdir=${D}${datadir}/applications"
+
+CFLAGS += " -I${STAGING_INCDIR}/agg2 "
diff --git a/recipes/roadmap/roadmap-gtk2_1.1.0.bb b/recipes/roadmap/roadmap-gtk2_1.1.0.bb
new file mode 100644
index 0000000000..a4a72a2c8a
--- /dev/null
+++ b/recipes/roadmap/roadmap-gtk2_1.1.0.bb
@@ -0,0 +1,12 @@
+require roadmap-gtk2.inc
+
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/roadmap/roadmap-${PV}-src.tar.gz \
+ file://cross.patch;patch=1;pnum=2 \
+ file://options.mk.patch;patch=1;pnum=2 \
+ file://roadmap_path.patch;patch=1 \
+ file://roadmap.desktop.patch;patch=1 \
+ http://roadmap.digitalomaha.net/maps/usdir.rdm.tar.gz "
+
+S = "${WORKDIR}/roadmap-${PV}/src"
diff --git a/recipes/roadmap/roadmap-gtk2_cvs.bb b/recipes/roadmap/roadmap-gtk2_cvs.bb
new file mode 100644
index 0000000000..9d7adbaa3e
--- /dev/null
+++ b/recipes/roadmap/roadmap-gtk2_cvs.bb
@@ -0,0 +1,13 @@
+require roadmap-gtk2.inc
+
+PV = "0.0+cvs${SRCDATE}"
+PR = "r1"
+
+SRC_URI = "cvs://anonymous:@roadmap.cvs.sf.net/cvsroot/roadmap;module=roadmap \
+ file://cross.patch;patch=1;pnum=2 \
+ file://options.mk.patch;patch=1;pnum=2 \
+ file://roadmap_path.patch;patch=1 \
+ http://roadmap.digitalomaha.net/maps/usdir.rdm.tgz "
+
+S = "${WORKDIR}/roadmap/src"
+
diff --git a/recipes/roadmap/roadmap.inc b/recipes/roadmap/roadmap.inc
new file mode 100644
index 0000000000..d98a7f88df
--- /dev/null
+++ b/recipes/roadmap/roadmap.inc
@@ -0,0 +1,19 @@
+DESCRIPTION = "RoadMap is a program that provides car navigation for Linux and UNIX."
+AUTHOR = "Paul Fox <pgf@foxharp.boston.ma.us>"
+HOMEPAGE = "http://roadmap.digitalomaha.net/maps.html"
+LICENSE = "GPL"
+DEPENDS = "expat"
+
+FILES_${PN} += "${datadir}/roadmap"
+
+do_compile() {
+ oe_runmake runtime ${TOOLS} icons
+}
+
+do_install() {
+ oe_runmake install
+ install -m 0644 ${WORKDIR}/usdir.rdm ${D}${datadir}/roadmap/
+}
+
+RRECOMMENDS = "gpsd flite"
+FILES_${PN} += "${datadir}/roadmap"
diff --git a/recipes/roadmap/zroadmap.inc b/recipes/roadmap/zroadmap.inc
new file mode 100644
index 0000000000..3c99f9d234
--- /dev/null
+++ b/recipes/roadmap/zroadmap.inc
@@ -0,0 +1,23 @@
+require roadmap.inc
+
+PARALLEL_MAKE = ""
+
+SECTION = "opie/applications"
+
+inherit palmtop
+
+QT_LIBRARY = '${@base_conditional("PALMTOP_USE_MULTITHREADED_QT", "yes", "qte-mt", "qte",d)}'
+QT_LIBRARY_append_c7x0 = " -laticore"
+
+EXTRA_OEMAKE = "DESKTOP=QPE MOC=${OE_QMAKE_MOC} UIC=${OE_QMAKE_UIC} QTDIR=${QTDIR} \
+ POPT=NO SCRIPTS= BUILD= INSTALLDIR=/usr DESTDIR=${D} \
+ icondir=${D}${palmtopdir}/pics \
+ desktopdir=${D}${palmtopdir}/apps/Applications \
+ CFLAGS="-DQWS -I${S} ${OE_QMAKE_CFLAGS} -I${OE_QMAKE_INCDIR_QT}" \
+ LDFLAGS="${OE_QMAKE_LDFLAGS} -L${OE_QMAKE_LIBDIR_QT} -Wl,-rpath-link,${OE_QMAKE_LIBDIR_QT}""
+
+do_configure() {
+ echo removing pregenerated stuff
+ find . -name "moc*"|xargs rm -f
+}
+
diff --git a/recipes/roadmap/zroadmap_1.1.0.bb b/recipes/roadmap/zroadmap_1.1.0.bb
new file mode 100644
index 0000000000..b06e4e7ad0
--- /dev/null
+++ b/recipes/roadmap/zroadmap_1.1.0.bb
@@ -0,0 +1,16 @@
+require zroadmap.inc
+
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/roadmap/roadmap-${PV}-src.tar.gz \
+ file://cross.patch;patch=1;pnum=2 \
+ file://options.mk.patch;patch=1;pnum=2 \
+ file://qt/qt2-fixes.patch;patch=1 \
+ file://qt/qt_canvas.patch;patch=1 \
+ file://qt/qt_main.patch;patch=1 \
+ file://qt/roadmap_main.patch;patch=1 \
+ file://roadmap_path.patch;patch=1 \
+ file://roadmap.desktop.patch;patch=1 \
+ http://roadmap.digitalomaha.net/maps/usdir.rdm.tar.gz"
+
+S = "${WORKDIR}/roadmap-${PV}/src"
diff --git a/recipes/roadmap/zroadmap_cvs.bb b/recipes/roadmap/zroadmap_cvs.bb
new file mode 100644
index 0000000000..383ffe8f69
--- /dev/null
+++ b/recipes/roadmap/zroadmap_cvs.bb
@@ -0,0 +1,13 @@
+require zroadmap.inc
+
+PV = "0.0+cvs${SRCDATE}"
+PR = "r0"
+
+SRC_URI = "cvs://anonymous:@roadmap.cvs.sf.net/cvsroot/roadmap;module=roadmap \
+ file://cross.patch;patch=1;pnum=2 \
+ file://options.mk.patch;patch=1;pnum=2 \
+ file://qt/qt2-fixes.patch;patch=1 \
+ file://roadmap_path.patch;patch=1 \
+ http://roadmap.digitalomaha.net/maps/usdir.rdm.tar.gz"
+
+S = "${WORKDIR}/roadmap/src"