aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/robostix-utils/robostix-sertest.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/robostix-utils/robostix-sertest.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/robostix-utils/robostix-sertest.bb')
-rw-r--r--recipes/robostix-utils/robostix-sertest.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/robostix-utils/robostix-sertest.bb b/recipes/robostix-utils/robostix-sertest.bb
new file mode 100644
index 0000000000..0196f6c8f3
--- /dev/null
+++ b/recipes/robostix-utils/robostix-sertest.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "robostix programs"
+SECTION = "base"
+PRIORITY = "required"
+PR = "r1"
+
+DEPENDS = robostix-module
+
+SRC_URI = " \
+ file://sertest.c \
+ "
+
+CMD_NAME=sertest
+LDLIBS = -lpthread
+
+S = "${WORKDIR}"
+
+do_compile () {
+ ${CC} ${LDLIBS} -o ${CMD_NAME} *.c
+}
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 0755 ${WORKDIR}/${CMD_NAME} ${D}${bindir}/
+}
+
+PACKAGES = "${PN}"
+FILES_${PN} = "${bindir}/*"
+