aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/rpm/files/external-tools.patch
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2008-11-19 12:12:37 +0100
committerMarcin Juszkiewicz <hrw@openembedded.org>2009-03-19 20:22:34 +0100
commitaed057419cb98babd0c3856a76222c72c7919a81 (patch)
tree111aef7acd635c1a1addf9548466c92e45d6ca1d /recipes/rpm/files/external-tools.patch
parent47bb0f5ca3d62205703973398d79ed553bed8a4f (diff)
downloadopenembedded-aed057419cb98babd0c3856a76222c72c7919a81.tar.gz
rpm/rpm-native: Add recipe for 4.4.2.3 (from Poky)
Squashed set of changes from Poky: svn r5069 - rpm/rpm-native: Add recipe for 4.4.2.3 svn r5085 - rpm: Patch out some Makefile strangeness causing build failures svn r5093 - rpm: Enable python extensions and improve cross compiling patches svn r5103 - rpm: Tweak patches to remove popt problem svn r5113 - rpm: Add recommends support from suse rpm patches svn r5132 - rpm-native: Set varprefix to get the rpm database in a sane location svn r5152 - rpm: Handle PYTHONVER differently in EXTRA_OECONF to stop gettext/uclibc failures during parsing svn r5154 - rpm: Add missing patches svn r5423 - rpm: Add python module packaging OE changes: rpm-native: add Python 2.6 support rpm: use distutils-base to get Python version rpm: use sed instead of ed - it is present in our metadata rpm: set ARM_INSTRUCTION_SET as it fails to build for thumb | /tmp/ccYO91se.s: Assembler messages: | /tmp/ccYO91se.s:71: Error: selected processor does not support `swpb r2,r3,[r4]' | /tmp/ccYO91se.s:72: Error: unshifted register required -- `eor r2,r2,#1'
Diffstat (limited to 'recipes/rpm/files/external-tools.patch')
-rw-r--r--recipes/rpm/files/external-tools.patch108
1 files changed, 108 insertions, 0 deletions
diff --git a/recipes/rpm/files/external-tools.patch b/recipes/rpm/files/external-tools.patch
new file mode 100644
index 0000000000..2b2ff701ad
--- /dev/null
+++ b/recipes/rpm/files/external-tools.patch
@@ -0,0 +1,108 @@
+Index: rpm-4.4.2.3/configure.ac
+===================================================================
+--- rpm-4.4.2.3.orig/configure.ac 2008-04-01 08:30:14.000000000 +0100
++++ rpm-4.4.2.3/configure.ac 2008-08-17 10:57:30.000000000 +0100
+@@ -529,7 +529,7 @@
+ WITH_MAGIC_INCLUDE=
+ WITH_MAGIC_LIB=
+
+-if test -d file ; then
++if test -d file ; then
+ WITH_RPMFILE=rpmfile
+ WITH_MAGIC_SUBDIR=file
+ WITH_MAGIC_INCLUDE="-I\${top_srcdir}/${WITH_MAGIC_SUBDIR}/src"
+@@ -1307,7 +1307,7 @@
+ dnl # XXX Propagate -lucb to popt ...
+ dnl export LIBS INCPATH CONFIG_SITE
+
+-AC_CONFIG_SUBDIRS(popt file db3)
++AC_CONFIG_SUBDIRS(db/dist file)
+
+ AC_CONFIG_FILES([ Doxyfile Makefile rpmrc macros platform rpmpopt
+ rpmio/Makefile rpmdb/Makefile lib/Makefile build/Makefile
+Index: rpm-4.4.2.3/db/dist/configure.ac
+===================================================================
+--- rpm-4.4.2.3.orig/db/dist/configure.ac 2008-04-01 08:28:21.000000000 +0100
++++ rpm-4.4.2.3/db/dist/configure.ac 2008-08-17 09:54:37.000000000 +0100
+@@ -11,14 +11,6 @@
+ AC_CANONICAL_HOST()
+ AC_ARG_PROGRAM()
+
+-# Don't build in the top-level or dist directories.
+-AC_MSG_CHECKING(if building in the top-level or dist directories)
+-if [ test -d db_archive -o -f configure.ac ] ; then
+- AC_MSG_RESULT(yes)
+- AC_MSG_ERROR(
+- [Berkeley DB should not be built in the top-level or dist directories.])
+-fi
+-AC_MSG_RESULT(no)
+
+ # Substitution variables.
+ AC_SUBST(ADDITIONAL_INCS)
+@@ -281,7 +273,7 @@
+ AC_PROG_LIBTOOL
+
+ SOFLAGS="-rpath \$(libdir)"
+-LIBTOOL_PROG="${SHELL} ./libtool"
++LIBTOOL_PROG="${SHELL} ./$host_alias-libtool"
+
+ # Set SOSUFFIX and friends
+ SOSUFFIX_CONFIG
+@@ -297,7 +289,7 @@
+ MAKEFILE_XSOLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CXXLINK} -avoid-version"
+ MAKEFILE_CXXLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CXXLINK}"
+
+-LIBTOOL="\$(SHELL) ./libtool"
++LIBTOOL="\$(SHELL) ./$host_alias-libtool"
+
+ case "$host_os" in
+ cygwin* | mingw*)
+Index: rpm-4.4.2.3/db/dist/aclocal/options.ac
+===================================================================
+--- rpm-4.4.2.3.orig/db/dist/aclocal/options.ac 2008-08-17 09:57:49.000000000 +0100
++++ rpm-4.4.2.3/db/dist/aclocal/options.ac 2008-08-17 09:57:59.000000000 +0100
+@@ -277,10 +277,6 @@
+
+ # Uniquename excludes C++, Java, RPC.
+ if test "$db_cv_uniquename" = "yes"; then
+- if test "$db_cv_rpc" = "yes"; then
+- AC_MSG_ERROR(
+- [--with-uniquename is not compatible with --enable-rpc])
+- fi
+ if test "$db_cv_cxx" = "yes"; then
+ AC_MSG_ERROR(
+ [--with-uniquename is not compatible with --enable-cxx])
+Index: rpm-4.4.2.3/db/dist/aclocal/rpc.ac
+===================================================================
+--- rpm-4.4.2.3.orig/db/dist/aclocal/rpc.ac 2008-08-17 10:46:26.000000000 +0100
++++ rpm-4.4.2.3/db/dist/aclocal/rpc.ac 2008-08-17 10:46:47.000000000 +0100
+@@ -60,6 +60,7 @@
+ -e 's/^}/__dbsrv_timeout(0);}/' \
+ -e '}' \
+ -e '1,/^#include/s/^#include/#include "db_config.h"\
++#include "db_int_def.h"\
+ &/' > db_server_svc.c
+
+ $RPCGEN -c $XDR_FILE |
+Index: rpm-4.4.2.3/tools/rpmfile.c
+===================================================================
+--- rpm-4.4.2.3.orig/tools/rpmfile.c 2008-08-17 11:01:51.000000000 +0100
++++ rpm-4.4.2.3/tools/rpmfile.c 2008-08-17 11:03:07.000000000 +0100
+@@ -29,7 +29,7 @@
+ * file - find type of a file or files - main program.
+ */
+
+-#include "file.h"
++#include "../file/src/file.h"
+ #include "magic.h"
+
+ #include <stdio.h>
+@@ -69,7 +69,7 @@
+
+ #include <netinet/in.h> /* for byte swapping */
+
+-#include "patchlevel.h"
++#include "../file/src/patchlevel.h"
+
+ #ifndef lint
+ FILE_RCSID("@(#)$Id: file.c,v 1.96 2005/03/06 05:58:22 christos Exp $")