aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/rpm
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/rpm
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/rpm')
-rw-r--r--recipes/rpm/files/cross_libpaths.patch24
-rw-r--r--recipes/rpm/files/fix_mypath.patch13
-rw-r--r--recipes/rpm/rpm_4.4.bb44
3 files changed, 81 insertions, 0 deletions
diff --git a/recipes/rpm/files/cross_libpaths.patch b/recipes/rpm/files/cross_libpaths.patch
new file mode 100644
index 0000000000..d6139dbdde
--- /dev/null
+++ b/recipes/rpm/files/cross_libpaths.patch
@@ -0,0 +1,24 @@
+Index: rpm-4.4/configure.ac
+===================================================================
+--- rpm-4.4.orig/configure.ac 2005-01-29 10:54:37.698359056 -0500
++++ rpm-4.4/configure.ac 2005-01-29 10:55:16.492461456 -0500
+@@ -321,10 +321,8 @@
+
+ localdone=
+
+-dirs=$prefix
+ if test "$cross_compiling" != "yes"; then
+- dirs="$dirs /usr/local"
+-fi
++dirs="$prefix /usr/local"
+ for dir in $dirs
+ do
+ case $dir in
+@@ -366,6 +364,7 @@
+ else
+ AC_MSG_RESULT(no)
+ fi
++fi
+
+ dnl
+ dnl Check for features
diff --git a/recipes/rpm/files/fix_mypath.patch b/recipes/rpm/files/fix_mypath.patch
new file mode 100644
index 0000000000..09512be131
--- /dev/null
+++ b/recipes/rpm/files/fix_mypath.patch
@@ -0,0 +1,13 @@
+Index: rpm-4.4/configure.ac
+===================================================================
+--- rpm-4.4.orig/configure.ac 2005-01-29 10:54:13.599022712 -0500
++++ rpm-4.4/configure.ac 2005-01-29 10:54:37.698359056 -0500
+@@ -230,7 +230,7 @@
+ dnl use defaults if cross-compiling, otherwise use the default path.
+ dnl
+ if test "$cross_compiling" = "yes"; then
+- MYPATH=""
++ MYPATH=":"
+ else
+ # MYPATH="/bin:/usr/bin:/usr/local/bin:$PATH:/sbin:/usr/sbin:/usr/local/sbin:/opt/gnu/bin"
+ MYPATH=$PATH
diff --git a/recipes/rpm/rpm_4.4.bb b/recipes/rpm/rpm_4.4.bb
new file mode 100644
index 0000000000..ff69ddc50f
--- /dev/null
+++ b/recipes/rpm/rpm_4.4.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "The RPM Package Manager."
+HOMEPAGE = "http://rpm.org/"
+LICENSE = "LGPL GPL"
+# NOTE: currently rpm doesn't support using an external popt,
+# file, or virtual/db. FIXME: patch it to support that.
+# DEPENDS = "virtual/db popt file zlib"
+DEPENDS = "zlib"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.jbj.org/pub/rpm-4.4.x/rpm-4.4-1.src.rpm \
+ file://fix_mypath.patch;patch=1 \
+ file://cross_libpaths.patch;patch=1"
+TARBALL = "${WORKDIR}/rpm-4.4.tar.gz"
+
+inherit autotools gettext
+
+acpaths = ""
+# NOTE: currently BROKEN because its internal build of 'file' tries
+# to run the binary it builds. Either switch to an external build,
+# or depend on our file-native and make it call that.
+BROKEN = "1"
+EXTRA_OECONF = "--without-python \
+ --without-apidocs \
+ --without-selinux \
+ --without-lua \
+ --without-dmalloc \
+ --without-efence"
+
+python unpack_again () {
+ import bb, os
+ os.chdir(bb.data.getVar('WORKDIR', d, 1) or '')
+ if not oe_unpack_file(bb.data.expand('${TARBALL}', d), d):
+ raise bb.build.FuncFailed(bb.data.expand("Unable to unpack ${TARBALL}", d))
+}
+
+python do_unpack () {
+ bb.build.exec_func('base_do_unpack', d)
+ bb.build.exec_func('unpack_again', d)
+}
+
+do_configure () {
+ touch db3/configure.ac
+ autotools_do_configure
+}