aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/rsync
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/rsync
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/rsync')
-rw-r--r--recipes/rsync/files/m4.patch33
-rw-r--r--recipes/rsync/files/rsyncd.conf15
-rw-r--r--recipes/rsync/rsync.inc18
-rw-r--r--recipes/rsync/rsync_2.6.9.bb5
-rw-r--r--recipes/rsync/rsync_3.0.0.bb12
5 files changed, 83 insertions, 0 deletions
diff --git a/recipes/rsync/files/m4.patch b/recipes/rsync/files/m4.patch
new file mode 100644
index 0000000000..9279e0e354
--- /dev/null
+++ b/recipes/rsync/files/m4.patch
@@ -0,0 +1,33 @@
+--- /dev/null 2008-03-14 20:41:13.712070199 -0500
++++ rsync-3.0.0/m4/have_type.m4 2008-03-15 03:28:57.000000000 -0500
+@@ -0,0 +1,30 @@
++dnl $Id: have-type.m4 14166 2004-08-26 12:35:42Z joda $
++dnl
++dnl check for existance of a type
++
++dnl AC_HAVE_TYPE(TYPE,INCLUDES)
++AC_DEFUN([AC_HAVE_TYPE], [
++AC_REQUIRE([AC_HEADER_STDC])
++cv=`echo "$1" | sed 'y%./+- %__p__%'`
++AC_MSG_CHECKING(for $1)
++AC_CACHE_VAL([ac_cv_type_$cv],
++AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
++#include <sys/types.h>
++#if STDC_HEADERS
++#include <stdlib.h>
++#include <stddef.h>
++#endif
++$2]],
++[[$1 foo;]])],
++[eval "ac_cv_type_$cv=yes"],
++[eval "ac_cv_type_$cv=no"]))dnl
++ac_foo=`eval echo \\$ac_cv_type_$cv`
++AC_MSG_RESULT($ac_foo)
++if test "$ac_foo" = yes; then
++ ac_tr_hdr=HAVE_`echo $1 | sed 'y%abcdefghijklmnopqrstuvwxyz./- %ABCDEFGHIJKLMNOPQRSTUVWXYZ____%'`
++if false; then
++ AC_CHECK_TYPES($1)
++fi
++ AC_DEFINE_UNQUOTED($ac_tr_hdr, 1, [Define if you have type `$1'])
++fi
++])
diff --git a/recipes/rsync/files/rsyncd.conf b/recipes/rsync/files/rsyncd.conf
new file mode 100644
index 0000000000..845f5b33f5
--- /dev/null
+++ b/recipes/rsync/files/rsyncd.conf
@@ -0,0 +1,15 @@
+# /etc/rsyncd.conf
+
+# Minimal configuration file for rsync daemon
+# See rsync(1) and rsyncd.conf(5) man pages for help
+
+# This file is required by rsync --daemon
+pid file = /var/run/rsyncd.pid
+use chroot = yes
+read only = yes
+
+# Simple example for enabling your own local rsync server
+#[everything]
+# path = /
+# comment = Everything except /etc exposed
+# exclude = /etc
diff --git a/recipes/rsync/rsync.inc b/recipes/rsync/rsync.inc
new file mode 100644
index 0000000000..75f4c46303
--- /dev/null
+++ b/recipes/rsync/rsync.inc
@@ -0,0 +1,18 @@
+DESCRIPTION = "A file-synchronization tool"
+HOMEPAGE = "http://www.samba.org/rsync"
+SECTION = "console/network"
+LICENSE = "GPL"
+PRIORITY = "optional"
+DEPENDS += "popt"
+
+inherit autotools
+
+SRC_URI = "http://rsync.samba.org/ftp/rsync/src/rsync-${PV}.tar.gz"
+
+EXTRA_OEMAKE='STRIP=""'
+
+do_install_append() {
+ install -d ${D}/etc
+ install -m 0644 ${WORKDIR}/rsyncd.conf ${D}/etc
+}
+
diff --git a/recipes/rsync/rsync_2.6.9.bb b/recipes/rsync/rsync_2.6.9.bb
new file mode 100644
index 0000000000..77cb0b2b67
--- /dev/null
+++ b/recipes/rsync/rsync_2.6.9.bb
@@ -0,0 +1,5 @@
+require rsync.inc
+
+PR = "r3"
+
+SRC_URI += "file://rsyncd.conf"
diff --git a/recipes/rsync/rsync_3.0.0.bb b/recipes/rsync/rsync_3.0.0.bb
new file mode 100644
index 0000000000..cd8a986f8f
--- /dev/null
+++ b/recipes/rsync/rsync_3.0.0.bb
@@ -0,0 +1,12 @@
+require rsync.inc
+
+PR = "r1"
+
+SRC_URI += "\
+ file://m4.patch;patch=1 \
+ file://rsyncd.conf \
+"
+
+do_compile_prepend() {
+ sed -i "s/conf_stop make_stop//" Makefile
+}