aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ruby/files/extmk.patch
diff options
context:
space:
mode:
authorJesse Gilles <jgilles@multitech.com>2010-02-15 09:45:58 +0000
committerKhem Raj <raj.khem@gmail.com>2010-03-22 16:43:48 -0700
commit7202fbf2fc9edead3903e108fa25b2bca10c6c68 (patch)
tree05a54333b9d0f57f57b0af7ae870654f818fb9e7 /recipes/ruby/files/extmk.patch
parent74b47226f88e5f99da1512b9c722baf773cacc5a (diff)
downloadopenembedded-7202fbf2fc9edead3903e108fa25b2bca10c6c68.tar.gz
ruby_1.8.7-p248.bb: fix ext/dl compile
* Update ruby library path so extensions needing mkmf can build and find the right ruby headers. Fixes building of ext/dl. Signed-off-by: Jesse Gilles <jgilles@multitech.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/ruby/files/extmk.patch')
-rw-r--r--recipes/ruby/files/extmk.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes/ruby/files/extmk.patch b/recipes/ruby/files/extmk.patch
new file mode 100644
index 0000000000..8b68450341
--- /dev/null
+++ b/recipes/ruby/files/extmk.patch
@@ -0,0 +1,13 @@
+diff -ru ruby-1.8.7-p248.orig/ext/extmk.rb ruby-1.8.7-p248/ext/extmk.rb
+--- ruby-1.8.7-p248.orig/ext/extmk.rb 2009-12-24 03:01:58.000000000 -0600
++++ ruby-1.8.7-p248/ext/extmk.rb 2010-02-12 15:55:27.370061558 -0600
+@@ -354,8 +354,8 @@
+ $ruby = '$(topdir)/miniruby' + EXEEXT
+ end
+ $ruby << " -I'$(topdir)'"
++$ruby << " -I'$(top_srcdir)/lib'"
+ unless CROSS_COMPILING
+- $ruby << " -I'$(top_srcdir)/lib'"
+ $ruby << " -I'$(extout)/$(arch)' -I'$(extout)/common'" if $extout
+ $ruby << " -I./- -I'$(top_srcdir)/ext' -rpurelib.rb"
+ ENV["RUBYLIB"] = "-"