aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ruby
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-24 13:01:00 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:54:52 -0700
commit6fe7cef27069415f2eba36bc640cf59013d4979b (patch)
treeb0cb8845ddc6b8bcffc50e08a2eeae98e049be98 /recipes/ruby
parentbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (diff)
downloadopenembedded-6fe7cef27069415f2eba36bc640cf59013d4979b.tar.gz
Make the do_patch apply=yes param implicit if extension is .diff/.patch
For .diff/.patch you need to apply manually, you can specify apply=no. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/ruby')
-rw-r--r--recipes/ruby/ruby.inc6
-rw-r--r--recipes/ruby/ruby_1.8.7-p248.bb4
2 files changed, 5 insertions, 5 deletions
diff --git a/recipes/ruby/ruby.inc b/recipes/ruby/ruby.inc
index 10acfe84ad..6ef65358fa 100644
--- a/recipes/ruby/ruby.inc
+++ b/recipes/ruby/ruby.inc
@@ -10,9 +10,9 @@ INC_PR = "r1"
SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
SRC_URI = "ftp://ftp.ruby-lang.org/pub/ruby/${SHRT_VER}/ruby-${PV}.tar.gz \
- file://extmk_run.patch;apply=yes \
- file://openssl.patch;apply=yes \
- file://disable_wide_getaddrinfo_check.patch;apply=yes"
+ file://extmk_run.patch \
+ file://openssl.patch \
+ file://disable_wide_getaddrinfo_check.patch"
S = "${WORKDIR}/ruby-${PV}"
diff --git a/recipes/ruby/ruby_1.8.7-p248.bb b/recipes/ruby/ruby_1.8.7-p248.bb
index 6120e3666d..6de359d590 100644
--- a/recipes/ruby/ruby_1.8.7-p248.bb
+++ b/recipes/ruby/ruby_1.8.7-p248.bb
@@ -1,8 +1,8 @@
require ruby.inc
PR = "${INC_PR}.0"
SRC_URI = "ftp://ftp.ruby-lang.org/pub/ruby/${SHRT_VER}/ruby-${PV}.tar.gz \
- file://extmk_run.patch;apply=yes \
- file://extmk.patch;apply=yes \
+ file://extmk_run.patch \
+ file://extmk.patch \
"
FILES_${PN}-dbg += "${libdir}/ruby/1.8/*/.debug \
${libdir}/ruby/1.8/*/*/.debug"