aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ruby
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-03-22 16:51:15 -0700
committerKhem Raj <raj.khem@gmail.com>2010-03-22 16:51:15 -0700
commit814ad5d596f12b089f113256ca8fc9d55c3da046 (patch)
treea735f8726a79df899187b3d7c4125b1e68cf6d61 /recipes/ruby
parent7202fbf2fc9edead3903e108fa25b2bca10c6c68 (diff)
downloadopenembedded-814ad5d596f12b089f113256ca8fc9d55c3da046.tar.gz
ruby: Move to using INC_PR and BBCLASSEXTEND
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/ruby')
-rw-r--r--recipes/ruby/ruby-native_1.8.7-p248.bb3
-rw-r--r--recipes/ruby/ruby.inc2
-rw-r--r--recipes/ruby/ruby_1.8.5.bb2
-rw-r--r--recipes/ruby/ruby_1.8.7-p248.bb3
4 files changed, 5 insertions, 5 deletions
diff --git a/recipes/ruby/ruby-native_1.8.7-p248.bb b/recipes/ruby/ruby-native_1.8.7-p248.bb
deleted file mode 100644
index a20e2544d3..0000000000
--- a/recipes/ruby/ruby-native_1.8.7-p248.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-require ruby_${PV}.bb
-DEPENDS = ""
-inherit native
diff --git a/recipes/ruby/ruby.inc b/recipes/ruby/ruby.inc
index 4fdfdca976..c9bad796b0 100644
--- a/recipes/ruby/ruby.inc
+++ b/recipes/ruby/ruby.inc
@@ -4,6 +4,8 @@ SECTION = "devel/ruby"
PRIORITY = "optional"
LICENSE = "GPL"
+INC_PR = "r1"
+
SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
SRC_URI = "ftp://ftp.ruby-lang.org/pub/ruby/${SHRT_VER}/ruby-${PV}.tar.gz \
file://extmk_run.patch;patch=1 \
diff --git a/recipes/ruby/ruby_1.8.5.bb b/recipes/ruby/ruby_1.8.5.bb
index 6260614772..e1cc3bbdf7 100644
--- a/recipes/ruby/ruby_1.8.5.bb
+++ b/recipes/ruby/ruby_1.8.5.bb
@@ -1,7 +1,7 @@
require ruby.inc
DEPENDS = "ruby-native zlib openssl"
-PR = "r1"
+PR = "${INC_PR}.0"
FILES_${PN}-dbg += "${libdir}/ruby/1.8/*/.debug \
${libdir}/ruby/1.8/*/*/.debug"
diff --git a/recipes/ruby/ruby_1.8.7-p248.bb b/recipes/ruby/ruby_1.8.7-p248.bb
index 827327b3d8..ae660fbbf7 100644
--- a/recipes/ruby/ruby_1.8.7-p248.bb
+++ b/recipes/ruby/ruby_1.8.7-p248.bb
@@ -1,4 +1,5 @@
require ruby.inc
+PR = "${INC_PR}.0"
DEPENDS = "ruby-native zlib openssl"
SRC_URI = "ftp://ftp.ruby-lang.org/pub/ruby/${SHRT_VER}/ruby-${PV}.tar.gz \
file://extmk_run.patch;patch=1 \
@@ -6,4 +7,4 @@ SRC_URI = "ftp://ftp.ruby-lang.org/pub/ruby/${SHRT_VER}/ruby-${PV}.tar.gz \
"
FILES_${PN}-dbg += "${libdir}/ruby/1.8/*/.debug \
${libdir}/ruby/1.8/*/*/.debug"
-
+BBCLASSEXTEND = "native"