aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ruby
diff options
context:
space:
mode:
authorIhar Hrachyshka <ihar.hrachyshka@gmail.com>2009-02-16 03:02:41 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2009-04-03 17:14:05 -0300
commit89eeba8660061aa02248257c4f759930ba610d34 (patch)
treea2abd6f88dbeee64d15c3d38dd31423f423caab1 /recipes/ruby
parentc2f22a74d9aaf4c68820c77ba50fac46565feca9 (diff)
downloadopenembedded-89eeba8660061aa02248257c4f759930ba610d34.tar.gz
ruby-dbus: new recipe
This is a package with D-Bus bindings for Ruby language. Signed-off-by: Ihar Hrachyshka <ihar.hrachyshka@gmail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes/ruby')
-rw-r--r--recipes/ruby/ruby-dbus_0.2.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/ruby/ruby-dbus_0.2.1.bb b/recipes/ruby/ruby-dbus_0.2.1.bb
new file mode 100644
index 0000000000..40627d347b
--- /dev/null
+++ b/recipes/ruby/ruby-dbus_0.2.1.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "${PN} bindings"
+SECTION = "devel/ruby"
+LICENSE = "LGPL"
+RDEPENDS = "dbus ruby"
+
+SRC_URI = "http://trac.luon.net/data/${PN}/releases/${PN}-0.2.1.tar.gz"
+
+RUBY_DIR = "/usr/lib/ruby/1.8"
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+FILES_${PN} += "${RUBY_DIR}"
+
+do_install() {
+ install -d ${D}${RUBY_DIR}
+ cp -r lib/* ${D}${RUBY_DIR}
+}
+