aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ruby
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-23 20:23:53 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:53:41 -0700
commitbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (patch)
tree96f28e2f5133d68c3e3dadabaa2339340671454f /recipes/ruby
parentfab0af3aefee22b21541e403d3c356a6979bfa63 (diff)
downloadopenembedded-bf7d0467a0788a7fcc1c96e0dc35a25ae09278a0.tar.gz
Rename url params patch=<ignored>/pnum=<n> to apply={yes,no}/striplevel=<n>
I think this makes the behavior rather more clear. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/ruby')
-rw-r--r--recipes/ruby/ruby.inc6
-rw-r--r--recipes/ruby/ruby_1.8.7-p248.bb4
2 files changed, 5 insertions, 5 deletions
diff --git a/recipes/ruby/ruby.inc b/recipes/ruby/ruby.inc
index 27316e0a7b..10acfe84ad 100644
--- a/recipes/ruby/ruby.inc
+++ b/recipes/ruby/ruby.inc
@@ -10,9 +10,9 @@ INC_PR = "r1"
SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
SRC_URI = "ftp://ftp.ruby-lang.org/pub/ruby/${SHRT_VER}/ruby-${PV}.tar.gz \
- file://extmk_run.patch;patch=1 \
- file://openssl.patch;patch=1 \
- file://disable_wide_getaddrinfo_check.patch;patch=1"
+ file://extmk_run.patch;apply=yes \
+ file://openssl.patch;apply=yes \
+ file://disable_wide_getaddrinfo_check.patch;apply=yes"
S = "${WORKDIR}/ruby-${PV}"
diff --git a/recipes/ruby/ruby_1.8.7-p248.bb b/recipes/ruby/ruby_1.8.7-p248.bb
index 9b94503361..6120e3666d 100644
--- a/recipes/ruby/ruby_1.8.7-p248.bb
+++ b/recipes/ruby/ruby_1.8.7-p248.bb
@@ -1,8 +1,8 @@
require ruby.inc
PR = "${INC_PR}.0"
SRC_URI = "ftp://ftp.ruby-lang.org/pub/ruby/${SHRT_VER}/ruby-${PV}.tar.gz \
- file://extmk_run.patch;patch=1 \
- file://extmk.patch;patch=1 \
+ file://extmk_run.patch;apply=yes \
+ file://extmk.patch;apply=yes \
"
FILES_${PN}-dbg += "${libdir}/ruby/1.8/*/.debug \
${libdir}/ruby/1.8/*/*/.debug"