summaryrefslogtreecommitdiffstats
path: root/recipes/rxvt-unicode
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/rxvt-unicode
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/rxvt-unicode')
-rw-r--r--recipes/rxvt-unicode/files/makefile.patch20
-rw-r--r--recipes/rxvt-unicode/files/signedchar.patch11
-rw-r--r--recipes/rxvt-unicode/files/xwc.patch28
-rw-r--r--recipes/rxvt-unicode/rxvt-unicode-5.3/xwc.patch24
-rw-r--r--recipes/rxvt-unicode/rxvt-unicode-5.4/xwc.patch24
-rw-r--r--recipes/rxvt-unicode/rxvt-unicode-5.6/xwc.patch24
-rw-r--r--recipes/rxvt-unicode/rxvt-unicode-7.7/xwc.patch23
-rw-r--r--recipes/rxvt-unicode/rxvt-unicode-7.9/xwc.patch23
-rw-r--r--recipes/rxvt-unicode/rxvt-unicode_4.8.bb55
-rw-r--r--recipes/rxvt-unicode/rxvt-unicode_4.9.bb54
-rw-r--r--recipes/rxvt-unicode/rxvt-unicode_5.2.bb53
-rw-r--r--recipes/rxvt-unicode/rxvt-unicode_5.3.bb55
-rw-r--r--recipes/rxvt-unicode/rxvt-unicode_5.4.bb55
-rw-r--r--recipes/rxvt-unicode/rxvt-unicode_5.6.bb59
-rw-r--r--recipes/rxvt-unicode/rxvt-unicode_7.7.bb54
-rw-r--r--recipes/rxvt-unicode/rxvt-unicode_7.9.bb56
-rw-r--r--recipes/rxvt-unicode/rxvt-unicode_cvs.bb58
17 files changed, 676 insertions, 0 deletions
diff --git a/recipes/rxvt-unicode/files/makefile.patch b/recipes/rxvt-unicode/files/makefile.patch
new file mode 100644
index 0000000000..86f82eeb4c
--- /dev/null
+++ b/recipes/rxvt-unicode/files/makefile.patch
@@ -0,0 +1,20 @@
+--- ../rxvt-unicode-cvs-r0/rxvt-unicode/Makefile.in 2004-08-12 22:32:40 +01:00
++++ rxvt-unicode/Makefile.in 2004-12-24 03:09:00 +00:00
+@@ -9,7 +9,7 @@
+ first_rule: all
+ dummy:
+
+-subdirs = src doc src/test
++subdirs = src src/test
+ allsubdirs = W11 $(subdirs)
+
+ DIST = INSTALL README.configure configure Makefile Makefile.in ChangeLog
+@@ -24,7 +24,7 @@
+
+ #-------------------------------------------------------------------------
+
+-all allbin alldoc tags:
++all allbin tags:
+ @if test x@host_os@ = xcygwin; then (cd W11; ${MAKE} $@) || exit 1; fi
+ @for I in ${subdirs}; do (cd $$I; ${MAKE} $@) || exit 1; done
+
diff --git a/recipes/rxvt-unicode/files/signedchar.patch b/recipes/rxvt-unicode/files/signedchar.patch
new file mode 100644
index 0000000000..6faa175143
--- /dev/null
+++ b/recipes/rxvt-unicode/files/signedchar.patch
@@ -0,0 +1,11 @@
+--- ../rxvt-unicode-cvs-r0/rxvt-unicode/src/command.C 2004-12-21 06:43:00 +00:00
++++ rxvt-unicode/src/command.C 2004-12-24 02:31:36 +00:00
+@@ -1862,7 +1862,7 @@
+ #endif /* NO_SCROLLBAR_REPORT */
+
+ {
+- char upordown = 0;
++ signed char upordown = 0;
+
+ if (scrollBar.style == R_SB_NEXT)
+ {
diff --git a/recipes/rxvt-unicode/files/xwc.patch b/recipes/rxvt-unicode/files/xwc.patch
new file mode 100644
index 0000000000..7cf59656ce
--- /dev/null
+++ b/recipes/rxvt-unicode/files/xwc.patch
@@ -0,0 +1,28 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- rxvt-unicode-4.8/src/screen.C~xwc.c
++++ rxvt-unicode-4.8/src/screen.C
+@@ -3058,7 +3058,7 @@
+ else
+ rxvt_warn ("can't get primary selection, ignoring.\n");
+
+-#if 0
++#ifdef HAVE_XWC
+ XTextProperty ct;
+
+ if (XwcTextListToTextProperty (display->display, &selection.text, 1, XStringStyle, &ct) >= 0)
+@@ -3632,9 +3632,11 @@
+ }
+ else
+ #endif
++#ifdef HAVE_XWC
+ if (XwcTextListToTextProperty (display->display, &cl, 1, (XICCEncodingStyle) style, &ct) >= 0)
+ freect = 1;
+ else
++#endif
+ {
+ /* if we failed to convert then send it raw */
+ ct.value = (unsigned char *)cl;
diff --git a/recipes/rxvt-unicode/rxvt-unicode-5.3/xwc.patch b/recipes/rxvt-unicode/rxvt-unicode-5.3/xwc.patch
new file mode 100644
index 0000000000..eb87b84b25
--- /dev/null
+++ b/recipes/rxvt-unicode/rxvt-unicode-5.3/xwc.patch
@@ -0,0 +1,24 @@
+diff -urNd ../rxvt-unicode-5.3-r2/rxvt-unicode-5.3/src/screen.C rxvt-unicode-5.3/src/screen.C
+--- ../rxvt-unicode-5.3-r2/rxvt-unicode-5.3/src/screen.C 2005-02-22 21:39:10 +00:00
++++ rxvt-unicode-5.3/src/screen.C 2005-04-05 22:12:45 +01:00
+@@ -3064,7 +3064,7 @@
+ else
+ rxvt_warn ("can't get primary selection, ignoring.\n");
+
+-#if 0
++#ifdef HAVE_XWC
+ XTextProperty ct;
+
+ if (XwcTextListToTextProperty (display->display, &selection.text, 1, XStringStyle, &ct) >= 0)
+@@ -3648,9 +3648,11 @@
+ }
+ else
+ #endif
++#ifdef HAVE_XWC
+ if (XwcTextListToTextProperty (disp, &cl, 1, (XICCEncodingStyle) style, &ct) >= 0)
+ freect = 1;
+ else
++#endif
+ {
+ /* if we failed to convert then send it raw */
+ ct.value = (unsigned char *)cl;
diff --git a/recipes/rxvt-unicode/rxvt-unicode-5.4/xwc.patch b/recipes/rxvt-unicode/rxvt-unicode-5.4/xwc.patch
new file mode 100644
index 0000000000..eb87b84b25
--- /dev/null
+++ b/recipes/rxvt-unicode/rxvt-unicode-5.4/xwc.patch
@@ -0,0 +1,24 @@
+diff -urNd ../rxvt-unicode-5.3-r2/rxvt-unicode-5.3/src/screen.C rxvt-unicode-5.3/src/screen.C
+--- ../rxvt-unicode-5.3-r2/rxvt-unicode-5.3/src/screen.C 2005-02-22 21:39:10 +00:00
++++ rxvt-unicode-5.3/src/screen.C 2005-04-05 22:12:45 +01:00
+@@ -3064,7 +3064,7 @@
+ else
+ rxvt_warn ("can't get primary selection, ignoring.\n");
+
+-#if 0
++#ifdef HAVE_XWC
+ XTextProperty ct;
+
+ if (XwcTextListToTextProperty (display->display, &selection.text, 1, XStringStyle, &ct) >= 0)
+@@ -3648,9 +3648,11 @@
+ }
+ else
+ #endif
++#ifdef HAVE_XWC
+ if (XwcTextListToTextProperty (disp, &cl, 1, (XICCEncodingStyle) style, &ct) >= 0)
+ freect = 1;
+ else
++#endif
+ {
+ /* if we failed to convert then send it raw */
+ ct.value = (unsigned char *)cl;
diff --git a/recipes/rxvt-unicode/rxvt-unicode-5.6/xwc.patch b/recipes/rxvt-unicode/rxvt-unicode-5.6/xwc.patch
new file mode 100644
index 0000000000..eb87b84b25
--- /dev/null
+++ b/recipes/rxvt-unicode/rxvt-unicode-5.6/xwc.patch
@@ -0,0 +1,24 @@
+diff -urNd ../rxvt-unicode-5.3-r2/rxvt-unicode-5.3/src/screen.C rxvt-unicode-5.3/src/screen.C
+--- ../rxvt-unicode-5.3-r2/rxvt-unicode-5.3/src/screen.C 2005-02-22 21:39:10 +00:00
++++ rxvt-unicode-5.3/src/screen.C 2005-04-05 22:12:45 +01:00
+@@ -3064,7 +3064,7 @@
+ else
+ rxvt_warn ("can't get primary selection, ignoring.\n");
+
+-#if 0
++#ifdef HAVE_XWC
+ XTextProperty ct;
+
+ if (XwcTextListToTextProperty (display->display, &selection.text, 1, XStringStyle, &ct) >= 0)
+@@ -3648,9 +3648,11 @@
+ }
+ else
+ #endif
++#ifdef HAVE_XWC
+ if (XwcTextListToTextProperty (disp, &cl, 1, (XICCEncodingStyle) style, &ct) >= 0)
+ freect = 1;
+ else
++#endif
+ {
+ /* if we failed to convert then send it raw */
+ ct.value = (unsigned char *)cl;
diff --git a/recipes/rxvt-unicode/rxvt-unicode-7.7/xwc.patch b/recipes/rxvt-unicode/rxvt-unicode-7.7/xwc.patch
new file mode 100644
index 0000000000..fbab74aa3d
--- /dev/null
+++ b/recipes/rxvt-unicode/rxvt-unicode-7.7/xwc.patch
@@ -0,0 +1,23 @@
+--- rxvt-unicode-7.7/src/screen.C.orig 2006-05-11 14:48:12.000000000 +0100
++++ rxvt-unicode-7.7/src/screen.C 2006-05-11 14:49:37.000000000 +0100
+@@ -3061,7 +3061,7 @@
+ return false;
+ }
+
+-#if 0
++#if HAVE_XWC
+ XTextProperty ct;
+
+ if (XwcTextListToTextProperty (dpy, &selection.text, 1, XStringStyle, &ct) >= 0)
+@@ -3628,9 +3628,11 @@
+ }
+ else
+ #endif
++#if HAVE_XWC
+ if (XwcTextListToTextProperty (dpy, &cl, 1, (XICCEncodingStyle) style, &ct) >= 0)
+ freect = 1;
+ else
++#endif
+ {
+ /* if we failed to convert then send it raw */
+ ct.value = (unsigned char *)cl;
diff --git a/recipes/rxvt-unicode/rxvt-unicode-7.9/xwc.patch b/recipes/rxvt-unicode/rxvt-unicode-7.9/xwc.patch
new file mode 100644
index 0000000000..fbab74aa3d
--- /dev/null
+++ b/recipes/rxvt-unicode/rxvt-unicode-7.9/xwc.patch
@@ -0,0 +1,23 @@
+--- rxvt-unicode-7.7/src/screen.C.orig 2006-05-11 14:48:12.000000000 +0100
++++ rxvt-unicode-7.7/src/screen.C 2006-05-11 14:49:37.000000000 +0100
+@@ -3061,7 +3061,7 @@
+ return false;
+ }
+
+-#if 0
++#if HAVE_XWC
+ XTextProperty ct;
+
+ if (XwcTextListToTextProperty (dpy, &selection.text, 1, XStringStyle, &ct) >= 0)
+@@ -3628,9 +3628,11 @@
+ }
+ else
+ #endif
++#if HAVE_XWC
+ if (XwcTextListToTextProperty (dpy, &cl, 1, (XICCEncodingStyle) style, &ct) >= 0)
+ freect = 1;
+ else
++#endif
+ {
+ /* if we failed to convert then send it raw */
+ ct.value = (unsigned char *)cl;
diff --git a/recipes/rxvt-unicode/rxvt-unicode_4.8.bb b/recipes/rxvt-unicode/rxvt-unicode_4.8.bb
new file mode 100644
index 0000000000..3b96243b77
--- /dev/null
+++ b/recipes/rxvt-unicode/rxvt-unicode_4.8.bb
@@ -0,0 +1,55 @@
+SECTION = "x11/utils"
+DEPENDS = "virtual/libx11 libxt libxft"
+DESCRIPTION = "rxvt-unicode is a clone of the well known \
+terminal emulator rxvt, modified to store text in Unicode \
+(either UCS-2 or UCS-4) and to use locale-correct input and \
+output. It also supports mixing multiple fonts at the \
+same time, including Xft fonts."
+PR = "r2"
+LICENSE = "GPL"
+SRC_URI = "http://dist.schmorp.de/rxvt-unicode/Attic/rxvt-unicode-${PV}.tar.bz2 \
+ file://xwc.patch;patch=1 \
+ file://signedchar.patch;patch=1"
+
+inherit autotools update-alternatives
+
+PROVIDES = "virtual/x-terminal-emulator"
+ALTERNATIVE_NAME = "x-terminal-emulator"
+ALTERNATIVE_PATH = "${bindir}/rxvt"
+
+CFLAGS_append = " -fpermissive"
+
+EXTRA_OECONF = "--enable-menubar --enable-xim \
+ --enable-utmp --enable-wtmp --enable-lastlog \
+ --disable-strings --with-term=rxvt --enable-keepscrolling \
+ --enable-xft --with-name=rxvt --enable-frills \
+ --enable-swapscreen --enable-transparency \
+ --with-codesets=eu \
+ --enable-cursor-blink --enable-pointer-blank \
+ --enable-text-blink --enable-plain-scroll \
+ --enable-combining --enable-shared \
+ --enable-xgetdefault \
+ --with-x=${STAGING_LIBDIR}/.."
+EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
+ 'XLIB=-L${STAGING_LIBDIR} -lX11'"
+
+do_configure () {
+ mv autoconf/configure.in . || true
+ rm autoconf/libtool.m4
+ libtoolize --force
+ autotools_do_configure
+ echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
+ echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
+ echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
+ echo '#define HAVE_XLOCALE 1' >> config.h
+}
+
+do_compile () {
+ if test -e ${S}/${HOST_SYS}-libtool; then
+ LIBTOOL=${S}/${HOST_SYS}-libtool
+ else
+ LIBTOOL=${S}/libtool
+ fi
+ # docs need "yodl" and I have no idea what that is
+ oe_runmake -C src "LIBTOOL=$LIBTOOL"
+}
diff --git a/recipes/rxvt-unicode/rxvt-unicode_4.9.bb b/recipes/rxvt-unicode/rxvt-unicode_4.9.bb
new file mode 100644
index 0000000000..d7c5b4c705
--- /dev/null
+++ b/recipes/rxvt-unicode/rxvt-unicode_4.9.bb
@@ -0,0 +1,54 @@
+SECTION = "x11/utils"
+DEPENDS = "virtual/libx11 libxt libxft"
+DESCRIPTION = "rxvt-unicode is a clone of the well known \
+terminal emulator rxvt, modified to store text in Unicode \
+(either UCS-2 or UCS-4) and to use locale-correct input and \
+output. It also supports mixing multiple fonts at the \
+same time, including Xft fonts."
+LICENSE = "GPL"
+SRC_URI = "http://dist.schmorp.de/rxvt-unicode/Attic/rxvt-unicode-${PV}.tar.bz2 \
+ file://xwc.patch;patch=1 \
+ file://signedchar.patch;patch=1"
+
+inherit autotools update-alternatives
+
+PROVIDES = "virtual/x-terminal-emulator"
+ALTERNATIVE_NAME = "x-terminal-emulator"
+ALTERNATIVE_PATH = "${bindir}/rxvt"
+
+CFLAGS_append = " -fpermissive"
+
+EXTRA_OECONF = "--enable-menubar --enable-xim \
+ --enable-utmp --enable-wtmp --enable-lastlog \
+ --disable-strings --with-term=rxvt --enable-keepscrolling \
+ --enable-xft --with-name=rxvt --enable-frills \
+ --enable-swapscreen --enable-transparency \
+ --with-codesets=eu \
+ --enable-cursor-blink --enable-pointer-blank \
+ --enable-text-blink --enable-plain-scroll \
+ --enable-combining --enable-shared \
+ --enable-xgetdefault \
+ --with-x=${STAGING_LIBDIR}/.."
+EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
+ 'XLIB=-L${STAGING_LIBDIR} -lX11'"
+
+do_configure () {
+ mv autoconf/configure.in . || true
+ rm autoconf/libtool.m4
+ libtoolize --force
+ autotools_do_configure
+ echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
+ echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
+ echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
+ echo '#define HAVE_XLOCALE 1' >> config.h
+}
+
+do_compile () {
+ if test -e ${S}/${HOST_SYS}-libtool; then
+ LIBTOOL=${S}/${HOST_SYS}-libtool
+ else
+ LIBTOOL=${S}/libtool
+ fi
+ # docs need "yodl" and I have no idea what that is
+ oe_runmake -C src "LIBTOOL=$LIBTOOL"
+}
diff --git a/recipes/rxvt-unicode/rxvt-unicode_5.2.bb b/recipes/rxvt-unicode/rxvt-unicode_5.2.bb
new file mode 100644
index 0000000000..966f006178
--- /dev/null
+++ b/recipes/rxvt-unicode/rxvt-unicode_5.2.bb
@@ -0,0 +1,53 @@
+SECTION = "x11/utils"
+DEPENDS = "virtual/libx11 libxt libxft"
+DESCRIPTION = "rxvt-unicode is a clone of the well known \
+terminal emulator rxvt, modified to store text in Unicode \
+(either UCS-2 or UCS-4) and to use locale-correct input and \
+output. It also supports mixing multiple fonts at the \
+same time, including Xft fonts."
+LICENSE = "GPL"
+SRC_URI = "http://dist.schmorp.de/rxvt-unicode/rxvt-unicode-${PV}.tar.bz2 \
+ file://signedchar.patch;patch=1"
+
+inherit autotools update-alternatives
+
+PROVIDES = "virtual/x-terminal-emulator"
+ALTERNATIVE_NAME = "x-terminal-emulator"
+ALTERNATIVE_PATH = "${bindir}/rxvt"
+
+CFLAGS_append = " -fpermissive"
+
+EXTRA_OECONF = "--enable-menubar --enable-xim \
+ --enable-utmp --enable-wtmp --enable-lastlog \
+ --disable-strings --with-term=rxvt --enable-keepscrolling \
+ --enable-xft --with-name=rxvt --enable-frills \
+ --enable-swapscreen --enable-transparency \
+ --with-codesets=eu \
+ --enable-cursor-blink --enable-pointer-blank \
+ --enable-text-blink --enable-plain-scroll \
+ --enable-combining --enable-shared \
+ --enable-xgetdefault \
+ --with-x=${STAGING_LIBDIR}/.."
+EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
+ 'XLIB=-L${STAGING_LIBDIR} -lX11'"
+
+do_configure () {
+ mv autoconf/configure.in . || true
+ rm autoconf/libtool.m4
+ libtoolize --force
+ autotools_do_configure
+ echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
+ echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
+ echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
+ echo '#define HAVE_XLOCALE 1' >> config.h
+}
+
+do_compile () {
+ if test -e ${S}/${HOST_SYS}-libtool; then
+ LIBTOOL=${S}/${HOST_SYS}-libtool
+ else
+ LIBTOOL=${S}/libtool
+ fi
+ # docs need "yodl" and I have no idea what that is
+ oe_runmake -C src "LIBTOOL=$LIBTOOL"
+}
diff --git a/recipes/rxvt-unicode/rxvt-unicode_5.3.bb b/recipes/rxvt-unicode/rxvt-unicode_5.3.bb
new file mode 100644
index 0000000000..b3f261818c
--- /dev/null
+++ b/recipes/rxvt-unicode/rxvt-unicode_5.3.bb
@@ -0,0 +1,55 @@
+SECTION = "x11/utils"
+DEPENDS = "virtual/libx11 libxt libxft"
+DESCRIPTION = "rxvt-unicode is a clone of the well known \
+terminal emulator rxvt, modified to store text in Unicode \
+(either UCS-2 or UCS-4) and to use locale-correct input and \
+output. It also supports mixing multiple fonts at the \
+same time, including Xft fonts."
+LICENSE = "GPL"
+SRC_URI = "http://dist.schmorp.de/rxvt-unicode/Attic/rxvt-unicode-${PV}.tar.bz2 \
+ file://xwc.patch;patch=1 \
+ file://signedchar.patch;patch=1"
+PR = "r2"
+
+inherit autotools update-alternatives
+
+PROVIDES = "virtual/x-terminal-emulator"
+ALTERNATIVE_NAME = "x-terminal-emulator"
+ALTERNATIVE_PATH = "${bindir}/rxvt"
+
+CFLAGS_append = " -fpermissive"
+
+EXTRA_OECONF = "--enable-menubar --enable-xim \
+ --enable-utmp --enable-wtmp --enable-lastlog \
+ --disable-strings --with-term=rxvt --enable-keepscrolling \
+ --enable-xft --with-name=rxvt --enable-frills \
+ --enable-swapscreen --enable-transparency \
+ --with-codesets=eu \
+ --enable-cursor-blink --enable-pointer-blank \
+ --enable-text-blink --enable-rxvt-scroll \
+ --enable-combining --enable-shared \
+ --enable-xgetdefault \
+ --with-x=${STAGING_LIBDIR}/.."
+EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
+ 'XLIB=-L${STAGING_LIBDIR} -lX11'"
+
+do_configure () {
+ mv autoconf/configure.in . || true
+ rm autoconf/libtool.m4
+ libtoolize --force
+ autotools_do_configure
+ echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
+ echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
+ echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
+ echo '#define HAVE_XLOCALE 1' >> config.h
+}
+
+do_compile () {
+ if test -e ${S}/${HOST_SYS}-libtool; then
+ LIBTOOL=${S}/${HOST_SYS}-libtool
+ else
+ LIBTOOL=${S}/libtool
+ fi
+ # docs need "yodl" and I have no idea what that is
+ oe_runmake -C src "LIBTOOL=$LIBTOOL"
+}
diff --git a/recipes/rxvt-unicode/rxvt-unicode_5.4.bb b/recipes/rxvt-unicode/rxvt-unicode_5.4.bb
new file mode 100644
index 0000000000..b3f261818c
--- /dev/null
+++ b/recipes/rxvt-unicode/rxvt-unicode_5.4.bb
@@ -0,0 +1,55 @@
+SECTION = "x11/utils"
+DEPENDS = "virtual/libx11 libxt libxft"
+DESCRIPTION = "rxvt-unicode is a clone of the well known \
+terminal emulator rxvt, modified to store text in Unicode \
+(either UCS-2 or UCS-4) and to use locale-correct input and \
+output. It also supports mixing multiple fonts at the \
+same time, including Xft fonts."
+LICENSE = "GPL"
+SRC_URI = "http://dist.schmorp.de/rxvt-unicode/Attic/rxvt-unicode-${PV}.tar.bz2 \
+ file://xwc.patch;patch=1 \
+ file://signedchar.patch;patch=1"
+PR = "r2"
+
+inherit autotools update-alternatives
+
+PROVIDES = "virtual/x-terminal-emulator"
+ALTERNATIVE_NAME = "x-terminal-emulator"
+ALTERNATIVE_PATH = "${bindir}/rxvt"
+
+CFLAGS_append = " -fpermissive"
+
+EXTRA_OECONF = "--enable-menubar --enable-xim \
+ --enable-utmp --enable-wtmp --enable-lastlog \
+ --disable-strings --with-term=rxvt --enable-keepscrolling \
+ --enable-xft --with-name=rxvt --enable-frills \
+ --enable-swapscreen --enable-transparency \
+ --with-codesets=eu \
+ --enable-cursor-blink --enable-pointer-blank \
+ --enable-text-blink --enable-rxvt-scroll \
+ --enable-combining --enable-shared \
+ --enable-xgetdefault \
+ --with-x=${STAGING_LIBDIR}/.."
+EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
+ 'XLIB=-L${STAGING_LIBDIR} -lX11'"
+
+do_configure () {
+ mv autoconf/configure.in . || true
+ rm autoconf/libtool.m4
+ libtoolize --force
+ autotools_do_configure
+ echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
+ echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
+ echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
+ echo '#define HAVE_XLOCALE 1' >> config.h
+}
+
+do_compile () {
+ if test -e ${S}/${HOST_SYS}-libtool; then
+ LIBTOOL=${S}/${HOST_SYS}-libtool
+ else
+ LIBTOOL=${S}/libtool
+ fi
+ # docs need "yodl" and I have no idea what that is
+ oe_runmake -C src "LIBTOOL=$LIBTOOL"
+}
diff --git a/recipes/rxvt-unicode/rxvt-unicode_5.6.bb b/recipes/rxvt-unicode/rxvt-unicode_5.6.bb
new file mode 100644
index 0000000000..f9ba2bedde
--- /dev/null
+++ b/recipes/rxvt-unicode/rxvt-unicode_5.6.bb
@@ -0,0 +1,59 @@
+SECTION = "x11/utils"
+DEPENDS = "virtual/libx11 libxt libxft"
+DESCRIPTION = "rxvt-unicode is a clone of the well known \
+terminal emulator rxvt, modified to store text in Unicode \
+(either UCS-2 or UCS-4) and to use locale-correct input and \
+output. It also supports mixing multiple fonts at the \
+same time, including Xft fonts."
+LICENSE = "GPL"
+PACKAGES =+ "${PN}-daemon ${PN}-control"
+FILES_${PN}-daemon = "${bindir}/rxvtd"
+FILES_${PN}-control = "${bindir}/rxvtc"
+
+SRC_URI = "http://dist.schmorp.de/rxvt-unicode/Attic/rxvt-unicode-${PV}.tar.bz2 \
+ file://xwc.patch;patch=1 \
+ file://signedchar.patch;patch=1"
+PR = "r3"
+
+inherit autotools update-alternatives
+
+PROVIDES = "virtual/x-terminal-emulator"
+ALTERNATIVE_NAME = "x-terminal-emulator"
+ALTERNATIVE_PATH = "${bindir}/rxvt"
+
+CFLAGS_append = " -fpermissive"
+
+EXTRA_OECONF = "--enable-menubar --enable-xim \
+ --enable-utmp --enable-wtmp --enable-lastlog \
+ --disable-strings --with-term=rxvt --enable-keepscrolling \
+ --enable-xft --with-name=rxvt --enable-frills \
+ --enable-swapscreen --enable-transparency \
+ --with-codesets=eu \
+ --enable-cursor-blink --enable-pointer-blank \
+ --enable-text-blink --enable-rxvt-scroll \
+ --enable-combining --enable-shared \
+ --enable-xgetdefault \
+ --with-x=${STAGING_LIBDIR}/.."
+EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
+ 'XLIB=-L${STAGING_LIBDIR} -lX11'"
+
+do_configure () {
+ mv autoconf/configure.in . || true
+ rm autoconf/libtool.m4
+ libtoolize --force
+ autotools_do_configure
+ echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
+ echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
+ echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
+ echo '#define HAVE_XLOCALE 1' >> config.h
+}
+
+do_compile () {
+ if test -e ${S}/${HOST_SYS}-libtool; then
+ LIBTOOL=${S}/${HOST_SYS}-libtool
+ else
+ LIBTOOL=${S}/libtool
+ fi
+ # docs need "yodl" and I have no idea what that is
+ oe_runmake -C src "LIBTOOL=$LIBTOOL"
+}
diff --git a/recipes/rxvt-unicode/rxvt-unicode_7.7.bb b/recipes/rxvt-unicode/rxvt-unicode_7.7.bb
new file mode 100644
index 0000000000..f80984bc7a
--- /dev/null
+++ b/recipes/rxvt-unicode/rxvt-unicode_7.7.bb
@@ -0,0 +1,54 @@
+SECTION = "x11/utils"
+DEPENDS = "virtual/libx11 libxt libxft libxpm"
+DESCRIPTION = "rxvt-unicode is a clone of the well known \
+terminal emulator rxvt, modified to store text in Unicode \
+(either UCS-2 or UCS-4) and to use locale-correct input and \
+output. It also supports mixing multiple fonts at the \
+same time, including Xft fonts."
+LICENSE = "GPL"
+PACKAGES =+ "${PN}-daemon ${PN}-control"
+FILES_${PN}-daemon = "${bindir}/rxvtd"
+FILES_${PN}-control = "${bindir}/rxvtc"
+
+SRC_URI = "http://dist.schmorp.de/rxvt-unicode/Attic/rxvt-unicode-${PV}.tar.bz2 \
+ file://xwc.patch;patch=1 \
+ file://signedchar.patch;patch=1"
+PR = "r0"
+
+DEFAULT_PREFERENCE = "-1"
+
+inherit autotools update-alternatives
+
+PROVIDES = "virtual/x-terminal-emulator"
+ALTERNATIVE_NAME = "x-terminal-emulator"
+ALTERNATIVE_PATH = "${bindir}/rxvt"
+
+CFLAGS_append = " -fpermissive"
+
+EXTRA_OECONF = "--enable-menubar --enable-xim \
+ --enable-utmp --enable-wtmp --enable-lastlog \
+ --disable-strings --with-term=rxvt --enable-keepscrolling \
+ --enable-xft --with-name=rxvt --enable-frills \
+ --enable-swapscreen --enable-transparency \
+ --with-codesets=eu \
+ --enable-cursor-blink --enable-pointer-blank \
+ --enable-text-blink --enable-rxvt-scroll \
+ --enable-combining --enable-shared \
+ --enable-xgetdefault \
+ --with-x=${STAGING_LIBDIR}/.. \
+ --enable-xpm-background \
+ --disable-perl \
+ --with-xpm-includes=${STAGING_INCDIR} \
+ --with-xpm-libs=${STAGING_LIBDIR}"
+
+do_configure_prepend () {
+ cp aclocal.m4 acinclude.m4
+}
+
+do_compile_prepend () {
+ echo '#define UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
+ echo '#define WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
+ echo '#define LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
+ echo '#define HAVE_XLOCALE 1' >> config.h
+}
+
diff --git a/recipes/rxvt-unicode/rxvt-unicode_7.9.bb b/recipes/rxvt-unicode/rxvt-unicode_7.9.bb
new file mode 100644
index 0000000000..e08583527c
--- /dev/null
+++ b/recipes/rxvt-unicode/rxvt-unicode_7.9.bb
@@ -0,0 +1,56 @@
+SECTION = "x11/utils"
+DEPENDS = "virtual/libx11 libxt libxft libxpm"
+DESCRIPTION = "rxvt-unicode is a clone of the well known \
+terminal emulator rxvt, modified to store text in Unicode \
+(either UCS-2 or UCS-4) and to use locale-correct input and \
+output. It also supports mixing multiple fonts at the \
+same time, including Xft fonts."
+LICENSE = "GPL"
+PACKAGES =+ "${PN}-daemon ${PN}-control"
+FILES_${PN}-daemon = "${bindir}/rxvtd"
+FILES_${PN}-control = "${bindir}/rxvtc"
+
+SRC_URI = "http://dist.schmorp.de/rxvt-unicode/Attic/rxvt-unicode-${PV}.tar.bz2 \
+ file://xwc.patch;patch=1 \
+ file://signedchar.patch;patch=1"
+PR = "r1"
+
+inherit autotools update-alternatives
+
+PROVIDES = "virtual/x-terminal-emulator"
+ALTERNATIVE_NAME = "x-terminal-emulator"
+ALTERNATIVE_PATH = "${bindir}/rxvt"
+
+CFLAGS_append = " -fpermissive"
+
+# This is necessary so that the "tic" command executed during the install can
+# link with the correct libary in staging.
+export LD_LIBRARY_PATH = "${STAGING_LIBDIR_NATIVE}"
+
+EXTRA_OECONF = "--enable-menubar --enable-xim \
+ --enable-utmp --enable-wtmp --enable-lastlog \
+ --disable-strings --with-term=rxvt --enable-keepscrolling \
+ --enable-xft --with-name=rxvt --enable-frills \
+ --enable-swapscreen --enable-transparency \
+ --with-codesets=eu \
+ --enable-cursor-blink --enable-pointer-blank \
+ --enable-text-blink --enable-rxvt-scroll \
+ --enable-combining --enable-shared \
+ --enable-xgetdefault \
+ --with-x=${STAGING_LIBDIR}/.. \
+ --enable-xpm-background \
+ --disable-perl \
+ --with-xpm-includes=${STAGING_INCDIR} \
+ --with-xpm-libs=${STAGING_LIBDIR}"
+
+do_configure_prepend () {
+ cp aclocal.m4 acinclude.m4
+}
+
+do_compile_prepend () {
+ echo '#define UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
+ echo '#define WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
+ echo '#define LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
+ echo '#define HAVE_XLOCALE 1' >> config.h
+}
+
diff --git a/recipes/rxvt-unicode/rxvt-unicode_cvs.bb b/recipes/rxvt-unicode/rxvt-unicode_cvs.bb
new file mode 100644
index 0000000000..0ee35f78c8
--- /dev/null
+++ b/recipes/rxvt-unicode/rxvt-unicode_cvs.bb
@@ -0,0 +1,58 @@
+SECTION = "x11/utils"
+DEPENDS = "virtual/libx11 libxt libxft"
+DESCRIPTION = "rxvt-unicode is a clone of the well known \
+terminal emulator rxvt, modified to store text in Unicode \
+(either UCS-2 or UCS-4) and to use locale-correct input and \
+output. It also supports mixing multiple fonts at the \
+same time, including Xft fonts."
+DEFAULT_PREFERENCE = "-1"
+LICENSE = "GPL"
+SRC_URI = "cvs://anonymous@cvs.schmorp.de/schmorpforge;module=rxvt-unicode;port=636 \
+ file://xwc.patch;patch=1 \
+ file://signedchar.patch;patch=1 \
+ file://makefile.patch;patch=1"
+
+inherit autotools update-alternatives
+
+PROVIDES = "virtual/x-terminal-emulator"
+ALTERNATIVE_NAME = "x-terminal-emulator"
+ALTERNATIVE_PATH = "${bindir}/rxvt"
+
+S = "${WORKDIR}/rxvt-unicode"
+
+CFLAGS_append = " -fpermissive"
+
+EXTRA_OECONF = "--enable-menubar --enable-xim \
+ --enable-utmp --enable-wtmp --enable-lastlog \
+ --disable-strings --with-term=rxvt --enable-keepscrolling \
+ --enable-xft --with-name=rxvt --enable-frills \
+ --enable-swapscreen --enable-transparency \
+ --with-codesets=eu,jp \
+ --enable-cursor-blink --enable-pointer-blank \
+ --enable-text-blink --enable-plain-scroll \
+ --enable-combining --enable-shared \
+ --enable-xgetdefault \
+ --with-x=${STAGING_LIBDIR}/.."
+EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
+ 'XLIB=-L${STAGING_LIBDIR} -lX11'"
+
+do_configure () {
+ mv autoconf/configure.in . || true
+ rm autoconf/libtool.m4
+ libtoolize --force
+ autotools_do_configure
+ echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
+ echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
+ echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
+ echo '#define HAVE_XLOCALE 1' >> config.h
+}
+
+do_compile () {
+ if test -e ${S}/${HOST_SYS}-libtool; then
+ LIBTOOL=${S}/${HOST_SYS}-libtool
+ else
+ LIBTOOL=${S}/libtool
+ fi
+ # docs need "yodl" and I have no idea what that is
+ oe_runmake -C src "LIBTOOL=$LIBTOOL"
+}